Jump to content





Updated assembly-6502 and batari BASIC mode files

Posted by SpiceWare, in batari BASIC, jEdit 28 September 2014 · 1,517 views

DPC+ registers have been added to the assembly-6502.xml mode file for 2600 development.
 
The zero and hex problems have been fixed and DPC+ registers have been added to the batari BASIC.xml mode file.
 
See the prior blog entry for how to add the mode files.  The assembly entry for the catalog file is:

 
<MODE NAME="assembly-6502"      FILE="assembly-6502.xml"
                                FILE_NAME_GLOB="*.asm"
                                FIRST_LINE_GLOB="*PROCESSOR 6502*"/> 
 
Mode files:
Attached File  assembly-6502.xml.20140928.zip (2.83KB)
downloads: 152
Attached File  batari BASIC.xml.20140928.zip (3.15KB)
downloads: 141
 
 
Catalog file, for reference:
Attached File  catalog.zip (801bytes)
downloads: 131




Thanks to some prodding by iesposta, I figured out how to use jEdit to compile assembly code and run the resulting bin via Stella!

 

I'll post a blog entry detailing the configuration changes in the next day or two.

  • Report

I got Stella to launch my bin by using this:

/Applications/Stella.app/Contents/MacOS/Stella $f.bin

  • Report

I have a question, though I've done this in linux now I'm trying it on windows but I can't get the batari Basic mode file to work and instead it shows vbscript, am I the only that has had this problem?

  • Report
In jEdit do this:
  • Select Utilities menu

  • Select jEdit Home Directory submenu

  • Select Modes menu entry

  • Select catalog from the list of files

  • Locate the following lines:
    <MODE NAME="vbscript" FILE="vbscript.xml"
    FILE_NAME_GLOB="*.{vbs,bas,cls}" />

  • then either change it to this to disable vbscript recognition:
    <!-- MODE NAME="vbscript" FILE="vbscript.xml"
    FILE_NAME_GLOB="*.{vbs,bas,cls}" / -->

  • or change it to this to disable just the recognition of bas files as vbscript:
    <MODE NAME="vbscript" FILE="vbscript.xml"
    FILE_NAME_GLOB="*.{vbs,cls}" />

You'll probably need to quit/rerun jEdit after saving the change.
  • Report

Search My Blog

Recent Entries

Recent Comments

Latest Visitors

3 user(s) viewing

0 members, 3 guests, 0 anonymous users