Jump to content

Photo

PSP Mame4all ? how do I get it to work?


4 replies to this topic

#1 mimo OFFLINE  

mimo

    Preppie!

  • 6,802 posts
  • It's easy living in a bubble

Posted Wed Oct 15, 2008 10:29 AM

Heeeeeeeeeeeeeeeeeeeeelp

I can usually figure out how to get emulators to work, but this one has thrown me.

PSP fat CFW 4.01-m33
trying to get PSP MAME4ALL v4.9r1 Hires by TTYman - 05112007 working

Not sure If I have my PSP set up correctly for 1.5

#2 Underball OFFLINE  

Underball

    Stargunner

  • 1,507 posts

Posted Wed Oct 15, 2008 11:02 AM

Heeeeeeeeeeeeeeeeeeeeelp

I can usually figure out how to get emulators to work, but this one has thrown me.

PSP fat CFW 4.01-m33
trying to get PSP MAME4ALL v4.9r1 Hires by TTYman - 05112007 working

Not sure If I have my PSP set up correctly for 1.5

create a new folder on your memstick called ms0:\PSP\GAME150 and place the MAMe4all folder, etc. in it.

MAME4allPSP won't run under the 4.01 kernel. So you need to create a separate GAME150 folder for all your games that need to run under 150 Kernel.

PSPfiler requires this as well. Some older homebrews like this require the 1.50 Kernel, so you need to either: create a GAME150 folder next to the GAME folder and place these 1.50 only games in it, or in the recovery menu - enable the 1.50 Kernel as the default - in which case you don't need the extra GAME150 folder, but some newer games might not run right under the 1.50 Kernel as the default.

#3 Buzbard OFFLINE  

Buzbard

    Chopper Commander

  • 224 posts
  • Rhindle & Grundle go to White Castle.
  • Location:Washington State

Posted Wed Oct 15, 2008 1:17 PM

I have both a PSP Phat & slim with 4.01m33 on both.
I have MAME4ALL v4.9r2 16112007 and it works fine on both.
I don't think you need the 1.5 firmware to run it.

After downloading, inside the zip you'll find 4 files, unzip the one named: PSP_MAME4ALL_v4.9r2_Hires_by_TTYman_-_16112007.zip
Inside there you'll see a folder named: psp_mame4all_v4.9r2
Copy it and all subfolders to you PSP memory stick in the GAME4xx folder
Now go back and find the folder named: psp_mame4all_v4.9r2-usermode
use the eboot.pbp file in that folder to replace the one you just copied to the memorystick in the mame4all folder.

The roms need to be zipped and in the MAME 0.34 format since mame4all is base on v0.34

#4 mimo OFFLINE  

mimo

    Preppie!

  • Topic Starter
  • 6,802 posts
  • It's easy living in a bubble

Posted Wed Oct 15, 2008 5:00 PM

Thanks, up and running now. A corrupted memory card did not help :skull:

#5 Nebulon OFFLINE  

Nebulon

    Stargunner

  • 1,591 posts

Posted Sat May 27, 2017 9:52 PM

I'm usually the one giving people instructions on how to get MAME running. Looks like I've met my match with the PSP version of MAME. 

 

I am also stuck and I've tried just about everything. Any ideas? 

 

I've tried both "PSP MAME 0.4" and "PSP MAME 4 ALL v 4.9 r1"

 

The PSP I'm using is a fat model (i.e. PSP 1000). It's running a modded version of 6.39 (since the PSP I have came with 6.39 installed).

 

ROMs are zipped and in 0.34 format. 

 

The EBOOT.PBP executable is in the GAME directory. 

 

I tried the GAME105 folder as well, but nothing that I put in that folder ever shows up on the PSP's file list. 

 

As for the GAME folder, I've tried EBOOT.PBP files for psp_mame4all_v4.9r1, psp_mame4all_v4.9r1-fat-noneogeo-nocps1, PSP MAME 0.4 KN, PSP MAME 0.4 NM, PSP MAME 0.4 SG, and PSP MAME 0.4 TT. All of the PSP MAME 0.4 executables start to load and then the screen goes blank and the PSP eventually goes to sleep. 

 

As for the mame4all_v4.9r1 executables, they issue the error: "The game could not be started. (8002013C)"

 

I tried all the ISO modes available. No go. 

 

This PSP's stats are:

 

Kernel version: 6.39 (0x006030910)

Motherboard model: TA-081

Motherboard type: Fat 1001 (01g)

PSP version: Fat v2.0






0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users