Jump to content

Photo

Atari 8-bit IRC client: FujiChat (0.3 released)


54 replies to this topic

#26 Urchlay OFFLINE  

Urchlay

    Stargunner

  • Topic Starter
  • 1,158 posts

Posted Mon Dec 22, 2008 10:15 PM

Bam! Fujichat in an emulator with no need for real serial ports or cables. All you really need is a linux box with SLIP support in the kernel.


Nice! I've been wanting a way to debug Fujichat with the atari800 debugger, this will help immensely!

#27 w1k OFFLINE  

w1k

    Stargunner

  • 1,669 posts
  • Location:martin, slovakia

Posted Thu Oct 8, 2009 2:49 AM

hello, it's possile connect to internet/chat via APE? i try today (irc.tobug.net), but doesnt work

#28 Urchlay OFFLINE  

Urchlay

    Stargunner

  • Topic Starter
  • 1,158 posts

Posted Thu Oct 8, 2009 1:18 PM

hello, it's possile connect to internet/chat via APE? i try today (irc.tobug.net), but doesnt work


No, APE doesn't support SLIP. FujiChat uses a standard SLIP link, not special Atari-specific software... if you're on Windows, see if you can find a program called "slirp" for the PC side.

#29 NML32 OFFLINE  

NML32

    Dragonstomper

  • 659 posts
  • Location:Tampabay FL

Posted Thu Oct 8, 2009 5:47 PM

DL link seems to be down.

#30 Beetle OFFLINE  

Beetle

    Dragonstomper

  • 515 posts
  • Atarian at 8, 16, 32 and 64 Bits
  • Location:north west in Germany

Posted Thu Oct 8, 2009 7:44 PM

Yeah, right now the whole page is offline.

For the meantime, i have a copy on my webspace.
Download FujiChat Version 0.4 here

Regards,
Beetle

#31 NML32 OFFLINE  

NML32

    Dragonstomper

  • 659 posts
  • Location:Tampabay FL

Posted Thu Oct 8, 2009 7:46 PM

Thx, but I am getting a permission error.


Yeah, right now the whole page is offline.

For the meantime, i have a copy on my webspace.
Download FujiChat Version 0.4 here

Regards,
Beetle



#32 w1k OFFLINE  

w1k

    Stargunner

  • 1,669 posts
  • Location:martin, slovakia

Posted Fri Oct 9, 2009 12:44 AM

hello, it's possile connect to internet/chat via APE? i try today (irc.tobug.net), but doesnt work


No, APE doesn't support SLIP. FujiChat uses a standard SLIP link, not special Atari-specific software... if you're on Windows, see if you can find a program called "slirp" for the PC side.



thank you.. but.. slirp? is it DLL or what? o have no slirp in my comp

#33 w1k OFFLINE  

w1k

    Stargunner

  • 1,669 posts
  • Location:martin, slovakia

Posted Fri Oct 9, 2009 12:44 AM

Thx, but I am getting a permission error.


Yeah, right now the whole page is offline.

For the meantime, i have a copy on my webspace.
Download FujiChat Version 0.4 here

Regards,
Beetle


yes, i use fujichat 0.4

#34 w1k OFFLINE  

w1k

    Stargunner

  • 1,669 posts
  • Location:martin, slovakia

Posted Fri Oct 9, 2009 2:26 AM

http://atari8.podstr...ds/fujichat.atr

#35 Urchlay OFFLINE  

Urchlay

    Stargunner

  • Topic Starter
  • 1,158 posts

Posted Fri Oct 9, 2009 3:40 AM

thank you.. but.. slirp? is it DLL or what? o have no slirp in my comp


It's a regular program, you download & install it... I can't really give you any useful advice for using Slirp on Windows, as I don't use Windows, but it implements the standard SLIP protocol, so it should work fine with FujiChat.

About the site... I've been going through what you might call financial difficulties lately, haven't had time to work on FujiChat much, nor set up a new site for it. The project isn't dead, but it's definitely on hold for now.

#36 w1k OFFLINE  

w1k

    Stargunner

  • 1,669 posts
  • Location:martin, slovakia

Posted Fri Oct 9, 2009 4:24 AM

thank you.. but.. slirp? is it DLL or what? o have no slirp in my comp


It's a regular program, you download & install it... I can't really give you any useful advice for using Slirp on Windows, as I don't use Windows, but it implements the standard SLIP protocol, so it should work fine with FujiChat.

About the site... I've been going through what you might call financial difficulties lately, haven't had time to work on FujiChat much, nor set up a new site for it. The project isn't dead, but it's definitely on hold for now.


i found only this:
http://ag.arizona.ed.../Winxpslirp.htm
http://ag.arizona.ed.../slirp/winx.htm

no executable

#37 Beetle OFFLINE  

Beetle

    Dragonstomper

  • 515 posts
  • Atarian at 8, 16, 32 and 64 Bits
  • Location:north west in Germany

Posted Fri Oct 9, 2009 10:19 AM

Permissions fixed, thx for the info.

Thx, but I am getting a permission error.


Yeah, right now the whole page is offline.

For the meantime, i have a copy on my webspace.
Download FujiChat Version 0.4 here

Regards,
Beetle



#38 w1k OFFLINE  

w1k

    Stargunner

  • 1,669 posts
  • Location:martin, slovakia

Posted Tue May 11, 2010 10:01 AM

can i use fujichat on windows with ape and sio2pc?

#39 w1k OFFLINE  

w1k

    Stargunner

  • 1,669 posts
  • Location:martin, slovakia

Posted Mon Mar 7, 2011 1:02 PM

..or this http://cals.arizona..../Winxpslirp.htm from use fujichat on real atari with sio2pc (rs232) and ape?

i have SLIP for WIN7.. how ip address i must type? when i connect - failed to connect com1

Edited by w1k, Mon Mar 7, 2011 1:37 PM.


#40 w1k OFFLINE  

w1k

    Stargunner

  • 1,669 posts
  • Location:martin, slovakia

Posted Mon Mar 7, 2011 1:44 PM

and fujichat settings? i use this

Posted Image

#41 fibrewire OFFLINE  

fibrewire

    Stargunner

  • 1,625 posts
  • Location:Southern California

Posted Thu Feb 16, 2012 1:42 PM

Did anyone ever grab the binary, source, and documentation from Urchlay's site before it went down?

#42 kogden OFFLINE  

kogden

    Dragonstomper

  • 636 posts

Posted Thu Feb 16, 2012 3:18 PM

Rather than have the 8-bit do the heavy lifting with TCP/IP, why not just use the "Internet Modem" functionality built into APE/SIO2OSX and just connect on Port 6667 and deal with only the Application Layer IRC protocol from the Atari? This way the same code could be useful with Lantronix Serial<->Ethernet adapters.

I understand the "cool factor" of a full IP stack running on the 8-bit but really very little hardware exists to make it usable for most folks as 850's and R-Verters aren't always easy to find cheap. Setting up a SLIP server on the PC side is a lot of work for most folks as well. Internet Modem functionality works out of the box with SIO2OSX and APE as far as know. ISP's generally don't use SLIP anymore so it's not like you could hook up an XM301 and connect these days.

Not trying to knock anybody's hard work, this is very cool!

#43 MEtalGuy66 OFFLINE  

MEtalGuy66

    River Patroller

  • 2,776 posts
  • If it aint broke, fix it anyway!
  • Location:Houston, TX, USA

Posted Thu Feb 16, 2012 5:06 PM

Thats whats being discussed in the other forums..

#44 charliecron OFFLINE  

charliecron

    Moonsweeper

  • 413 posts

Posted Thu Feb 16, 2012 7:41 PM

Well I don't have the source, but I found the documentation at web.archive.org. But seriously, your probably not gonna be hacking 8-bit TCP/IP C code.

In the zip file you will find:

atariserver_slip.sh
Changelog
fujichat-0.3.atr
fujichat-0.5pre3.atr
HOWTO
README

Version 4 is still available at links posted above.

I'm not sure of the differences in 0.5-pre3, and I do not have a 'virgin' image, so this will be configured for my setup, with an Atari 850 at 9600 baud, sorry. It's easy to configure, there is a menu item to configure it.

#45 fibrewire OFFLINE  

fibrewire

    Stargunner

  • 1,625 posts
  • Location:Southern California

Posted Thu Feb 16, 2012 8:11 PM

I'm not sure of the differences in 0.5-pre3, and I do not have a 'virgin' image, so this will be configured for my setup, with an Atari 850 at 9600 baud, sorry. It's easy to configure, there is a menu item to configure it.

Luckily, that's exactly how my configuration is :)

#46 TheMontezuma OFFLINE  

TheMontezuma

    Dragonstomper

  • 676 posts
  • Location:Hildesheim, D / Kraków, PL

Posted Wed Dec 17, 2014 11:56 AM

I come back with the similar question again - did anyone ever grab the source and documentation from Urchlay's site before it went down?

#47 Beetle OFFLINE  

Beetle

    Dragonstomper

  • 515 posts
  • Atarian at 8, 16, 32 and 64 Bits
  • Location:north west in Germany

Posted Fri May 20, 2016 2:42 AM

Hi, may i dig this one up once more?

 

I just managed to run my old script in slightly modified form on my Linux MiNT laptop, with standard "slattach" binary:

#!/bin/sh

modprobe slip &> /dev/null
ifconfig sl0 down &> /dev/null

slattach -L -p slip -s 9600 /dev/ttyUSB0 &
sleep 1

ifconfig sl0 192.168.0.1 pointopoint 192.168.0.2

ifconfig sl0 mtu 576

echo "1" > /proc/sys/net/ipv4/ip_forward
iptables -t nat -F
iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

 Since i got a USB Serial Adapter cable with FTDI chip, i changed from ttyS0 to ttyUSB0.

On the Atari i run Fujichat 0.4 from  my own link, and i am able to connect and chat.

 

 

I have a Fujichat05pre2.atr on my CF card, but it fails to read its own config file nor saves a valid new one.

However, in addidtion to FC 0.4 it offers 19200 as connection speed (FC has 9600 max) and

i recall the editor was fixed, too.

 

Does someone still have the latest Fujichat 05pre3.atr and can offer a link? I'll happily put it on my

webspace (you see my old Link still works).

 

Can someone recall what a8_slattach had patched/fixed over the standard binary?

 

 

Greets,

Beetle


Edited by Beetle, Fri May 20, 2016 2:58 AM.


#48 charliecron OFFLINE  

charliecron

    Moonsweeper

  • 413 posts

Posted Fri May 20, 2016 6:33 AM

This ATR is likely configured for what I did use back then. an 850 at 9600 baud.

 

Attached Files



#49 Beetle OFFLINE  

Beetle

    Dragonstomper

  • 515 posts
  • Atarian at 8, 16, 32 and 64 Bits
  • Location:north west in Germany

Posted Fri May 20, 2016 9:29 AM

Thanks, Charliecron!



#50 Beetle OFFLINE  

Beetle

    Dragonstomper

  • 515 posts
  • Atarian at 8, 16, 32 and 64 Bits
  • Location:north west in Germany

Posted Fri May 20, 2016 10:26 AM

I can confirm that FujiChat 0.5pre3 also runs from within SpartaDos X 4.47,

with VBXE 80column console enabled ( and even with Rapidus in '816 mode on).

 

nice :)






0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users