Jump to content


AspeQt: Yet another SIO2PC/APE clone

857 replies to this topic

#851 HiassofT OFFLINE  



  • 819 posts
  • Location:Salzburg, Austria

Posted Tue Aug 19, 2014 3:24 AM

New error: Cannot not set serial port speed to 19200. Input/Output error.  I get this with ttyS0 and ttyS1.

Could you run the following command:
dmesg | grep ttyS
If this doesn't work try
sudo grep ttyS /var/log/kern.log
You should then see something like this:
[    0.218044] 00:02: ttyS0 at I/O 0x3f8 (irq = 4, base_baud = 115200) is a 16550A
[    0.218836] ttyS4: detected caps 00000700 should be 00000500
[    0.218839] 0000:05:00.0: ttyS4 at I/O 0xd000 (irq = 20, base_baud = 921600) is a 16C950/954
[    0.218965] ttyS5: detected caps 00000700 should be 00000500
[    0.218968] 0000:05:00.0: ttyS5 at I/O 0xd100 (irq = 20, base_baud = 921600) is a 16C950/954
[   21.974463] 0000:05:01.0: ttyS6 at I/O 0xd800 (irq = 19, base_baud = 115200) is a 16550A
[   21.994939] 0000:05:01.0: ttyS7 at I/O 0xd900 (irq = 19, base_baud = 115200) is a 16550A
The "ttySx" are the device nodes under dev, the output above is from my Debian PC with one onboard RS232 interface (/dev/ttyS0) and 2 2-port serial cards - an Oxford 16C950 based card (/dev/ttyS4 and /dev/ttyS5) and an el-cheapo NetMos based card (/dev/ttyS6 and /dev/ttyS7).

Addon cards usually get numbers 4 and up, onboard ports have numbers 0-3.

so long,


#852 Tempest OFFLINE  


    Your Imperious Leader

  • 22,845 posts
  • Location:The Ethereal Plane of Atrii

Posted Tue Aug 19, 2014 6:54 PM

Ok it's either 4 or 5 but I can't get anything to load.  I mount a disk image and turn the system on but it just goes to Basic.  Holding down Option doesn't seem to do anything either.

#853 atarixle OFFLINE  



  • 250 posts
  • Location:Germany

Posted Sat Aug 23, 2014 9:35 AM

I just tried to compile the AspeQt ... but there is a problem I have ... Where are the sources????

#854 atari8warez OFFLINE  


    River Patroller

  • 2,326 posts
  • Location:Canada

Posted Sat Aug 23, 2014 9:56 PM

Here. Current release is r77, just click on "Download snapshut" and SF will create an archive and let you download it. If you want an earlier release just walk down the release three; click "History" and then select a release from the displayed list, (for example r74), then click "Browse code at this revision". Once you are at the new release level you can click "Download snapshut" to download code.


I no longer provide a separate source archive along with the binary, as this would be an unnecessary duplication and sometimes maybe out of sync with the source code maintained by SF.

Edited by atari8warez, Sat Aug 23, 2014 10:11 PM.

#855 starwindz OFFLINE  


    Chopper Commander

  • 248 posts
  • Location:South Korea

Posted Mon Sep 15, 2014 3:33 AM

When I run aspeqt.exe via command line as follows, .atr file could not be mounted properly as the attached screenshot.

d:\aspe>"d:\aspeqt.exe" "c1.aspeqt" [enter]


c1.aspeqt has some information about disk mounting shown as follows.


1\FileName=D:/aspe/Crossfire (19xx)(Sierra).atr
What is the cause of this problem?

Attached Thumbnails

  • aspe1.PNG

#856 resetreboot OFFLINE  


    Combat Commando

  • 3 posts

Posted Mon Sep 15, 2014 3:33 PM

Hey, atari8warez


New user here! I'm enjoying AspeQt so far, but noticed it doesn't have the modem emulation working yet. I tried downloading the APE trial to see if I could get online but the version at the site is 3.0.2 so it won't work, and I can't shell out fifty bucks without any warranties it'll work. Anyway, I saw you've started a bit of work regarding the modem emulation and I'd be willing to help make it happen. I just need some information, documentation, on how SIO cables and Atari modems work so I can start puttings things there.


I was looking to try to merge Atari800 R: device emulation code, which makes it simple to connect, using two commands; "ATDL" deactivates linefeeds and "ATDI host port" makes the modem connect to the host to the wanted port. I feel like it makes more sense than making a full AT commands set and faking calls, right?


So, I'm here looking and studying your code, I hope I can give something back to this wonderful community!

#857 Mclaneinc OFFLINE  


    River Patroller

  • 2,357 posts
  • Location:Northolt, UK

Posted Tue Sep 16, 2014 4:39 AM

Hi there Atari8warez,


Starwindz who made the gamepack front end and to a large extent myself are keen to add the ability to the Best Atari Gamepack frontend to send from it to a real machine, is there a command line interface other than the one for the Atari side, if not would you best interested in adding a simple command line to just mount disks?


People are really liking the gamepack that Starwindz has created and as part of the team I'd also love to be able to use it to send files to the hardware for testing, it would just be nice to do it from inside the GB and other users have asked also if it would be something Starwindz could add.


Hoping to hear kind words but whatever the answer let me thank you for Aspeqt, I use it a lot myself when testing stuff via Phaerons wonderful Altirra and real hardware.

Edited by Mclaneinc, Tue Sep 16, 2014 4:40 AM.




  • 1,062 posts
  • Always looking for GFX and MSX for my demos
  • Location:Lebach, Germany

Posted Yesterday, 3:58 AM

Adding to the post above: It would be great if AspecQt could be associated with the ".atr" file file extension (and mount it in D1:). Current I already have it associated, so at least is starts, but since it thinks the ATR is a session file, I have to manually select the ATR again then. I just his very often to extract DOS files via the nice explorer window.

0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users