Jump to content

Photo

Fixing dead 2600 and VCS 4 switcher


3 replies to this topic

#1 31336haxx0r OFFLINE  

31336haxx0r

    Dragonstomper

  • 515 posts
  • Location:Germany

Posted Thu Sep 15, 2011 6:42 AM

Hey there! I have 2 dead PAL consoles here I'm looking forward to repair.

2600:

There is no RF output. When putting my finger on C32 and Q3 (the parts just next to the CA3086), I get a hint of a signal on the TV but it isn't syncronized.I assume the modulator circuitry is dead?

VCS:

I get an RF signal of some kind, i.e. a colored screen (most of the time blue-ish) and sometimes some sort of sound. Like a short buzz. Is the cartridge port dirty/corroded or is the RIOT chip shot?

#2 31336haxx0r OFFLINE  

31336haxx0r

    Dragonstomper

  • Topic Starter
  • 515 posts
  • Location:Germany

Posted Sun Apr 22, 2012 6:58 AM

Okay I've got an update. The 4 switcher had a broken RIOT chip. After replacing it, it works fine. The Jr. has a broken TIA. I think I'll gut it for its RIOT chip, so I have a spare one...

#3 Trinity OFFLINE  

Trinity

    Stargunner

  • 1,023 posts

Posted Sun Apr 22, 2012 7:01 AM

damn, i need to hoard back-up chips for my baby's...

#4 31336haxx0r OFFLINE  

31336haxx0r

    Dragonstomper

  • Topic Starter
  • 515 posts
  • Location:Germany

Posted Sun Apr 22, 2012 7:28 AM

Yes but take care. Your relatives may think you're an electronic junk hoarder. My relatives do. :ponder:

Edited by 31336haxx0r, Sun Apr 22, 2012 7:28 AM.





0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users