Jump to content

Photo

Sega CD Model 1 Audio Problem

Sega CD Genesis Audio Stuttering Broken Mega CD

2 replies to this topic

#1 ViciousTengu OFFLINE  

ViciousTengu

    Space Invader

  • 28 posts

Posted Mon Feb 4, 2013 3:25 PM

I recently purchased a broken Sega CD Model 1 off an auction and did a bunch of small repairs. So far I've gotten everything to work perfectly except one annoying problem that I can't seem to figure out, stuttering choppy audio. All of the obvious things have been checked & contacts have been cleaned thoroughly and the Genesis runs fine on its own. When connected to Sega CD the sound is stuttering from the Genesis headphone port as well as the TV and even when the mixing cable is used. The only time it sounds clear is when a aux cable is plugged into the Sega CD mixing jack with nothing connected to the other end, which I assume is disabling the sound that is coming out of the Sega CD side of things. Anyone ever experience this before?

#2 evilevoix OFFLINE  

evilevoix

    Moonsweeper

  • 332 posts
  • Location:Jerzy Shore

Posted Sun Apr 14, 2013 12:05 PM

The laser is probably dying.

#3 low_budget OFFLINE  

low_budget

    Chopper Commander

  • 159 posts
  • Location:Missouri

Posted Sun Apr 14, 2013 1:03 PM

I had choppy sound coming from a Turbo Duo and it turned out to be leaking capacitors.

Check the caps around the audio circuit for signs of leakage and replace as necessary.





Also tagged with one or more of these keywords: Sega CD, Genesis, Audio, Stuttering, Broken, Mega CD

0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users