Jump to content

Photo

Pal scart rgb 7800 video problems


10 replies to this topic

#1 frenchguy OFFLINE  

frenchguy

    Space Invader

  • 12 posts

Posted Sun Jun 15, 2014 9:36 AM

Hi,

 

As I said in my presentation topic :

 

http://atariage.com/...e/#entry3011092

 

 

I've got a 7800 with some video problems. I hope I post this topic in the correct forum.

 

 

Here's the problems :

 

When I play a cartridge (2600 games, I don't own any 7800 game for now), the display is dominantly red/orange, with very visible scanlines (like a very bad filter in some emulation program) and a bit blury too.

 

When I play the internal 7800 game (asteroids), the problems are less important, but the display is still far from being perfect (especially the blur).

 

I tried to move the video cable to see if any diference appears : no diference. So I don't think it's the cable fault.

 

So I dissassembled the console. The video female plug seems in good shape, with all pins firmly attached to the daughter board. The weld points seems a bit dry maybe.

 

I also tried to move the 2 "knobs" on the daughter board, with apparently no effect (difficult to see, because of the awfull red-ish blurry display).

 

 

 

Now I'm a bit lost, so I think I'll start by doing new fresh weld points for the video plug.  Any help will be appreciated.

 

Many thanks !



#2 frenchguy OFFLINE  

frenchguy

    Space Invader

  • Topic Starter
  • 12 posts

Posted Mon Jun 16, 2014 2:17 PM

Today I made some screenshots of the console current state.

 

Here's some screenshots of a vcs2600 cart inserted (double dragon). You can see the strong scanline, the blury graphics and the red color everywhere.

 

P6160809_zps41cf7530.jpg

 

P6160806_zps0145350d.jpg

 

 

Here's a screenshot of the 7800 embedded Asteroids game. THe red effet remains, even if it's not as visible. The graphics still blury and scanlined too.

 

P6160770_zps23f94a7c.jpg

 

 

I tried to rotate the 2 knobs on the rgb daugther PCB, but with no significant result. If I set them for better 7800 display (less blury especially), 2600 games appears almost in black and white. If I set the knobs for better 2600 display, the 7800 games are awfull.

 

 

I don't know what to do. I'll try to clean the cart port, and maybe re-do the welding points of the rgb cable plug.  But I'm not very confident in the result.



#3 roland p OFFLINE  

roland p

    River Patroller

  • 2,455 posts
  • $23
  • Location:The Netherlands

Posted Mon Jun 16, 2014 2:21 PM

I can't see the pictures.

 

Edit: Now I do see the pictures in the above post.


Edited by roland p, Mon Jun 16, 2014 3:14 PM.


#4 frenchguy OFFLINE  

frenchguy

    Space Invader

  • Topic Starter
  • 12 posts

Posted Mon Jun 16, 2014 2:47 PM

Strange, I hosted them like I do usually, and they are working for me. Anyway, I uploaded them directly on the forum, now anyone should be able to see them.

The very red ones are the 2600 pics, the not so red is the 7800 pic.

thanks

Attached Thumbnails

  • P6160809.JPG
  • P6160806.JPG
  • P6160770.JPG


#5 Thibr OFFLINE  

Thibr

    Star Raider

  • 79 posts

Posted Tue Jun 17, 2014 5:30 PM

Thank you for these pictures frenchguy. I'd say that your TV/monitor may also be involved (the red zone is the center of the picture for your built-in game).



#6 frenchguy OFFLINE  

frenchguy

    Space Invader

  • Topic Starter
  • 12 posts

Posted Tue Jun 17, 2014 5:49 PM

thanks for your answer,

 

The tv is almost brand new, it accepts 50 and 60hz, pal, and ntsc. I use it with all my retro machines (from the master system to the dreamcast), all using RGB scart, with perfect image.
 

I'm afraid the problem is related to the 7800 console. On a french forum some members gave me clues and things to try, I'll try it tommorow and keep you informed.



#7 frenchguy OFFLINE  

frenchguy

    Space Invader

  • Topic Starter
  • 12 posts

Posted Fri Jun 20, 2014 4:21 PM

Is this the first time a 7800 has technical problems ? :grin:



#8 frenchguy OFFLINE  

frenchguy

    Space Invader

  • Topic Starter
  • 12 posts

Posted Thu Jan 8, 2015 10:54 AM

Too bad I never found any solution (or help) to fix this console. It will probably go to garbage, finally.  :(



#9 roland p OFFLINE  

roland p

    River Patroller

  • 2,455 posts
  • $23
  • Location:The Netherlands

Posted Fri Jan 9, 2015 8:07 AM

Would you sell it? :)

#10 alex_79 OFFLINE  

alex_79

    Stargunner

  • 1,195 posts
  • Location:Italy

Posted Fri Jan 9, 2015 11:31 AM

I'm not a tech expert, but here's some suggestions:

- Try tuning the 2 pots on the 7800 board that control the color, one for 2600 games, the other for 7800 ones. The pots I'm referring to are on the MAIN board, below the cartridge port, not on the RGB daughter board.
color_pots_7800.JPG

- Check the cable for continuity (you'll need a multimeter). A broken wire in one of the RGB components cold be the cause for the strange colors.
7800_connector.gif

 

- If the problem is in the RGB daughter board and you can't fix it, but you have some soldering experience, then you could just disable it and install one of the A/V mods on your console (which is based on the PAL version). The "easier composite mod" that you find in the forum is very easy to do and gives good results (at least on CRT TVs). If you wants better quality you should go for an s-video mod. After the mod the console will be PAL, so you need a TV which accepts a PAL signal.
 



#11 frenchguy OFFLINE  

frenchguy

    Space Invader

  • Topic Starter
  • 12 posts

Posted Sat Jan 10, 2015 6:45 AM

Thank you for your help, it's the kind of help I was hoping for. I'll try your advises, and come back here with result ! 






0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users