Jump to content

Photo

LTO Flash! - Intellivision Flash Cartridge Information


1656 replies to this topic

#1651 Rev OFFLINE  

Rev

    A.K.A. Revolutionika

  • 14,977 posts
  • Location:NC

Posted Wed Apr 19, 2017 5:13 PM

I never updated my Lto. Works just fine.

What's in the update anyway.

#1652 Eric7100 OFFLINE  

Eric7100

    River Patroller

  • 3,029 posts

Posted Wed Apr 19, 2017 5:41 PM

What's in the update anyway.

 

Just some mumbo jumbo.



#1653 intvnut OFFLINE  

intvnut

    River Patroller

  • 2,740 posts
  • Location:@R6 (top of stack)

Posted Wed Apr 19, 2017 5:49 PM

I never updated my Lto. Works just fine.

What's in the update anyway.

 

Short version:  Some features for sorting ROMs, a launcher for jzIntv, and a few stability fixes and tweaks for edge cases.

 

Long version: See the changelog.



#1654 intvsteve ONLINE  

intvsteve

    River Patroller

  • 2,674 posts
  • Location:At the keyboard

Posted Wed Apr 19, 2017 6:01 PM

FWIW, I downloaded the sources for all the different versions released at the site, built debug versions, and launched. My current ROM list under test has about 225 ROMs, and the cart has ... oh, i don't know. Maybe approxmately that number, but "weird" menu layout -- some test ROMs and some goofy stuff like 100 copies of the same ROM in a folder, etc.

 

Anyway, on the same system, I detected no qualitative difference... about 5 seconds 'validating' on device connect. The exact number is meaningless to anyone but my setup on my system -- the interesting part is that it does not seem to vary by any noticeable amount.

 

That doesn't mean that things did not change or somehow get worse in any obvious way. It does mean that it's perhaps more subtle -- why some systems may seem more affected than others.

 

Still, there are performance improvements to be made here, and I'm exploring them, and they will be made. Hopefully they'll help everyone when they roll out.



#1655 Utopia OFFLINE  

Utopia

    Dragonstomper

  • 633 posts
  • Location:Brisbane Australia

Posted Yesterday, 6:21 PM

FWIW, I downloaded the sources for all the different versions released at the site, built debug versions, and launched. My current ROM list under test has about 225 ROMs, and the cart has ... oh, i don't know. Maybe approxmately that number, but "weird" menu layout -- some test ROMs and some goofy stuff like 100 copies of the same ROM in a folder, etc.

 

Anyway, on the same system, I detected no qualitative difference... about 5 seconds 'validating' on device connect. The exact number is meaningless to anyone but my setup on my system -- the interesting part is that it does not seem to vary by any noticeable amount.

 

That doesn't mean that things did not change or somehow get worse in any obvious way. It does mean that it's perhaps more subtle -- why some systems may seem more affected than others.

 

Still, there are performance improvements to be made here, and I'm exploring them, and they will be made. Hopefully they'll help everyone when they roll out.

When the "sped up" next version of the software rolls out will we just find it on the LTO site?



#1656 intvnut OFFLINE  

intvnut

    River Patroller

  • 2,740 posts
  • Location:@R6 (top of stack)

Posted Yesterday, 6:37 PM

When the "sped up" next version of the software rolls out will we just find it on the LTO site?

 

It'll go up on the LTO Flash GUI webpage.  Also, if you have it enabled, the GUI will alert you that an update is available if it sees an update's been posted to the website.



#1657 intvsteve ONLINE  

intvsteve

    River Patroller

  • 2,674 posts
  • Location:At the keyboard

Posted Today, 11:59 AM

I'm awaiting some feedback on the progress made so far. I did find that for Windows users, when support for launching jzIntv was added, a potential slowdown crept in - but the core issue some of you have noticed has been there since the beginning.

 

And, as intvnut mentioned, when a new release happens, it'll be at the website. Those who haven't disabled the "check for udpates when launched" will be annoyed by a dialog telling you there's an update the next time you run the UI.






0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users