Jump to content

Photo

Issues with 'Bounty Bob' on a modified 130XE


10 replies to this topic

#1 PlayingTheAngel OFFLINE  

PlayingTheAngel

    Space Invader

  • 16 posts
  • Just hang on and Suffer Well
  • Location:Lincoln

Posted Fri Mar 13, 2015 8:17 PM

Hi all,

 

I don't know how many of you have 1mb Ultimate and VBXE installed into your XL/XE computers but I had one of my 130XE's modified recently. I have to say that I was quite excited  :) It's been fun and it's certainly re-energised my enthusiasm for the 8 Bit Atari computer.

 

Recently I've been using the following Utilities and Menu Makers that I've had on disk for years:

 

Alpha Menu Maker

Ian K Menu Maker

Rob C Musical Menu Maker

MultiBoot

 

When it came to putting 'Bounty Bob Strikes Back' onto a menu, it read from high speed menu (Ian K) to normal 1050 speed menu (Rob C) without issues. When the data loaded and the game begins I cannot control anything with the joystick and he will only jump which is rather bizarre. I unplugged my modified 130XE and plugged my stock 65XE into my 1050 and the game wouldn't even load or work at all and then I tried my stock 130XE and the game worked fine. How can it be that it won't work at all on my modded 130XE with all the extra ram onboard? I tried all different settings on the BIOS and still it wouldn't work  :?

 

I would be interested to hear your thoughts.

 

Rachel  ;-)


Edited by PlayingTheAngel, Fri Mar 13, 2015 8:18 PM.


#2 phaeron OFFLINE  

phaeron

    River Patroller

  • 2,738 posts
  • Location:Bay Area, CA, USA

Posted Fri Mar 13, 2015 9:21 PM

Ultimate1MB takes over some memory locations in the computer that are normally used by the chip that's connected to the joysticks (PIA). Software that uses the official methods of reading the joystick are OK, but Bounty Bob uses one of these unusual locations to read the joystick ($D3F0), and so it doesn't work with U1MB installed.



#3 Stefan Both OFFLINE  

Stefan Both

    Moonsweeper

  • 451 posts

Posted Sat Mar 14, 2015 6:03 AM

I also own an ultimate, that's why
i ask for a better understanding.
The problem still exist, when you switch
off (set everything to STOCK) in ultimate menu?

Stefan

#4 PlayingTheAngel OFFLINE  

PlayingTheAngel

    Space Invader

  • Topic Starter
  • 16 posts
  • Just hang on and Suffer Well
  • Location:Lincoln

Posted Sat Mar 14, 2015 10:18 AM

I've changed all BIOS settings before Stefan and switched everything to stock and still doesn't work. Thanks for the explanation Phaeron



#5 Stefan Both OFFLINE  

Stefan Both

    Moonsweeper

  • 451 posts

Posted Sat Mar 14, 2015 2:58 PM

Agree. You are right. Tested it myselfe.
Strange thing. Thanks to Phaeron also.

Stefan

#6 nobody OFFLINE  

nobody

    Space Invader

  • 23 posts

Posted Sat Mar 14, 2015 4:18 PM

Try this version - it should work...

Attached Files


Edited by nobody, Sat Mar 14, 2015 4:20 PM.


#7 nobody OFFLINE  

nobody

    Space Invader

  • 23 posts

Posted Sun Mar 15, 2015 2:34 AM

Ok... Now with correct sound, i think... This Game is tricky...

Attached Files



#8 Stefan Both OFFLINE  

Stefan Both

    Moonsweeper

  • 451 posts

Posted Sun Mar 15, 2015 2:57 PM

Thank you! I'll try it.

Stefan

#9 FULS OFFLINE  

FULS

    Moonsweeper

  • 344 posts
  • Location:Troy, Ohio

Posted Mon Mar 16, 2015 3:52 PM

Ok... Now with correct sound, i think... This Game is tricky...

Thank You very much!!!

Haven't tried all the levels yet, but I did notice this version fixed the SYSTEM RESET bug on screen #2.

This looks like it might be the best file version of BBSB I've seen.



#10 bandit OFFLINE  

bandit

    Chopper Commander

  • 201 posts
  • Location:Central Point , Oregon 97502

Posted Wed Mar 18, 2015 9:54 AM

This also works on the Incognito Board which the Cartridge DID not and the many different Files of bounty bob
Also Had the basic issue, NO JOYSTICK always ran to the left of the screen.

So, this file now works !! Thanks!!

#11 MrMartian OFFLINE  

MrMartian

    Moonsweeper

  • 303 posts
  • Location:Ontario, Canada

Posted Wed Mar 18, 2015 5:54 PM

This also works on the Incognito Board which the Cartridge DID not and the many different Files of bounty bob
Also Had the basic issue, NO JOYSTICK always ran to the left of the screen.

So, this file now works !! Thanks!!

 

Exactly! That's where I was having a problem now that I have an Incognito, and BBSB didn't work at all! Hooray for nobody! (Hmm, that sounds odd....)






0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users