Jump to content

Photo

Coleco Gemini RF video issues need help

coleco gemini RF

4 replies to this topic

#1 AtengaGames OFFLINE  

AtengaGames

    Space Invader

  • 38 posts
  • Joustin'
  • Location:Oregon City OR

Posted Mon Jul 20, 2015 12:12 AM

I am having an issue with my coleco gemini's RF signal and I need some help trying to fix it.

 

To see the issue check out this youtube video:

()

 

Any responses would be appreciated Thanks.


Edited by AtengaGames, Mon Jul 20, 2015 12:13 AM.


#2 Nutsy Doodleheimer OFFLINE  

Nutsy Doodleheimer

    Total Retard

  • 5,619 posts

Posted Mon Jul 20, 2015 3:15 PM

The RF box soldering is most likely loose and needs to be resoldered. Geminis are notorious for the soldering to become brittle overvtime and the system was built with off the shelf parts.

#3 AtengaGames OFFLINE  

AtengaGames

    Space Invader

  • Topic Starter
  • 38 posts
  • Joustin'
  • Location:Oregon City OR

Posted Mon Jul 20, 2015 4:16 PM

The RF box soldering is most likely loose and needs to be resoldered. Geminis are notorious for the soldering to become brittle overvtime and the system was built with off the shelf parts.

Thanks for the reply I appreciate it.



#4 AtengaGames OFFLINE  

AtengaGames

    Space Invader

  • Topic Starter
  • 38 posts
  • Joustin'
  • Location:Oregon City OR

Posted Mon Jul 20, 2015 4:32 PM

I am probably going to hold off on trying to fix this system for now because i have 4 switch woody coming in the mail. This is actually my first atari playing console and I would like to get it functioning without breaking it. Does anybody happen to have pictures they can use to show which solder points I need to reheat and maybe some step by steps I could follow? I know I would certainly appreciate it and others would too considering I really couldn't find instructions for this fix on Google or AtariAge. If you have a link that's fine too.



#5 Brianeric26 OFFLINE  

Brianeric26

    Space Invader

  • 38 posts

Posted Sun Jul 17, 2016 8:18 PM

I never seen a gemini board before , but i have repair broken solder joint on power supplys jacks and rf boxes before , I jus disassblemble the rf box , maybe desoldering is needed and just look for bad solder joint it should look a like very dull , not shiny as the other ones and maybe some obvious damage , firts star by searching for joint near of the rf conector jack it most likely be one damege there . or the part when the rf board connecest so the main board , i dont know anything more thats the more I can help you , an if that doest work just resolder some ramdon joint or ones that maybe be bad , what can happend , waste of solder , if not maybe a av mod should help , but remenber the tia of the gemini is diferent , if you are interesed , some guy posted a gemini tia pinout in one of my post , i hope i help you





Also tagged with one or more of these keywords: coleco, gemini, RF

0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users