Jump to content

Photo

Emulation Issue

emulator emulation mousetrap

4 replies to this topic

#1 theredf OFFLINE  

theredf

    Combat Commando

  • 2 posts

Posted Fri Aug 21, 2015 5:47 PM

Aight so please excuse the ignorant question, but I've been trying to get a game I played as a kid on my PC.  I have Windows7 (possibly 10 soon) and have tried STEEM (including the SSE version), Hatari, and one other emulator (name escapes me).  When I run Mousetrap, it runs through the preview sequence of a few seconds of each level, but I can never seem to assume control of the game to start playing.

 

I can play at least another game (Lotus racing) on STEEM, but can't get Mousetrap to respond to any key commands (despite messing with the joystick setup multiple times). I KNOW this worked at some point because I emulated the game on an old Pentium circa 2005 - I can't figure out why I can't get this to work now.

 

Anyone have any ideas?  Is it the ROM, is there some config setting I'm screwing up...what's the deal?

 

Any help would be VERY much appreciated.



#2 galax OFFLINE  

galax

    Dragonstomper

  • 747 posts
  • Location:Toronto, Canada

Posted Fri Aug 21, 2015 6:35 PM

Is it just mousetrap that can't see your joystick commands, or any joystick game (perhaps you were using the keyboard commands on Lotus)? Mouse Trap works fine for me in Steem SSE.

 

With Steem, the keyboard-joystick isn't enabled by default- I think the default is to press 'Scroll Lock' to switch it on. This is because you won't be able to use the keys that are assigned to the joystick (cursor keys by default) when it is enabled.

 

You can also just play on keys: start the game with 'Space', then 'Z', 'X', and 'Shift'.

 

I seem to remember that the sprite images in the AUTO folder can be edited in Degas (we took the opportunity to make a copy of the game 'hilariously' obscene). Keep lots of backups while doing this though because at some point we made a change that just messed everything up and that copy wouldn't run.

 

Good luck!


Edited by galax, Fri Aug 21, 2015 6:36 PM.


#3 ParanoidLittleMan ONLINE  

ParanoidLittleMan

    Stargunner

  • 1,606 posts

Posted Sat Aug 22, 2015 2:09 AM

Some games need older TOS version for proper joystick or mouse, keyboard work.



#4 galax OFFLINE  

galax

    Dragonstomper

  • 747 posts
  • Location:Toronto, Canada

Posted Sat Aug 22, 2015 6:12 AM

That's a good suggestion, I forgot to mention I tried a few TOS versions and it seemed to work fine, even 2.06 on an STE.

 

Another possibility is that your emulated joystick is using 'space' for 'fire', and I can't see a way of starting a game without pressing 'space' - you might need to either reassign the joystick fire button, switch off joystick emulation temporarily, or play on keys.


Edited by galax, Sat Aug 22, 2015 6:13 AM.


#5 theredf OFFLINE  

theredf

    Combat Commando

  • Topic Starter
  • 2 posts

Posted Sat Aug 22, 2015 10:49 AM

Wow - this was extremely helpful.  I had fiddled with every joystick setting, but apparently never tried the spacebar to kick the game off.  Somehow when trying every key on the keyboard, I must have missed spacebar....thank you all so much!!! (I told you this was an ignorant question!).







Also tagged with one or more of these keywords: emulator, emulation, mousetrap

0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users