Jump to content

Photo

RespeQt general discussion

questions bug reports feature requests help

181 replies to this topic

#176 Joey Z OFFLINE  

Joey Z

    Dragonstomper

  • Topic Starter
  • 874 posts
  • Location:Hoffman Estates, IL

Posted Thu Apr 20, 2017 6:21 PM

Downloaded and compiled r4-beta2 on my anemic little RPi W tonight. Seems to be working fine as usual though for some reason, I still see the Qt Serial Port backend option, though I did *NOT* see it in the r4-beta1 build I did yesterday. Weird. Not sure I goofed up a git terminal command when I cloned the r4 repository tonight or what. The About page shows I definitely built Beta 2 though. 

maybe delete the whole thing and start from scratch, the files for the Qt serial port backend aren't in r4-beta2 here, and it doesn't show up on linux or windows.



#177 DrVenkman OFFLINE  

DrVenkman

    River Patroller

  • 2,265 posts
  • Back off, man! I'm a scientist.
  • Location:KMBT

Posted Fri Apr 21, 2017 3:36 PM

maybe delete the whole thing and start from scratch, the files for the Qt serial port backend aren't in r4-beta2 here, and it doesn't show up on linux or windows.

 

 

I've now deleted the entire directory, cloned the 'r4' branch three times into a brand new directory, run 'qmake' and then 'make' - I get the same executable each time. *shrug* 

 

IMG_7652.JPG

 

IMG_7651.JPG

 

Unless I'm using git wrong, which is possible, I don't know what's up here. I'm doing:  'git clone https://github.com/j...ski/RespeQt.git r4'



#178 Joey Z OFFLINE  

Joey Z

    Dragonstomper

  • Topic Starter
  • 874 posts
  • Location:Hoffman Estates, IL

Posted Fri Apr 21, 2017 9:11 PM

 

 

I've now deleted the entire directory, cloned the 'r4' branch three times into a brand new directory, run 'qmake' and then 'make' - I get the same executable each time. *shrug* 

 

attachicon.gifIMG_7652.JPG

 

attachicon.gifIMG_7651.JPG

 

Unless I'm using git wrong, which is possible, I don't know what's up here. I'm doing:  'git clone https://github.com/j...ski/RespeQt.git r4'

Have you double checked that it says r4 in the about box? I do think you're using git wrong. try:

git clone https://github.com/jzatarski/RespeQt.git
git checkout r4

Then see what you get. r4 where it is in the clone command will clone into a directory called r4, not get the r4 branch.



#179 DrVenkman OFFLINE  

DrVenkman

    River Patroller

  • 2,265 posts
  • Back off, man! I'm a scientist.
  • Location:KMBT

Posted Fri Apr 21, 2017 9:15 PM

Hmm. Well, my first photo in the previous post shows the About box. It says R4-RC2, which is what we're working from, right? I'll give it another (fourth) try though. 



#180 Joey Z OFFLINE  

Joey Z

    Dragonstomper

  • Topic Starter
  • 874 posts
  • Location:Hoffman Estates, IL

Posted Fri Apr 21, 2017 10:23 PM

Hmm. Well, my first photo in the previous post shows the About box. It says R4-RC2, which is what we're working from, right? I'll give it another (fourth) try though. 

nope, that's something one of the other contributors must have changed it to for their own purposes. It should say R4-beta2 or something like that.



#181 DrVenkman OFFLINE  

DrVenkman

    River Patroller

  • 2,265 posts
  • Back off, man! I'm a scientist.
  • Location:KMBT

Posted Fri Apr 21, 2017 10:41 PM

nope, that's something one of the other contributors must have changed it to for their own purposes. It should say R4-beta2 or something like that.

Your instructions got me going. Now it says "R4-beta1" but hey, the Qt backend is gone, so thanks. :)

3F1264D3-35A3-43D7-85E7-DAF66174ED3B.JPG

#182 Joey Z OFFLINE  

Joey Z

    Dragonstomper

  • Topic Starter
  • 874 posts
  • Location:Hoffman Estates, IL

Posted Sat Apr 22, 2017 1:40 AM

Your instructions got me going. Now it says "R4-beta1" but hey, the Qt backend is gone, so thanks. :)

attachicon.gif3F1264D3-35A3-43D7-85E7-DAF66174ED3B.JPG

Oh, that's just because I forgot to update the text to beta2, it's actually beta2 though.





Reply to this topic



  



Also tagged with one or more of these keywords: questions, bug reports, feature requests, help

0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users