Jump to content

Photo

PLATO, MESS, and Win99


12 replies to this topic

#1 etownandy OFFLINE  

etownandy

    Chopper Commander

  • 211 posts

Posted Fri Jul 8, 2016 1:45 PM

Has anyone experienced trouble with Plato via MESS?  When I try to load the interpreter module, that's fine, but the moment I insert a disk, MESS crashes on my Mac.  Win99 runs the same disk images fine under Windows 10.  

 

The "gromport" option is set to "single."  I haven't tried EVERY Plato disk, but I have tried several - all of which give the same result Win99 v MESS.



#2 mizapf OFFLINE  

mizapf

    River Patroller

  • 3,383 posts
  • Location:Germany

Posted Fri Jul 8, 2016 2:25 PM

Let me check.

 

  • What Plato disk causes the problem reproducibly?
  • What MESS version do you use?
  • Could you please run the emulator in a terminal window and tell me whether you get an error message on crashing?


#3 etownandy OFFLINE  

etownandy

    Chopper Commander

  • Topic Starter
  • 211 posts

Posted Mon Jul 11, 2016 2:29 PM

Math Sentences in one Variable Disk 1 and Geometry Disk 4 are both doing it.  I'll upload them here as soon as I figure out how. :)

 

Using qmc2-sdlmess 0.50 on a Mac.  Trying to get to the logs, but the exception viewer tells me it's a divide by 0.



#4 mizapf OFFLINE  

mizapf

    River Patroller

  • 3,383 posts
  • Location:Germany

Posted Mon Jul 11, 2016 3:23 PM

I'd need the MAME/MESS version, not the QMC2 version. You should see it when you launch it without a system name, or you start it with "-help" as argument.

 

I once fixed a related issue:

 

http://www.ninerpedi...version_history

 

(see 0.160)

 

For that reason I have to make sure you are using a release that contains that fix already.

 

 

Attached Files


Edited by mizapf, Mon Jul 11, 2016 3:31 PM.


#5 etownandy OFFLINE  

etownandy

    Chopper Commander

  • Topic Starter
  • 211 posts

Posted Thu Jul 14, 2016 2:57 PM

Sorry!  I was using 155 (32 bit), but just upgraded to 161 (64 bit) and sure enough, the problem is gone.  Thanks for the fix!  Works like a champ.



#6 mizapf OFFLINE  

mizapf

    River Patroller

  • 3,383 posts
  • Location:Germany

Posted Thu Jul 14, 2016 3:39 PM

Good news. But why don't you just upgrade to the latest release (0.175)?

 

[Edit: I really recommend to upgrade to at least 0.174 because the system ROMs and cartridge ZIPs have changed at that point. There is no such thing as "let's keep some safety space from the newest release to make sure we get a stable one", because there is a continuous development, and bugs are fixed all over the time. Also, you could enjoy floppy drive sounds. Yes, I know, there are people who heavily dislike that - I still love it. You can turn off that sound, of course.]


Edited by mizapf, Thu Jul 14, 2016 3:50 PM.


#7 etownandy OFFLINE  

etownandy

    Chopper Commander

  • Topic Starter
  • 211 posts

Posted Fri Jul 15, 2016 10:55 AM

Mostly because I haven't figured out this combined mame/mess thing, yet.  I still use separate front ends for the two (I do run qmcmame with the 175 executable).  I get my builds here (http://mirrors.xmiss...me/mac/sdlmame/) and the last standalone MESS version is 161.


Edited by etownandy, Fri Jul 15, 2016 11:02 AM.


#8 mizapf OFFLINE  

mizapf

    River Patroller

  • 3,383 posts
  • Location:Germany

Posted Fri Jul 15, 2016 11:15 AM

Oh, I see ...

 

But be assured, there's not really a problem with this combination. If you build MESS from sources, you can build for the subtarget MESS and you'll get the MESS-only part of MAME. If you take the full executable you won't have to change anything for starting up the emulation. You just have MAME and MESS in one executable, that's all.

 

There won't be a separate MESS after 0.161.

 

Maybe when you find some time you should just give it a try and run your emulations from the 0.175. Don't forget to go to WHTech and pick up the new system ROMs and cartridge ZIPs; this won't take more than a few minutes.



#9 etownandy OFFLINE  

etownandy

    Chopper Commander

  • Topic Starter
  • 211 posts

Posted Sat Jul 16, 2016 10:22 AM

I'm more than willing to try again, but the QMC front end for MESS doesn't seem to like the 175 executable.  As soon as I select it in the config and hit OK, the front end gives me "12:20:10.242: FATAL: couldn't determine emulator type and version

"  So I pretty much gave up at that point.



#10 mizapf OFFLINE  

mizapf

    River Patroller

  • 3,383 posts
  • Location:Germany

Posted Sat Jul 16, 2016 10:33 AM

Sounds to me as if you need an update to QMC2. I can't tell, I'm not using QMC2, but I can check it for you.

 

As I said, you may decide to continue with 0.161 for the time being, but there won't be any more updates.

 

[Edit: Just tried, works for me. I installed the latest QMC2 (0.65) for MAME, and I can start up the TI console. As I said, you will need the new ROMs when it says that it cannot find them.]


Edited by mizapf, Sat Jul 16, 2016 10:48 AM.


#11 --- Ω --- OFFLINE  

--- Ω ---

    HexaCoreRunner

  • 12,848 posts

Posted Mon Feb 5, 2018 5:37 PM

Before Gazoo left us, I figured he would have stuffed all this into an UberCart.  Ya gotta admit, that would be a cool application for that cartridge. 



#12 Ksarul OFFLINE  

Ksarul

    River Patroller

  • 4,784 posts

Posted Thu Feb 8, 2018 7:35 PM

There is an UberGROM image with Plato in it. . .Ckoba made it, and it is in the UberGROM thread.



#13 --- Ω --- OFFLINE  

--- Ω ---

    HexaCoreRunner

  • 12,848 posts

Posted Thu Feb 8, 2018 7:42 PM

There is an UberGROM image with Plato in it. . .Ckoba made it, and it is in the UberGROM thread.

 

Really?  I was only aware of his one with LOGO, LOGO II and Multiplan.  Do you have a link?






0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users