Jump to content

Photo

Atari800MacX macOS Sierra sound not working


116 replies to this topic

#76 luckybuck OFFLINE  

luckybuck

    Dragonstomper

  • 942 posts

Posted Mon May 7, 2018 12:00 PM

Mathy is right! If you can gonna make this, please publish your PayPal-me address... You really deserve this.

 

But wait, Altirra under wine is making big progress! Will send you an e-mail.

 

On the other hand, the Wiki wouldn't be at the status it is, if Mark didn't made that outstanding job. Even when living under social security, I have donated to him the max before Kagi shut off.

 

Great! Please go ahead! :-))))



#77 luckybuck OFFLINE  

luckybuck

    Dragonstomper

  • 942 posts

Posted Sun Aug 5, 2018 7:22 PM

Thanks Mr Robot, could brew the emulator and it works fine with sound! :-))))

 

Atari 800 Emulator 4.0.0-1.jpg

 

Star Raiders.jpg

 

Took me some time, if you extract the zip file, then in that folder search for the src folder and then go on from there.

 

Yes, it works and its fine, but if Wade will gonna make us a new version of Atari800MacX with sound, I think the community would be in his debt for ever. At least the the Mac users...

 

Further, it is a good idea to read the manual, please see attached.

 

Thank you all. :-))) Great pleasure.

Attached Files



#78 Jetboot Jack OFFLINE  

Jetboot Jack

    Stargunner

  • 1,833 posts
  • Making Games
  • Location:Disconnected

Posted Sun Aug 12, 2018 7:50 AM

Atari800 compiles and runs just fine under OSX - I've done it recently, the details are linked above by Mr Robot, it took me minimal effort (30 minutes) get it working (I also did an automator script and associated files)

 

Altirra on OSX is also great using PlayOn - see this post, near zero effort to get running and full file associations etc

 

sTeVE


Edited by Jetboot Jack, Sun Aug 12, 2018 7:54 AM.


#79 Mathy OFFLINE  

Mathy

    River Patroller

  • 2,817 posts
  • Location:Heerlen, NL

Posted Sun Aug 12, 2018 6:00 PM

Hello Steve

 

Altirra on OSX is also great using PlayOn - see this post, near zero effort to get running and full file associations etc

 

Let's say I know how to switch the Mac on, how likely would it be that I will be able to get Altirra working under PlayOn?

 

Sincerely

 

Mathy

 

PS I bought my first iMac in 2006 IIRC, so I do know a couple of things about the Mac, but everything outside of "drag this from here to there" and "click on this" gets me in trouble very, very fast.



#80 luckybuck OFFLINE  

luckybuck

    Dragonstomper

  • 942 posts

Posted Sun Aug 12, 2018 6:07 PM

Mathy, since nearly 30 years, I know to switch the Mac on, but nothing more. Maybe, I can help with a teamviewer session?



#81 Mathy OFFLINE  

Mathy

    River Patroller

  • 2,817 posts
  • Location:Heerlen, NL

Posted Sun Aug 12, 2018 6:22 PM

Hello Roland

 

Mathy, since nearly 30 years, I know to switch the Mac on, but nothing more.

 

Yeh, right!  Try to fool somebody else.   :grin:

 

Maybe, I can help with a teamviewer session?

 

Nope!  If I can't do it myself, I don't want it.  Sorry.

 

Sincerely

 

Mathy

 

 



#82 luckybuck OFFLINE  

luckybuck

    Dragonstomper

  • 942 posts

Posted Sun Aug 12, 2018 6:32 PM

You got me! :-) But the questionmark in my avatar has some meaning... ;-)

 

O. K. good argument. Did you try to download PlayOn and connect it with Altirra? It isn't really a big issue, really, 15 x Mac switching on... I guess... ;-)



#83 luckybuck OFFLINE  

luckybuck

    Dragonstomper

  • 942 posts

Posted Sun Aug 12, 2018 6:46 PM

Another idea: at the JHV, I can tell you, what to do and it is you, who is doing this, while understanding it the same second? Just loud thinking...



#84 pedgarcia ONLINE  

pedgarcia

    Space Invader

  • 27 posts

Posted Tue Jan 1, 2019 3:53 PM

Hi guys,

 

on my own time, I've been working on updating the Atari800MacX emulator. My changes are not as extensive as Ripdubski's since I kept SDL 1.2 but I managed to get the sound back working. There is still an issue with full-screen mode and other things, but it is mostly usable right now.

 

See here a video demo of its current state: https://youtu.be/TwZtZWt5yJs

 

 

 

 

Cheers

 

Paulo

www.vintageisthenewold.com

 

 

 



#85 luckybuck OFFLINE  

luckybuck

    Dragonstomper

  • 942 posts

Posted Tue Jan 1, 2019 4:48 PM

Hi Paulo!

 

WOW! That is the best start of the year, I ever had! :-)))

 

Would you be so kind and tell us, what actually you have changed here:

path.jpg

 

Or even better, can you upload the changed file of the path above, so we can include them into our emulators?

 

In the name of the Mac users THANK YOU!!!!!!!!!!!!! :-))  That is a great finding which brings us the full pleasure back! :-)

 

Thank you Paulo! :-)



#86 luckybuck OFFLINE  

luckybuck

    Dragonstomper

  • 942 posts

Posted Tue Jan 1, 2019 7:26 PM

Is this the file:

Attached File  Preferences.nib.txt   962.43KB   13 downloads

?

 

Many 'sound' findings in the file, if you delete the '.txt' from it and put it in the app's container... ;-)

 

Thank you very much. :-)



#87 pedgarcia ONLINE  

pedgarcia

    Space Invader

  • 27 posts

Posted Tue Jan 1, 2019 7:49 PM

Hey luckybuck,

 

there are many changes I made to the source but to fix the sound I had some patches applied to SDL as well.

 

I've put a preview of the emulator here: http://www.mediafire...review.zip/file

 

 

I will be adding the changes to my github repo later on as well.

 

Cheers

 

Paulo



#88 luckybuck OFFLINE  

luckybuck

    Dragonstomper

  • 942 posts

Posted Tue Jan 1, 2019 7:56 PM

Thank you soooo much! We really appreciate your help for all Mac users. :-)



#89 Savetz OFFLINE  

Savetz

    Stargunner

  • 1,011 posts
  • Location:Portland OR

Posted Tue Jan 1, 2019 8:10 PM

Thank you so much! This is great news.

 

-Kevin

 

Hi guys,

 

on my own time, I've been working on updating the Atari800MacX emulator. My changes are not as extensive as Ripdubski's since I kept SDL 1.2 but I managed to get the sound back working. There is still an issue with full-screen mode and other things, but it is mostly usable right now.

 

 



#90 doctorclu OFFLINE  

doctorclu

    ***Moon Patrol 5200*** *Moon Master2015* *Blue Max:Class 4*

  • 7,676 posts
  • *Star Raiders 2* **Captain -CL 2**
  • Location:*Star Raiders * *Star Commander -CL 1*

Posted Tue Jan 1, 2019 8:21 PM

there are many changes I made to the source but to fix the sound I had some patches applied to SDL as well.

 

We have sound again!!   Woot!!



#91 skr OFFLINE  

skr

    Dragonstomper

  • 650 posts
  • Ready
  • Location:Hamburg

Posted Wed Jan 2, 2019 1:08 AM

Yippieh, it works. :)

Thank you so much!



#92 Jetboot Jack OFFLINE  

Jetboot Jack

    Stargunner

  • 1,833 posts
  • Making Games
  • Location:Disconnected

Posted Wed Jan 2, 2019 11:18 AM

This is awesome - thanks so much for getting this working!

 

I now have three emulators working under OSX  :-D

 

sTeVE



#93 Mathy OFFLINE  

Mathy

    River Patroller

  • 2,817 posts
  • Location:Heerlen, NL

Posted Wed Jan 2, 2019 2:29 PM

Hello Paulo

 

Thank you very much!!!

 

Sincerely

 

Mathy



#94 atarimac OFFLINE  

atarimac

    Chopper Commander

  • 160 posts
  • Location:Missouri, USA

Posted Wed Jan 2, 2019 2:50 PM

Hi All,

   I know I've been for the most part silent for the past 4+ years.  I've had my head down completing my PhD, and then this fall teaching my first semester of classes as a Computer Science professor.

   I finally managed to get enough time over the holidays to make the changes to integrate the new version of libSDL 2.0 into Atari800MacX.  The 2.0 version makes wholesale changes to many things, including rendering, sound, and keypresses, so it took me about 2 weeks of effort to make the changes.  The good news is that moving to 2.0 should enable the emulator to with stand changes to Mac OSX in future versions, assuming that the library authors keep up with them.

   It looks like it was coincidence that people have been busy developing their own fixes around the same time I got time to take a look, and I really appreciate the help, as I have had zero time to do anything the past 4 years.

 

   The changes fix the sound and full screen issues, as well as printer emulation which wasn't working anymore either.  Be aware though it is still Alpha quality software, as the amount of testing I have done is limited (although I'm sure all of you can help there :) ).

 

   I'm just waiting for Al to give me new FTP credentials so I can post version 5.0 of AtariMacX to the web site.

 

Mark



#95 pedgarcia ONLINE  

pedgarcia

    Space Invader

  • 27 posts

Posted Wed Jan 2, 2019 3:21 PM

Hey Mark,

 

that's even better news! I wish I knew you were doing that :) however, I don't think it was a waste the time I spent playing with the source code since I've learned a lot.

 

If the FTP credentials will take longer, would you mind to send me/us the sources so I can update my own repo with that?

 

Cheers

 

Paulo Garcia 



#96 Fletch OFFLINE  

Fletch

    Stargunner

  • Topic Starter
  • 1,052 posts
  • Location:Pennsylvania

Posted Wed Jan 2, 2019 3:29 PM

Holy cow!  What an amazing development.  Thank you so very much.

 

 

Hi All,

   I know I've been for the most part silent for the past 4+ years.  I've had my head down completing my PhD, and then this fall teaching my first semester of classes as a Computer Science professor.

   I finally managed to get enough time over the holidays to make the changes to integrate the new version of libSDL 2.0 into Atari800MacX.  The 2.0 version makes wholesale changes to many things, including rendering, sound, and keypresses, so it took me about 2 weeks of effort to make the changes.  The good news is that moving to 2.0 should enable the emulator to with stand changes to Mac OSX in future versions, assuming that the library authors keep up with them.

   It looks like it was coincidence that people have been busy developing their own fixes around the same time I got time to take a look, and I really appreciate the help, as I have had zero time to do anything the past 4 years.

 

   The changes fix the sound and full screen issues, as well as printer emulation which wasn't working anymore either.  Be aware though it is still Alpha quality software, as the amount of testing I have done is limited (although I'm sure all of you can help there :) ).

 

   I'm just waiting for Al to give me new FTP credentials so I can post version 5.0 of AtariMacX to the web site.

 

Mark



#97 Mathy OFFLINE  

Mathy

    River Patroller

  • 2,817 posts
  • Location:Heerlen, NL

Posted Wed Jan 2, 2019 4:06 PM

Hello guys

 

Maybe Paulo can help Mark to keep Atari800MacX up to date in the future.

 

Sincerely

 

Mathy



#98 luckybuck OFFLINE  

luckybuck

    Dragonstomper

  • 942 posts

Posted Wed Jan 2, 2019 6:25 PM

@ Mark and Paulo: please don't forget to post your PayPal or Bitcoin address, so we can donate to your work. Btw. the emulator is the program I use the most! :-) Thank you so much for bringing back the fun to the Mac users. That is sooooo great! :-))) Best start into a new year ever! :-)



#99 Level42 OFFLINE  

Level42

    River Patroller

  • 2,593 posts
  • Location:Ridderkerk, The Netherlands

Posted Wed Jan 2, 2019 6:43 PM

Great news !



#100 atarimac OFFLINE  

atarimac

    Chopper Commander

  • 160 posts
  • Location:Missouri, USA

Posted Thu Jan 3, 2019 10:33 AM

All,

  I'm still waiting to hear from Al on the website FTP, but for now, you can grab the new release from Github if you like:

 

https://github.com/a...00MacX/releases

 

  Please use the issue system there on github to enter issues you find.  I will update the main web page when I can, but I may move to using github.iio pages as well in the future.

 

  The source has been moved there as well, at least for 4.6 and 5.0.  Paulo has grabbed the source and successfully built it also.  Anyone who would like to get involved in future development, please let us know, or just fork the project.

 

   I'll post some general announcements at the top level of the Emulation forum also in the next day or so.

 

Thanks,
Mark






0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users