Jump to content

Photo

Help: Dumping Cartridges for dummies


30 replies to this topic

#26 santosp OFFLINE  

santosp

    Dragonstomper

  • 777 posts
  • Location:Athens - Greece

Posted Wed May 23, 2018 8:19 PM

I made a video to show how its done


Nir

 

Nir your video not appear anymore online. I hope to not reported as illegal from some heat head!


Edited by santosp, Wed May 23, 2018 8:19 PM.


#27 Marsupilami OFFLINE  

Marsupilami

    Chopper Commander

  • Topic Starter
  • 129 posts
  • looking 4 Atari FR/DE/BX/IT software
  • Location:Brittany, France, Europe

Posted Wed May 23, 2018 9:48 PM

I convert the .rom file to .car, and load it on eclaireXL within cartridge loader.

The cartridge load normally, and choosing the "I" option I see in my screen "Gerat nicht angeschlossen - Prufen!" message.

Not some error.

Thanks @santop. That's the "error" message it should gives (the one with the real cartridge on a real 800xl).

But it's not the message i have in Altirra so i guess Altirra (windows version) is a bit sensitive with the .ROM file.

At least your test shows that my dump is good :)


Edited by Marsupilami, Wed May 23, 2018 9:56 PM.


#28 phaeron OFFLINE  

phaeron

    River Patroller

  • 2,561 posts
  • Location:USA

Posted Wed May 23, 2018 10:30 PM

Thanks @santop. That's the "error" message it should gives (the one with the real cartridge on a real 800xl).

But it's not the message i have in Altirra so i guess Altirra (windows version) is a bit sensitive with the .ROM file.

At least your test shows that my dump is good :)

 

The crash with the garbage at the bottom appears to be a bug in the cartridge that manifests if you have the H: device enabled in the emulator and have also enabled the non-default option to also install it as D:.

 

The bug is that the cartridge's init routine checks for a D: device, and if it finds one, attempts to patch it. Problem is, it revectors D: in HATABS to garbage in the middle of the ROM, which causes a crash. This is done at the same time that E: is patched, so it was probably a remnant of an early attempt at putting DOS on-cart. If you boot DOS off of a disk, this doesn't happen because DOS adds the D: device after cartridge init has occurred. But if it's already there... kaboom.



#29 ndary OFFLINE  

ndary

    Dragonstomper

  • 514 posts
  • Location:Israel

Posted Wed May 23, 2018 10:45 PM

 

Nir your video not appear anymore online. I hope to not reported as illegal from some heat head!

 

not sure why the link changed.. here is the new link:

 

Nir



#30 luckybuck OFFLINE  

luckybuck

    Dragonstomper

  • 878 posts

Posted Tue Jun 19, 2018 12:59 PM

Hi Marsupilami,

 

To my mind, you have done everything right, have taken your rom dump and a DOS II 2.0S disk from Atari (which is written in the manual, of course in German) everything works like a charm with the Atari800MacX emulator on a Mac with 400/800 system, XL and XE. But the disk has to be inserted, before the cart starts. With you incredible help, please see the credits, I was able to finish the Schreiber site yesterday:

https://atariwiki.or...Atari Schreiber

 

Remaining is just: does the cart take 8 KiB oder 16 KiB?

 

This is the picture, when everything is o. k.:

DIR.jpg

 

and this will occur, when, when the Schreiber disk (ATX image) is inserted, starting was from this disk and then made the "Inhaltsverzeichnis":

garbage.jpg

 

If you take away the SCHREIBER disk and insert a DOS II 2.0S disk, everything is o. k. :-)

 

So, you see Marsupilami, you have done everything all right, as always, it is just that German language... Will pass away...


Edited by luckybuck, Tue Jun 19, 2018 1:08 PM.


#31 Marsupilami OFFLINE  

Marsupilami

    Chopper Commander

  • Topic Starter
  • 129 posts
  • looking 4 Atari FR/DE/BX/IT software
  • Location:Brittany, France, Europe

Posted Tue Jun 19, 2018 3:51 PM

Ok Thanks, to both of you, Phaeron (i trully always enjoy your detailed explanations because i learn things) and luckybucky. 






0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users