Jump to content

Photo

Bug found maybe?


8 replies to this topic

#1 Bikerbob OFFLINE  

Bikerbob

    Dragonstomper

  • 693 posts
  • Location:Mississauga ON Canada

Posted Tue Dec 27, 2016 1:05 PM

Hello all,

 

As many reading this know I have been using RespeQt with pclink so that I can access pc directories through SDX 4.48.

 

The current setup I am using is an 800xl with U1mb - with drives 1050(std) Xf551 and Indus GT.  They are usually drives 2,3,4 OR 1,2,3 (sometimes I am booting from a large HD partition on the PC through RespeQt)

 

I am using a serial atarimax device ( a nice donation from a friend ) So i am not using any homebrew eqipment like I have stated in other past posts.

 

Here is the potential bug I think I have found - IT is specific to the Indus GT (or so it seems)

 

So.. if I have say 5 active drives  - 3 hardware (1050,xf,GT) and 2 through RespeQt (NOT PCLINK drives)  Lets say its A:respeQT b:1050 c:xf551 d:Indus GT E:respeQt.

 

IF I try and access drive d:  from a RespeQt drive   so   a: dir d:  it will give me a directory listing but will hang on sector 20 (read from led of Indus) and continue to spin ( I have let it go for as long as 10 mins)

 

If I go from hardware say b: dir d: - no issue I get the dir.. and it parks the head at sec 39 and shuts off.   IF I do it from any hardware to hardware the same.. if I go from a respeQt drive to the 1050 or the xf551 it parks and stops.. but to the Indus GT it does not.

 

Now - if I then go to D: do a dir or disk access direct from that drive - it does the operation and shuts down.. If I go to another hardware drive and access D: while its spinning away.. it will do the operation and then shut down.. BUT if I do more operations from a respeQt drive to the GT it will do the operation but again hang on 20 and continue to spin.

 

What do you think?

 

James

 

 



#2 _The Doctor__ ONLINE  

_The Doctor__

    Flux Capacitor Master Craftsman

  • 6,768 posts
  • Location:10-0-11-00:02

Posted Tue Jan 17, 2017 2:42 AM

you're definitely on to something there....


Edited by _The Doctor__, Tue Jan 17, 2017 2:43 AM.


#3 Kyle22 OFFLINE  

Kyle22

    River Patroller

  • 4,033 posts
  • Call my BBS! telnet://broadway1.lorexddns.net
  • Location:McKees Rocks (Pittsburgh), PA

Posted Tue Jan 17, 2017 12:24 PM

Track 20 is where the AtariDOS directory is located.  What happens if you try it with a Sparta format disk?



#4 Bikerbob OFFLINE  

Bikerbob

    Dragonstomper

  • Topic Starter
  • 693 posts
  • Location:Mississauga ON Canada

Posted Wed Jan 18, 2017 9:51 AM

I will try one. and get back.

 

James



#5 Bikerbob OFFLINE  

Bikerbob

    Dragonstomper

  • Topic Starter
  • 693 posts
  • Location:Mississauga ON Canada

Posted Sat Jan 21, 2017 10:50 PM

In my continuing effort to figure this out.. I found out.. its not QUITE RespeQT... but it might be pclink.

 

I tried this using RespeQT.. but not sparta 4.48 that is on my U1mb.. but I used my spart 4.19 cartridge.. NO problem.

 

Then I loaded Sparta 4.48 again.. but no drivers, no autoexec or config.. no problem.

 

But when I load Sparta 4.48 with the pclink driver.. I get the problem.. so maybe kinda related.. but its the pclink driver issue??

 

James



#6 TheMontezuma ONLINE  

TheMontezuma

    Dragonstomper

  • 676 posts
  • Location:Hildesheim, D / Kraków, PL

Posted Sun Jan 22, 2017 2:14 AM

PCLINK feature is not relevant to your test scenarios (accessing "d:" drives).



#7 Bikerbob OFFLINE  

Bikerbob

    Dragonstomper

  • Topic Starter
  • 693 posts
  • Location:Mississauga ON Canada

Posted Sun Jan 22, 2017 11:30 AM

I think I have found the issue.. although its not where I thought it would be.

It seems to be in the prompt command I issued in my autoexec.bat

prompt $l$p>

This is what is causing the indus GT to hang and continue to spin forever, unless I access the drive from a real drive in the sio chain. If I access the drive from an SIO2pc drive.. I get it hung up.

Now I know this is so odd, it does not effect a significant group.. but interesting none the less.

guess this should move this over to the spartados X thread.

James

Edited by Bikerbob, Sun Jan 22, 2017 12:24 PM.


#8 Joey Z OFFLINE  

Joey Z

    Dragonstomper

  • 876 posts
  • Location:Hoffman Estates, IL

Posted Tue Apr 11, 2017 2:10 PM

has this issue been confirmed to be an SDX problem, or is it potentially an issue with RespeQt still?



#9 Kyle22 OFFLINE  

Kyle22

    River Patroller

  • 4,033 posts
  • Call my BBS! telnet://broadway1.lorexddns.net
  • Location:McKees Rocks (Pittsburgh), PA

Posted Thu Apr 13, 2017 8:26 PM

So, are you saying that if your Indus is A: and your SIO2PC drive is B: that A:>DIR works fine and B:>DIR A: does not?



Reply to this topic



  


0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users