Jump to content

Photo

Balck Screen with ATARI Module


6 replies to this topic

#1 Brood69 OFFLINE  

Brood69

    Space Invader

  • 13 posts

Posted Fri Feb 24, 2017 12:35 AM

Hi guys,

 

I have a great fully working French/Scart Colecovision.

 

My problem is coming with the Module #1 : when plugging it, I just get a black screen and it won't read any game cartridge.

 

Unplugged, I get my Colecovision back as usual...

 

I already cleaned up the connectors many times, both in th extension slot and the Atari module,  and did not identify any other potential issues.

 

Anyone can help ?



#2 SiLic0ne t0aD85 OFFLINE  

SiLic0ne t0aD85

    River Patroller

  • 2,046 posts
  • Rock 'N Roller, Space Patroller
  • Location:Ohio Valley

Posted Fri Feb 24, 2017 4:26 AM

Replacing the capacitors inside wouldn't hurt.

#3 Brood69 OFFLINE  

Brood69

    Space Invader

  • Topic Starter
  • 13 posts

Posted Fri Feb 24, 2017 6:53 AM

I initially thought the Atari Module was just a rewiring...but indeed, after opening it, there is way more than that !

 

Mine looks brand new (I have it in box) and I will start looking at the electronic components.

 

Any other ideas welcome



#4 ten-four OFFLINE  

ten-four

    Dragonstomper

  • 886 posts
  • Here i am... again!
  • Location:Aalborg, Denmark.

Posted Fri Feb 24, 2017 7:27 AM

Hi Brood69.

:) 

You need a French CBS Atari Module for your French CBS Scart ColecoVision.

I am in the same boat as you, I have had several ColecoVisions.
But when I bought the French CBS Scart version few years back and would try my UK CBS Atari module it was all black screen.
​The French pin out is not the same as the U.S. and the "normal" CBS version.
​I do not have the French CBS Atari Module myself so.

 

it should be possible to change, but I have not had time to even look at it



#5 Brood69 OFFLINE  

Brood69

    Space Invader

  • Topic Starter
  • 13 posts

Posted Fri Feb 24, 2017 3:39 PM

Damned, I am done !!

 

Will check my Atari module but that must be it...

 

So I have an almost new module #1 for sale :-)



#6 Brood69 OFFLINE  

Brood69

    Space Invader

  • Topic Starter
  • 13 posts

Posted Tue Feb 28, 2017 2:53 AM

In fact no...I had a French version of the Expansion Module 1 too !

 

So it does not work...I need to check the Inside.

 

One quick question : when you switch on the Colecovision with the module connected but no Game cartridge inserted, do you get anything else than a blanck screen ?



#7 ten-four OFFLINE  

ten-four

    Dragonstomper

  • 886 posts
  • Here i am... again!
  • Location:Aalborg, Denmark.

Posted Tue Feb 28, 2017 2:36 PM

French CBS ColecoVision turned on and U.K. CBS Exp. Module 1 connected.

There is both Black screen with or without Atari cartridge inserted. (PAL Silver).

 

I know the sound can't work, but it can be fixed.

:) 






0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users