Jump to content

Photo

Visual Batari Basic, won't open or compile


6 replies to this topic

#1 Tangentg OFFLINE  

Tangentg

    Moonsweeper

  • 329 posts

Posted Wed Apr 12, 2017 8:10 AM

So I got Visual Batari Basic from the Tinkernut website yesterday and whenever I try to open a file, it gives me this error. (See draft_5)

 

When I try to run a tutorial code, it says the code "is not the latest version" and asks if I want to compile.

 

And every time I try compiling, it says "path is not legal".

 

What could be done to fix these? Thanks

 

Attached Thumbnails

  • draft_5.png


#2 Random Terrain OFFLINE  

Random Terrain

    Visual batari Basic User

  • 27,903 posts
  • Controlled Randomness
    Replay Value
    Nonlinear
  • Location:North Carolina (USA)

Posted Wed Apr 12, 2017 11:04 AM

Read this:

 

randomterrain.com/atari-2600-memories-batari-basic-commands.html#do_not_use_tinkernut_installer



#3 freshbrood OFFLINE  

freshbrood

    Space Invader

  • 43 posts

Posted Wed Apr 26, 2017 9:49 PM

Windows 7, 64bit. 

 

Visual Batari Basic will NOT save settings. This is driving me insane. 

 

Each and every time I start it, I get the "It looks like you are running VisualbB for the first time.. etc.." and I have to go through the config options again.

 

BatariBasic is in it's own folder in DOWNLOADS

 

VisualBatariBasic is in it's own folder in DOWNLOADS

 

Stella installed in PROGRAM FILES

 

I can properly set both paths, but the moment I close it then open it again, I need to reset everything.

 

 

Also, when I try to test it in Stella, I get the Missing Binary "Could not locate default.bas.bin" message.

 

Please help. What am I doing wrong?


Edited by freshbrood, Wed Apr 26, 2017 10:04 PM.


#4 Random Terrain OFFLINE  

Random Terrain

    Visual batari Basic User

  • 27,903 posts
  • Controlled Randomness
    Replay Value
    Nonlinear
  • Location:North Carolina (USA)

Posted Wed Apr 26, 2017 11:57 PM

Windows 7, 64bit. 

 

Visual Batari Basic will NOT save settings. This is driving me insane. 

 

Each and every time I start it, I get the "It looks like you are running VisualbB for the first time.. etc.." and I have to go through the config options again.

 

BatariBasic is in it's own folder in DOWNLOADS

 

VisualBatariBasic is in it's own folder in DOWNLOADS

 

Stella installed in PROGRAM FILES

 

I can properly set both paths, but the moment I close it then open it again, I need to reset everything.

 

 

Also, when I try to test it in Stella, I get the Missing Binary "Could not locate default.bas.bin" message.

 

Please help. What am I doing wrong?

 

I have an idea. Open your bB folder, right click at top on the file path and copy the address as text then post it here. Do the same for your VbB folder. Once we get that out of the way, we can try other things.



#5 freshbrood OFFLINE  

freshbrood

    Space Invader

  • 43 posts

Posted Thu Apr 27, 2017 1:22 AM

 

I have an idea. Open your bB folder, right click at top on the file path and copy the address as text then post it here. Do the same for your VbB folder. Once we get that out of the way, we can try other things.

 

C:\Users\FreshbroodsPCt\Downloads\batari_Basic_version_1.0

 

C:\Users\newport\Downloads\VisualbB_1.0_Build_554


Edited by freshbrood, Thu Apr 27, 2017 1:38 AM.


#6 Random Terrain OFFLINE  

Random Terrain

    Visual batari Basic User

  • 27,903 posts
  • Controlled Randomness
    Replay Value
    Nonlinear
  • Location:North Carolina (USA)

Posted Thu Apr 27, 2017 2:29 AM

 

C:\Users\FreshbroodsPCt\Downloads\batari_Basic_version_1.0

 

C:\Users\newport\Downloads\VisualbB_1.0_Build_554

 

Try using this version of VbB instead:

 

atariage.com/forums/topic/123849-visual-bb-10-a-new-ide-for-batari-basic/?p=3537039

 

 

And have you looked at this section of the bB page:

 

randomterrain.com/atari-2600-memories-batari-basic-commands.html#gettingstarted



#7 Gemintronic OFFLINE  

Gemintronic

    Jason S. - Lead Developer & CEO

  • 8,812 posts

Posted Tue May 23, 2017 10:09 AM

Also, there's my workaround here:

Hack for VisualbB not saving settings (usually on modern/x64 systems)

http://atariage.com/...ernx64-systems/

 

It fell off the first page so it might have gotten lost among other solutions.






0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users