Jump to content

Photo

Catastrophic fail. Any brilliant ideas to fix broken TI?

stupidity TI-99/4a F18A

21 replies to this topic

#1 silentsolace OFFLINE  

silentsolace

    Space Invader

  • 16 posts

Posted Thu Apr 27, 2017 8:43 AM

I've got two TIs with the same ailment. Black screen on power on with the unending tone. Both occurred in relation to an F18A mod (but I would guess the F18A is not the cause) and I was wondering if anyone had some brilliant advice that could save the day, or advice in avoiding future tragedy.

 

Story Time - Not for the faint of heart, you have been warned.

 

Beginning this year I got the urge to start playing with my TI-99/4A again, my TI had been sitting idle and collecting dust for a few years ever since it's TV went away.  It was a stock TI, no expansions apart from the speech; and I was really interested in improving it to explore the community offerings.  I read about this fabulous modification called the F18A that completely overhauled the TI's video out. It didn't seem too difficult, so I ordered one as soon as they came available and waited patiently.

 

After a time I received the magic F18A and dutifully opened my TI, removed the VDP, and installed the F18A. I then dremeled some holes for the VGA cable and snaked it to the back of my console. Shield, attach, close up, power on,  total victory! Everything seemed to work without complaint and I was playing Tunnels of Doom on my computer monitor the same evening. What followed were some good times, a month or so of vintage happiness. It was not to last.

 

A few weeks ago I powered on my TI so I could continue one of my latest Quests for the King. Black screen, blaring tone. As near as I can tell this was a spontaneous failure as nothing had changed - the system hadn't been opened since the F18A and it had powered on fine the evening before; no new expansions or cable changes. The internet informed me this dreaded error could mean virtually anything wrong with the system. I opened the system and did the only diagnostic steps I could handle. I replaced the original VDP and tried to power on. Nothing. Tried putting the F18A back and powering on. Nothing. I started re-seating the GROMs and clock chip. As I gently pried and lifted the first GROM it suddenly flipped 180 and attacked me, impaling my poor finger. I quickly deduced the reason, I had snapped off two of the pins. Disaster. Nonetheless, I carried on to see if any change in the system state could be discerned from the re-seating. The TI was unmoved by my efforts and continued with the black screen and harsh tone. As I was working with the TI motherboard, and under unremembered circumstances. I took hold of the keyboard ribbon cable to attach to the motherboard and instead had it come away in my fingers. Catastrophe. The keyboard ribbon cable had sheared off from the solder points on the keyboard. I sadly realized that my efforts had probably already killed my patient, I honestly am not equipped or knowledgeable enough for computer surgery, and should no longer indulge in this pointless torture. I resolved to visit eBay and order another TI.

 

A scan of ebay revealed that TIs generally would cost $50 after shipping. I decided to go ahead and order a lot of 2 that were both claimed to be working but were missing some accessories (only 1 power supply and no RF) and one was missing keycaps. I bid, I won, and I waited.

 

Yesterday the TIs have arrived. I verified that they were indeed functional as stock units (although the busted keycap one seemed to have some video issues). I set about opening the better of the pair to transplant my F18A. Unscrew, open, unshield, pry.  Everything proceeding smoothly I gently pried up the F18A from it's old host and I let out a cry of genuine anguish.  One of the pins was gone (nothing else bent or damaged that I saw, just cruel fate), the F18A had been wounded in this latest action. What follows is my descent into pure madness and unmitigated stupidity. Faced with the missing pin, and desiring to install the F18A in the fresh patient IMMEDIATELY, I resolved to solder a replacement pin to the F18A board.  Now some background, in years past some fool gifted me a inexpensive soldering iron as they knew my interest in vintage computing and thought I would find the tool useful. This tool would become a murder (of my poor TI) weapon.  I have no training or formal education, and my past successful efforts with the tool have been only to solder wires together. A pin isn't that much different from a wire though? Of course not. So I cut a pin from a bit of discarded electronics I had laying around and proceeded to attempt to solder it to the board. What followed was an hour of trembling hands, cursing, fiddling, and jabbing a hot iron at the little board to try and get the pin to stick and not be crooked.  Each passable attempt ended in failure, resulting in a black screen (but accompanied by the TI's lovely startup chirp). These efforts were interspersed with periodic sanity checks with the original VDP which I would insert to verify that I had not inflicted fatal injury. This continued until finally a measure of success. Video, but not that which brings joy, but a hideous abomination that shrivels the soul. The system powered on, but showed a title screen that was corrupted. The colors were wrong, the characters were garbled. Further desperate action improved nothing: from garbled screen, to blank blue screen, to black screen, to F18A ready screen, to garbled screen; round and round till I resolved myself and admitted defeat.

 

However, the drama still had one final cruel twist of fate.

 

I placed another F18A order and replaced the original VDP. Only this time instead of the grainy title screen I was greeted by doom's horrible screech. Black screen, blaring tone. Panic. I tried replacing the F18A. Black screen, blaring tone. Re-seat all the socketed chips. Black screen, blaring tone. Swap power supplies. Black screen, blaring tone.  To my shame it seems I have killed another patient. Now I confess my eyes have shifted to my last misshapen TI to perhaps harvest its organs to fuel my mad designs. One potential slight glimmer of growth, I have decided to err on the side of wisdom and solicit my  betters, and prevail upon their wisdom to see if there is any way I may undo this horror, or at least advice that I may prevent another one.

 

Well? What say you?

 

 

TL;DR - I am an idiot. Due to botched install+repair I'm soliciting help/advice in fixing my TIs. Black screens, blaring tones.



#2 --- Ω --- OFFLINE  

--- Ω ---

    TI-Runner

  • 10,618 posts

Posted Thu Apr 27, 2017 9:33 AM

Oh man....  



#3 jedimatt42 ONLINE  

jedimatt42

    Stargunner

  • 1,260 posts
  • Location:Beaverton, OR

Posted Thu Apr 27, 2017 2:32 PM

I would find a beige console, QI or not. Transplant the motherboard, and if v2.2 GROMs, transplant the socketed GROM chips.

---

I don't know how to fix the tone of death. I understand that it simply means the CPU doesn't get as far as the code that turns the sound chip off.

My assumption on order of likelihood is:
The ROMs
The SRAM
The CPU
The GROMs ( sone one here must know if you need groms to get the sound chip turned off during boot? )
Decoding logic

I've heard that we should be expecting all our roms to fail any day now. Do our TIs have mask ROMs, or PROMs?

I cannot site any references. I'm probably just spewing uneducated noise from the internet..

I'd love to know if any engineers here have educated info on the subject!

-M@

#4 matthew180 OFFLINE  

matthew180

    River Patroller

  • 2,408 posts
  • Location:Castaic, California

Posted Thu Apr 27, 2017 3:03 PM

I have a flat-fee repair service for the F18A on my web store.  Unless you damaged the PCB (too much heat on a pad for too long, etc.) then I can test and repair it.  I can also provide Digikey part numbers for any component (like the PCB pins) if you want to replace any parts yourself.

 

As you learned, PCB rework is not trivial and you should practice before working on the small SMD parts.  It is not terribly hard, most people's errors are due to impatience, lack of some basics, and using a war-ball & chain where a dagger was needed.

 

The screeching tone is because the sound chip powers-on making a tone by default.  One of the first tasks of the computer is to turn the sound chip off.  Thus, the "beep" you hear when the 99/4A powers on is not actually 99/4A programming that tone, but rather the time it takes for the startup ROM routines to get around to turning the screaming sound chip off.  Setting up the VDP and writing to the screen happens some time later in the startup.  It all seems rather instant by human perception.

 

Since you have a black screen and screaming sound chip, that means the 9900 never executed enough startup instructions to turn the sound chip off.  That means:

 

0. The system is being held in reset

1. The 9900 CPU is dead

2. A ROM is dead

3. A logic chip is dead

4. Bad power or power-distribution (those while strips all of the board are power distribution and your computer will fail if you break the little feet on them)

 

When you remove ICs from sockets, you should do so with a small screw driver and carefully pry them *evenly* from both sides.  Or use a chip-puller.  Same goes for cables (especially the keyboard cable), *never* pull them by the cable, always grab the connector part, pull evenly or rock back-and-forth to remove it straight.

 

The PCB pins on the F18A bend very easily, so be careful with the board.

 

There are tons of videos on the Internet on how to solder, do PCB rework, remove ICs from socket, etc.  Invest some time watching them.  There are also many threads here in the forums covering soldering, tools, procedures, etc.

 

Finally, I'm sure there are people who will repair you computer and/or install the F18A upgrade.



#5 Tursi OFFLINE  

Tursi

    River Patroller

  • 4,828 posts
  • HarmlessLion
  • Location:BUR

Posted Thu Apr 27, 2017 4:14 PM

It's worth adding that the code which mutes the sound is in GPL, so GROM 0 must also be working (as wondered) as well as scratchpad RAM (although I guess that's obvious). 



#6 silentsolace OFFLINE  

silentsolace

    Space Invader

  • Topic Starter
  • 16 posts

Posted Thu Apr 27, 2017 5:37 PM

 

I have a flat-fee repair service for the F18A on my web store.

 

I may take advantage of that once my pessimism subsides and the need for reminders of my hubris is past. I said black screen and tone, but the f18a does bring up the waiting for init screen most of the time when it's in so that may actually be an encouraging sign. At the very least it may be worthwhile to know if it's salvageable.

 

 

As you learned, PCB rework is not trivial and you should practice before working on the small SMD parts.  It is not terribly hard, most people's errors are due to impatience, lack of some basics, and using a war-ball & chain where a dagger was needed.

This. My niggling inner voice knew it was stupid and probably a bridge too far when I was pulling out the soldering iron, but I was upset and impatient with the new problem and was bent on getting results. My only successful electronic repair work/modding has involved electrical taping wires to fix broken connections or bypass. Not in any way secure but it has worked. In retrospect I maybe should of tried something of that nature to verify the fix before pulling the iron.

 

 

When you remove ICs from sockets, you should do so with a small screw driver and carefully pry them *evenly* from both sides.  Or use a chip-puller.  Same goes for cables (especially the keyboard cable), *never* pull them by the cable, always grab the connector part, pull evenly or rock back-and-forth to remove it straight.

Yep. I think my mistake is I didn't loosen it enough. I recall loosening slightly with a small screwdriver on both sides and it didn't want to give, so rather than loosening more I pulled harder and the thing popped, flipped, and stabbed my finger with its pins and bent a few off. I learned the lesson and haven't had a problem with any other of the removable chips since. The keyboard ribbon cable didn't surprise me and doesn't really upset me. When I opened it up the first time I noticed it was super brittle, and I disconnected it while pulling from the connector and only noticed it had come  away when I went to reconnect it.

 

 

The PCB pins on the F18A bend very easily, so be careful with the board.

As I have learned. I have two guesses. 1. When I was swapping between F18A and original VDP trying various diagnostic steps,  I suspect the last time I inserted it into the old TI it didn't slide in cleanly and instead pin20 bent and snapped off.  Or 2. When I pull the PCB off my fist instinct is to immediately flip it to make sure I didn't bend or damage anything, I may of started flipping too soon which caught pin 20 and snapped it off. In short, instead of the kid gloves I used on the initial install I was getting kind of cavalier handling the PCB.

 

 

Expensive, upsetting, and embarrassing mistakes to be sure. At this point I'm more worried about my touch of death. If I pull out the last TI and its motherboard, and even if I do successfully install the F18A again. Will it end up breaking on me within the month? I don't think I was inflicting any collateral damage (a laughable claim based on my earlier story, I am sure), but everything in these things is so old it's hard to say.  If there were someone or somewhere I could send my TIs to be repaired I might be willing to spring on it simply to salvage something from this disaster and ensure success. However, my niggling doubts say that vintage computing is not a profit making enterprise and there are probably precious few who can make any substantial opinion as to the ongoing viability of a 36 year computer after an internal modification.

 

At the moment I'm kind of trying to stay away from the TIs for a while to try and clear my head and let go of my guilt. I did bust out my little tester and verified that the power is good and it seems getting to the CPU okay. One document I found says I should check my clock signals but I'm not 100% on what I'm looking for and my multimeter is a rather cheap and limited one so it may not have the range to accurately measure for the clock.

 



#7 eightbit OFFLINE  

eightbit

    River Patroller

  • 2,638 posts
  • Location:Little Falls, NJ

Posted Thu Apr 27, 2017 9:29 PM

This type of stuff happens to the best of us. I have had mishaps in the past, most recently with a socket replacement on an Amiga 2000 motherboard. Granted the socket was "patched" in a bad way by whomever owned it last and that didn't make matters any better, but I rushed out of frustration as well and ended up destroying quite a few traces. There were other issues with that board as well so it is not exactly your scenario, but I am just saying that I know what it feels like to want to throw in the towel and feel like I made the situation that much worse.

 

I have learned from these mistakes and try my best not to make them again in the future. One of the most important lessons I have learned when working with electronics (and especially old electronics) is to take your time. Seriously, really go slow and take your time. I know it gets frustrating when something does not work and you just want to "make it work" so you start going to extremes. But that always makes matters worse than they were previously. If anything you got a good learning experience out of this that you will carry along with you when performing work of this type in the future on this or other vintage (or modern) equipment.

 

There are a lot of things you could have done differently but I won't throw salt on the wound so to speak. I would definitely suggest taking Matthew up on the F18A repair (if it can be repaired hopefully) as that part is worth double or triple the TI99/4A's worth (monetarily I mean). When it is hopefully repaired start again with a good known working TI99 and really take your time and care installing it and then try to forget this bad dream ;)

 

Will another one "die" on you on a month? Well, nobody can give you a guarantee on vintage electonics (be it computer OR game system) but generally it is rare from my experience with the TI. And if it does happen, just grab another TI. While other computers (Amiga I am looking at you) you would definitely want to look into repair options due to the cost/rarity of trying to obtain replacement machines, the TI is still so common and cheap and easy to obtain that I would say it is more cost effective to just buy another one than repair a current one. At least at *this* point in time. Just my thoughts on that matter.


Edited by eightbit, Thu Apr 27, 2017 9:46 PM.


#8 Shift838 OFFLINE  

Shift838

    Stargunner

  • 1,951 posts
  • SHIFT838
  • Location:Texas

Posted Thu Apr 27, 2017 9:46 PM

Oh Damn!

 

You have a flair for words.  As I read your nightmare I can only hope you are able to recover.

 

I think all of us that have upgraded the TI have done something and screw something up.  I  know I have.

 

You have come to the right place for advice and  help.

 

I have had to take the innards out of one TI to fix another as well.



#9 InsaneMultitasker OFFLINE  

InsaneMultitasker

    Stargunner

  • 1,731 posts

Posted Thu Apr 27, 2017 10:03 PM

I often use a thin, flat-head screwdriver with a head width of 1/4" to 3/8".   I grip the card and apply gentle pressure to the top of the chip (on the side I am prying) using my left thumb, and with the other hand use the screwdriver to gently pry the chip, one side then another, repeating until the chip is removed.   The pressure helps to ensure a gradual removal from the socket, minimizing accidental bends or damage while you 'rock' the chip with the prying motion.  Chips don't like to be rough-housed.  ;)  If you pry by pushing the blade down toward the board, you must be careful not to damage the traces underneath.

 

If you are gentle, the width of the screwdriver can also allow you to rotate the head slightly while the blade is underneath, allowing you to lift the IC from the socket by applying pressure between the chip and the edge of the socket. I usually only use this method for narrow chips since it does put higher pressure on one single spot of the chip. 

 

Some dental tools can be useful for IC extraction and desoldered chip removal, as they often have an angular tip that lets you work in tight spaces a screwdriver may not be able to get into.



#10 Keatah OFFLINE  

Keatah

    Quadrunner

  • 18,726 posts

Posted Thu Apr 27, 2017 10:13 PM

Sometimes I'll push the chip down firmly, this makes a cracking sound as all the oxidation on the pins and socket breaks. Then you can wiggle it out, going back and forth on both sides. I even prefer this to an extraction tool, which can (visibly!) bend the chip in the center while you lift. And sometimes those tools slip. I only use them on the smaller chips, no bigger than a standard ROM. The 40-pinners get special hand attention.

 

A little bit of DeOxit can also help, now, and in the future years later.

 

And don't forget to properly ground yourself. And on these classic rigs, I also inspect the solder joints before and after IC removal.



#11 silentsolace OFFLINE  

silentsolace

    Space Invader

  • Topic Starter
  • 16 posts

Posted Mon May 1, 2017 7:07 PM

Semi happy ending!

 

 

I was poking at my dead TI and I noticed something that I didn't notice earlier. The -5V line was reporting +5mV rather than -5V. I tested the other lines and everything checked out for the other powers - could this be my culprit? Could my power board of blown?

 

Attached File  IMG_3018.JPG   148.7KB   1 downloadsAttached File  IMG_3019.JPG   147.97KB   1 downloadsAttached File  IMG_3020.JPG   148.65KB   1 downloads

 

Well, I pulled out the prior TI and pulled its power board. Unfortunately the power board was apparently of an older vintage because it wouldn't work with the motherboard's connector without some conversion. However, I was able to use it to test and sanity check my finding.

 

Attached File  IMG_3021.JPG   117.7KB   1 downloadsAttached File  IMG_3022.JPG   114.01KB   1 downloadsAttached File  IMG_3023.JPG   93.49KB   1 downloads

 

Yes, -5V. I definitely lost my -5V line which could be the cause of my lament. So I opened up the third TI and checked out it's power board, and fortune smiled upon me. It's compatible and fully functional. I now have 1 TI back in business, and if I can get a hold of another power board I can get two in working order.

 

Attached File  IMG_3024.JPG   95.56KB   1 downloads

 

(Apologies for potato quality)

 

I took much of the advice given here to heart and I was able to re-assemble and put the TI back in working order!



#12 Ksarul OFFLINE  

Ksarul

    River Patroller

  • 4,217 posts

Posted Mon May 1, 2017 7:31 PM

Here is a nice bunch of power supply boards of the type you're looking for. . .six of them for $18, shipped.



#13 Opry99er OFFLINE  

Opry99er

    Quadrunner

  • 8,261 posts
  • Location:Cookeville, TN

Posted Mon May 1, 2017 8:38 PM

Excellent ending!!

#14 dphirschler OFFLINE  

dphirschler

    Moonsweeper

  • 376 posts
  • Location:Kennesaw, GA

Posted Wed May 3, 2017 4:17 PM

Hey, I am no repair expert, but I had similar symptoms in the past and it turned out to be a bad sound ship.  I just replaced it (using one from a donor board) and it was back up and running.

 

Darryl

 

EDIT - oh never mind.  I just read the update.


Edited by dphirschler, Wed May 3, 2017 4:19 PM.


#15 Sinphaltimus OFFLINE  

Sinphaltimus

    Stargunner

  • 1,971 posts
  • Distracted at the Keyboard
  • Location:Poconos, PA

Posted Thu May 4, 2017 10:40 AM

I once attempted the internal 32k mod on my currently primary system. It didn't work, it had something to do with my terrible soldering skills at the time (not so terrible now but thanks to these forums I'm better than I was). Long story short, I desoldered everything and removed the chips, TI was dead, i killed it. After some back and forth communications and careful inspection, I found I burned some traces off the board and had broken connections. Soldered jumper wires in place and brought it back to life. So I know how it feels to kill your own console and I know how great it feels to bring it back to life. It's now my primary system that takes all the mods I can throw at it. congrats on your resurrection. I am excited for and with you.



#16 x24b OFFLINE  

x24b

    Star Raider

  • 74 posts
  • Location:Apple Valley, CA

Posted Sun May 7, 2017 11:32 AM

Many moons ago, I attempted to build a Zeno board for my TI. It ended in failure, but I always felt it was a simple error somewhere. This thread gets me thinking and hopeful that I might be able to resurrect it. Maybe I'll get some time at the end of summer...

 

Anyone have experience with a Zeno?

Attached Files



#17 tep392 ONLINE  

tep392

    River Patroller

  • 2,800 posts
  • Location:Peoria, IL

Posted Sun May 7, 2017 11:50 AM

At least you learned a good lesson. Always check the power supply first. :)

#18 Ksarul OFFLINE  

Ksarul

    River Patroller

  • 4,217 posts

Posted Sun May 7, 2017 12:22 PM

There are a couple of traces on a Zeno where you have to be VERY careful not to get a solder bridge. Just look for the spots where two traces go between the same two legs of one of the ICs together. . .and for that matter, any possible solder bridges need to be looked for/eliminated. 



#19 iKarith OFFLINE  

iKarith

    Moonsweeper

  • 271 posts
  • Location:Portland OR

Posted Mon May 8, 2017 9:23 AM

I would find a beige console, QI or not. Transplant the motherboard, and if v2.2 GROMs, transplant the socketed GROM chips.

 

Arrrr, thread hijacked!  (Sort of.)

 

I am actually looking for a QI motherboard somewhat halfheartedly with designs on showing how to QI the QI hopefully with a process so easy a blind man can do it.  Just need to find a nice big solder point for the missing signal and show how to get a replacement ROM in there.

 

This is a process that should become easy IMO, and as common (for QI consoles at least) as alpha lock diodes.



#20 x24b OFFLINE  

x24b

    Star Raider

  • 74 posts
  • Location:Apple Valley, CA

Posted Mon May 8, 2017 2:56 PM

Ksarul I'll be looking for that. Thanks!

#21 CRams OFFLINE  

CRams

    Combat Commando

  • 5 posts

Posted Tue May 9, 2017 11:06 AM

Prolly bad caps on your board.  Check for swollen leaking Caps or open vents.  Get a Cap checker. 

Capacitors tend to decay, even when not in use plus there were a couple capacitor plagues from Asia.  

Its the most common failure of PC power supplies when you lose 5 or 12 v.  



#22 CC Clarke OFFLINE  

CC Clarke

    Space Invader

  • 33 posts
  • Location:Hartford, CT

Posted Wed May 10, 2017 5:56 PM

Always check power and timing first.  You can use a logic probe to verify the clock signals, but an oscope with a freq counter is ideal.  Before you get too far, pull the 2156, 2157, and sound chip out if socketed.  (The home screen is contained in the 2155 GROM.)  If a GROM or sound chip is bad, they can hold the bus down. 

 

After verifying the power and timing, (3 Mhz CPU clocks can be quickly checked on the clock chip, then four pins on the 9900 CPU) verify GROM select is on the GROM sockets, followed by READY on the CPU.  Loss of READY will prevent power up, resulting in a "Dead", described above by the OP.  If READY is missing or wrong, (Like GROM Select, it has a very noticeable signature on a scope.) First piggy-back then power up both ROMs, and if that doesn't work, replace them one at a time, followed by the 6810 scratchpad RAMs.

 

CCC







Also tagged with one or more of these keywords: stupidity, TI-99/4a, F18A

0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users