Jump to content

Photo

Programming a game and when I run it, it doesn't work.


3 replies to this topic

#1 tuckrix7865 OFFLINE  

tuckrix7865

    Combat Commando

  • 1 posts

Posted Sat Apr 29, 2017 1:46 PM

I am programming a very simple game and am learning from the Tinkernut tutorial. I believe that I downloaded the correct version of batari (Not the one provided by Tinkernut) and have followed his instructions in creating a background. However, when I load the game up in my emulator (StellaX), I get about one line across the screen and it some what flickers. Below is a copy of my current code and attached to this post is the screen that I see. 

 

       Thank you ahead of time, 

           Tuckrix

 playfield:
 XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
 XXXXXXXXXXX...........XXXXXXXXXX
 XXXXXXXXXX...XXXXXXX...XXXXXXXXX
 XXXXXXXXX...XXXXXXXXX...XXXXXXXX
 XXXXXXXX....X..XXX..X....XXXXXXX
 XXXXXXXX....XXXX.XXXX....XXXXXXX
 XXXXXXXX.....XXXXXXX.....XXXXXXX
 XXXXXXXXX.....X.X.X.....XXXXXXXX
 XXXXXXXXXX....XXXXX....XXXXXXXXX
 XXXXXXXXXXXX..........XXXXXXXXXX
 XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
end

 COLUBK  = $0E
 COLUPF  =  $E6

draw_loop
 drawscreen
 goto draw_loop

Attached Thumbnails

  • Problem.png


#2 bogax OFFLINE  

bogax

    Dragonstomper

  • 710 posts

Posted Sat Apr 29, 2017 2:15 PM

works for me with bB.1.1d.reveng37 and Stella 4.5



#3 Random Terrain ONLINE  

Random Terrain

    Visual batari Basic User

  • 28,170 posts
  • Controlled Randomness
    Replay Value
    Nonlinear
  • Location:North Carolina (USA)

Posted Sat Apr 29, 2017 3:07 PM

Have you read this:

 

atariage.com/forums/topic/264361-please-do-not-use-the-tinkernut-installer/



#4 stephena OFFLINE  

stephena

    River Patroller

  • 2,974 posts
  • Stella maintainer
  • Location:Newfoundland, Canada

Posted Sat Apr 29, 2017 3:43 PM

If this wasn't a typo, and you're actually using StellaX (note the 'X'), then this version of Stella is horribly out of date (version 1.1 or so).  Update to the latest 4.7.3, or soon to be 5.0.






0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users