Jump to content

Photo

Some games load but won't play on 2600


1 reply to this topic

#1 AndyEich OFFLINE  

AndyEich

    Combat Commando

  • 1 posts

Posted Sun Jul 16, 2017 7:25 PM

Hi--
 
I have a variant of the issue reported by other users where some games will load but not play.  I was hoping that someone might see a pattern in which work, and which don't, that might suggest which chip needs to be replaced (or other maintenance action).
 
These games work perfectly:
Pac Man
Vanguard
ET
Plaque Attack
Demon Attack
Decathlon
Sorcerer
Astroids
Football
Baseball
 
These games do not:
Firefly
Alpha Beam
Combat
Raiders of the Lost Ark
Space Invaders
 
They all load and display graphics / play music, and the game select/reset buttons on the unit work.  However, for the games listed as not working, it's as if the joystick and button presses don't have any effect, and thus you can't play the game.  The Joystick and button work fine on the other games.
 
I've cleaned all cartridge contacts repeatedly with alcohol, and I've opened up the box and joystick, cleaned them, and see nothing amiss.
 
Do you all see a pattern that would help diagnose what's wrong?  Thanks!
 


#2 toiletunes OFFLINE  

toiletunes

    River Patroller

  • 3,048 posts
  • Hater Brigader
  • Location:Salem, Mo 65560 USA

Posted Sun Jul 16, 2017 8:11 PM

Just to be sure, Raiders uses the right joystick and Alpha Beam uses a keypad controller.


  • jhd likes this




0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users