Jump to content

Photo

No apostrophes when posting to AA from ios11


17 replies to this topic

#1 Flojomojo OFFLINE  

Flojomojo

    I say boom boom boom

  • 10,312 posts
  • You say bam bam bam

Posted Wed Sep 13, 2017 4:54 AM

This has been happening for the last few betas of ios11 (iPhone/iPad) and continues with the GM which came out yesterday, so I dont think it will be fixed from Apples side. I think it could be an issue with AtariAges forum software.

Im a pretty careful mobile typist but have taken tonavoiding contractions like wont cant Im and isnt here. They show up when composing a message, but disappear when posted. Very weird and seems isolated to this site as I havent seen it anywhere else.

iOS is released for all users soon so it would be great to get ahead of this.



#2 Flojomojo OFFLINE  

Flojomojo

    I say boom boom boom

  • Topic Starter
  • 10,312 posts
  • You say bam bam bam

Posted Wed Sep 13, 2017 6:12 AM

Testing from iOS Chrome to see if its just mobile Safari, or the whole iOS.

Cant
Wont
Didnt
Im

#3 Flojomojo OFFLINE  

Flojomojo

    I say boom boom boom

  • Topic Starter
  • 10,312 posts
  • You say bam bam bam

Posted Wed Sep 13, 2017 6:13 AM

Looks like it's iOS 11 in general.  :?



#4 carlsson ONLINE  

carlsson

    Quadrunner

  • 5,024 posts
  • Location:Västerås, Sweden

Posted Fri Sep 15, 2017 3:04 AM

Perhaps you should try Don\'t and Don\\'t in case some browser layer magic quotes is trying to remove spurious, "dangerous" (SQL injections) quotes?



#5 Flojomojo OFFLINE  

Flojomojo

    I say boom boom boom

  • Topic Starter
  • 10,312 posts
  • You say bam bam bam

Posted Fri Sep 29, 2017 2:27 PM

Perhaps you should try Don\'t and Don\\'t in case some browser layer magic quotes is trying to remove spurious, "dangerous" (SQL injections) quotes?

Okay, lets try that

Don\t
Don\\t

Yeah, thats not awkward at all. :lolblue:

No one else is posting from a new-ish iPhone?

Anyone?

Hope this gets fixed, I look like an idiot! (I mean, more so than usual!)

#6 cmart604 OFFLINE  

cmart604

    Intellivision Hoarder

  • 11,409 posts
  • But Atari Rules!
  • Location:Vancouver

Posted Fri Sep 29, 2017 10:30 PM

Yep its happening for me as well

#7 SpiceWare ONLINE  

SpiceWare

    Draconian

  • 11,572 posts
  • Medieval Mayhem
  • Location:Planet Houston

Posted Sat Sep 30, 2017 7:33 AM

I noticed the same thing early this week and thought maybe autocorrect did it. Test:

Lets Ill arent

Autocorrect actually put the in there while I was typing.

Hmm, the lone apostrophe is different, maybe thats part of the problem -

Screenshot before I hit Add Reply:
1AF3E99D-4224-4FDD-AE74-991E64D0837F.jpeg

#8 RevEng OFFLINE  

RevEng

    River Patroller

  • 4,703 posts
  • Bitnik
  • Location:Canada

Posted Sat Sep 30, 2017 7:45 AM

Removing apostrophes... More Apple courage? :P
 
For suffering my stupid humor, one attempt at help: google says the workaround is to turn off "smart punctuation". Any luck trying that?

#9 frankodragon OFFLINE  

frankodragon

    River Patroller

  • 3,924 posts
  • No relation to the Adventure duck-like dragons
  • Location:Planet Vastia

Posted Sat Sep 30, 2017 7:49 AM

Maybe try copy/paste these words:     can't     won't     shouldn't       I'll      don't       didn't     I'm



#10 Flojomojo OFFLINE  

Flojomojo

    I say boom boom boom

  • Topic Starter
  • 10,312 posts
  • You say bam bam bam

Posted Sun Oct 1, 2017 10:43 AM

Maybe try copy/paste these words: can't won't shouldn't I'll don't didn't I'm

That worked. How odd

Quotes dont seem to work either
This is no fun!

#11 nanochess OFFLINE  

nanochess

    River Patroller

  • 4,894 posts
  • Coding something good
  • Location:Mexico City

Posted Sun Oct 1, 2017 11:27 AM

Maybe try copy/paste these words: can't won't shouldn't I'll don't didn't I'm

That worked. How odd

Quotes dont seem to work either
This is no fun!


I'm not sure if it's like TextEdit in Mac OS X, but I think you have enabled the option "typographic quotes" in your system editor, it's a pain in the a** when trying to edit a simple text file and saving it just to discover it replaced all the quotes and apostrophes with non-8 bits characters.

#12 Flojomojo OFFLINE  

Flojomojo

    I say boom boom boom

  • Topic Starter
  • 10,312 posts
  • You say bam bam bam

Posted Sun Oct 1, 2017 11:54 AM

I am using iOS on my phone, using the default keyboard, nothing fancy or complicated. It does not happen on any other site that I have noticed.

I can try another site running the same forum software if anyone knows a place to try. Or maybe this will just go away with the next forum update.

It just started with the latest OS update.

#13 SpiceWare ONLINE  

SpiceWare

    Draconian

  • 11,572 posts
  • Medieval Mayhem
  • Location:Planet Houston

Posted Sun Oct 1, 2017 2:16 PM

It's all better y'all.

 

Turn off Settings->General->Keyboard->Smart Punctuation.

287B1872-7416-43D2-85B7-071605B1F0A5.jpeg

36AA6689-DE5E-464B-A133-97AC451A78BA.jpeg

49900EB3-5230-4A9F-BB25-148A57BE2607.jpeg



#14 Flojomojo OFFLINE  

Flojomojo

    I say boom boom boom

  • Topic Starter
  • 10,312 posts
  • You say bam bam bam

Posted Tue Oct 3, 2017 5:01 PM

I just discovered this on my own and was about to test it. Good find!

"Problem" fixed!!

#15 Albert OFFLINE  

Albert

    Quadrunner

  • 34,078 posts

Posted Sat Oct 7, 2017 7:14 AM

Well, I have iOS 11 on a device, I'll have to try this.  Good to know how to fix it.  Guess this is something they changed in iOS 11.  Wonder how the newer forum software handles this.  Probably fine, is my guess.  I will have to test.

 

 ..Al



#16 Flojomojo OFFLINE  

Flojomojo

    I say boom boom boom

  • Topic Starter
  • 10,312 posts
  • You say bam bam bam

Posted Mon Nov 13, 2017 12:32 PM

There have been a few iOS updates since this started. Im turning off smart punctuation to see what happens here.

Its not so hard to have proper apostrophes!
Isnt it?
How about smart quotes?

Everything looks fine, lets see what happens when I press post.

#17 Flojomojo OFFLINE  

Flojomojo

    I say boom boom boom

  • Topic Starter
  • 10,312 posts
  • You say bam bam bam

Posted Mon Nov 13, 2017 12:32 PM

FAIL
turning it all off again.

#18 sramirez2008 OFFLINE  

sramirez2008

    Stargunner

  • 1,853 posts
  • Stella Foreva
  • Location:Houston

Posted Mon Nov 13, 2017 3:45 PM

Hmm...I'm still on iOS 10.3.2 and Smart Punctuation is not an option.   I'll keep this in mind, for whenever I decide to accept the update.






0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users