Jump to content

Photo

Black screen with High Tone audio


4 replies to this topic

#1 zonaps2 OFFLINE  

zonaps2

    Space Invader

  • 28 posts
  • Location:Montevideo, Uruguay

Posted Fri Oct 6, 2017 10:03 AM

Hi,

yesterday I got this TI-99/4A in nice cosmetic condition.

It's a PAL version, 220V PSU. Modulator says VHF Channel 3.

 

I plugged it in an old TV I have and I just got a black screen with a continuous beeeeeeep tone.

I tried a different TV just in case and same problem. I've tried a cartridge (Parsec), with no luck.

 

I have a bunch of old computers, commodore, amiga, etc, but I never owned a TI before. I've read the sticky post for new members and it say that this symptom could be anything on the board.

 

I've already disassembled the machine, on a visual inspection everything looks good, I've re inserted the socketed chips.

 

PSU voltages are:

on pins 1-2 = 19.6V

on pins 2-4 = 9.15V

 

I see that these voltages are higher than specified on the PSU case, I guess it's because it's under no load?

What things should I check? I have no idea beyond this.

 

HERE is a video with the symptom.

 

Attached File  ti-001.jpg   1.44MB   3 downloadsAttached File  ti-002.jpg   635.9KB   2 downloadsAttached File  ti-003.jpg   844.71KB   2 downloadsAttached File  ti-004.jpg   732.55KB   2 downloads


Edited by zonaps2, Fri Oct 6, 2017 10:05 AM.


#2 mjnurney OFFLINE  

mjnurney

    Space Invader

  • 16 posts
  • Location:Yorkshire - Milton Keynes

Posted Fri Oct 6, 2017 12:25 PM

years ago i used to have a few of these ....never fixed them sorry



#3 Tursi OFFLINE  

Tursi

    River Patroller

  • 4,781 posts
  • HarmlessLion
  • Location:BUR

Posted Fri Oct 6, 2017 6:41 PM

I guess the tone means that the sound chip is getting clock, at least. ;) But the system is not executing instructions far enough to silence it. Muting the sound chip happens in GPL code, so it requires that the CPU, scratchpad RAM, ROM, and GROM 0 all be working.

#4 zonaps2 OFFLINE  

zonaps2

    Space Invader

  • Topic Starter
  • 28 posts
  • Location:Montevideo, Uruguay

Posted Sun Oct 8, 2017 6:47 AM

Thanks Tursi, I see that I'll have to check out a lot of chips then


Sent from my iPhone using Tapatalk

#5 Pepper OFFLINE  

Pepper

    Space Invader

  • 10 posts

Posted Wed Oct 11, 2017 5:00 AM

I'm in the same boat as you. I have one unit that has the same issue as yours and another that runs fine for a while then after it warms up the keyboard mappings get messed up.

I'll be interested in what you find. I've been working my way through the IC's looking for issues.

There is a good checklist here http://atariage.com/...ng-my-ti-99-4a/ . That steps you through the checks to do.






0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users