Jump to content

Photo

Astro blaster glitch?


5 replies to this topic

#1 Jinks OFFLINE  

Jinks

    River Patroller

  • 3,771 posts
  • Location:Canada

Posted Fri Oct 6, 2017 8:27 PM

Ok so kids are over playing 7800 having fun with 2 player games centipede, ms pac man, galaga, food fight, dk pk(way too hard for them) and dig dug(way too hard) astro blaster 2 player novice. Started out can not see the shots in fact players shots only make sound and do zero damage.
I never tried this on two player before so I did not know. Anyone else notice this.
I know one player 7800 homebrews shine and work flawless but it seems two player has many glitches.
I appreciate the work put into these games and everyone involved but I feel two player testing should be looked at more before release. I would be willing to give any games a once over in two player mode as I have found fatal crashes in 4 homebrews so far. I think only 1 has been solved that I know of.

#2 CPUWIZ OFFLINE  

CPUWIZ

    Commander

  • 32,422 posts
  • Cartridge Recycler
  • Location:SoCal

Posted Fri Oct 6, 2017 8:37 PM

DLC - AHHHHH

Day One Patch - WHAAAAA

Upgrade OS - P*SS OFF!!!11!

Update homebrew EPROM - ???

 

No, we will just ask homebrewers to ship games without bugs, simple as that.  Because, cartridges!

 

 

J/K

 

I wish it would be easier, but that territory gets expensive.  And the 7800 was made by the devil.



#3 Jinks OFFLINE  

Jinks

    River Patroller

  • Topic Starter
  • 3,771 posts
  • Location:Canada

Posted Fri Oct 6, 2017 9:01 PM

I don't mean to sound like a douche about this just asking for a touch more attention to 2 player testing.
We all had fun tonight playing anyway and thats what really matters.
I was amazed at how crazy they were to play atari! They like the movie pixels so they wanted to play the pacmans and galagas etc..oh $%&_ I forgot to show them asteroids!! Gotta go!!

#4 PacManPlus OFFLINE  

PacManPlus

    River Patroller

  • 4,632 posts
  • Atari 7800 & NES Developer
  • Location:Florida

Posted Sat Oct 7, 2017 3:10 AM

I just tried this scenario on emulation, and on the real thing with a cart I made back when I did the game.  This does NOT happen to me. At all.  When the game switches players, player 2 works fine for me.

 

Something as obvious as a player's shots not coming out would have been caught VERY early on, as I DO test a game as much as possible, and I would have seen that.  Please don't assume just because something happens to you that it just 'wasn't tested enough', as there could be other factors involved.  I've only have one 7800 for quite a while now, so there could be other revisions that have timing issues (that's just an example, not an excuse).

 

There are things, however, that are almost impossible for me to test in other games, like two-player simultaneous game play (for very long anyway), but even that I try to test as much as possible.

 

I'm sorry you have a cart that is not behaving correctly. 


Edited by PacManPlus, Sat Oct 7, 2017 3:15 AM.


#5 Jinks OFFLINE  

Jinks

    River Patroller

  • Topic Starter
  • 3,771 posts
  • Location:Canada

Posted Sat Oct 7, 2017 7:28 AM

It could possibly be the case of my 7800 acting up as well as we all know about how different revisions do weird things.

I should try my other 7800.
I thought of something else that could be the problem. I put a cart in the other day and it was dirty. Not checking first and wondering why it did not work. Then trying a couple of games it took awhile for them to work.
Everything in your code works as you have confirmed so we are 100% sure something wrong on my end.
Thanks for double checking!
Astroblaster is a great game and my favorite of your line up of space shooters!

#6 Trebor OFFLINE  

Trebor

    River Patroller

  • 4,216 posts

Posted Sat Oct 7, 2017 8:10 AM

Just tested this game (again) this morning. Astro Blaster cart played under AT84 serial, A1 serial, and A3 serial consoles.  Two Players and EASY ("novice") setting.  Shooting and presence of laser shots for both Player One and Player Two, as well as enemies, evident.  No issues discovered.

 

Likely possible cart or console issue on your end, Jinks.






0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users