Jump to content

Photo

Bad Necromancer XEGS Cart - fixable?

xegs cartridge necromancer

11 replies to this topic

#1 Nezgar OFFLINE  

Nezgar

    Moonsweeper

  • 291 posts
  • Location:Regina SK Canada

Posted Sun Nov 5, 2017 4:04 PM

I received a 2nd hand Necromancer XEGS Cart that does not work. It does take over the ram (16K?) above $8000 because basic gets disabled, and it goes straight to self-test. Self test only shows 2 rows of blocks in RAM test, instead of 2.5. My new Sys-Check II shows bad ram above $8000 with the cart inserted. I believe this is only a 16K game with no bank switching, hence no chip in the middle. I re-flowed the solder to pretty much all the touchable points on the pcb, no difference.

 

I haven't looked to see if that 16K addressable space actually has anything in it yet..  Any other ideas? if the ROM chip is bad, can a 27128 EPROM be dropped in its place?

 

necromancer.jpg



#2 MrFish ONLINE  

MrFish

    River Patroller

  • 4,274 posts
  • Location:1010-1010

Posted Sun Nov 5, 2017 5:31 PM

You could check the traces for continuity. Although, I'm guessing a bad ROM is a more common problem for carts.



#3 SignGuy81 ONLINE  

SignGuy81

    Stargunner

  • 1,134 posts

Posted Sun Nov 5, 2017 7:59 PM

Hard to tell in that pic but it looks like I see a cracked solder joint on C1 on the right lead in the middle picture but it is hard to tell.  Also too C2, again hard to tell by the pic but the back side of the board it looks like that might not be a good joint, where the lead is coming through the backside of the board, and also it didn't flow to the top side of the board as well on that lead(basically that lead will need more heat to solder good because of the huge trace(ground plane) on each side).

 

EDIT:

 

All that being said I doubt it is your issue though as those are just decoupling caps, but there could be others as well that are too hard to spot from the pic.


Edited by SignGuy81, Sun Nov 5, 2017 8:01 PM.


#4 SignGuy81 ONLINE  

SignGuy81

    Stargunner

  • 1,134 posts

Posted Sun Nov 5, 2017 8:11 PM

Look at pin 22 of the ROM chip, on the back side of the board, I see looks like a ring around the joint indicative of a cracked joint.  Looking at the back of the board that pin will be the 7th one going up(starting from pin 28) along the edge of the board, you should see that ring around the joint I'm talking about in the pic.

 

Is there anyway you can get closer high res pic of the back of the board?


Edited by SignGuy81, Sun Nov 5, 2017 8:13 PM.


#5 _The Doctor__ ONLINE  

_The Doctor__

    River Patroller

  • 2,858 posts
  • Location:10-0-11-00:02

Posted Sun Nov 5, 2017 8:35 PM

you needs flux and lead based solder.... anyone know if u3 was or was not needed on this cart? or if the jumper pad belongs bridged or not... stranger things have been found when carts are located


Edited by _The Doctor__, Sun Nov 5, 2017 8:36 PM.


#6 Nezgar OFFLINE  

Nezgar

    Moonsweeper

  • Topic Starter
  • 291 posts
  • Location:Regina SK Canada

Posted Sun Nov 5, 2017 10:58 PM

Thanks for the ideas! I touched up most of the points again with a bit of flux and extra solder here and there, no difference.

 

So since the computer is able to boot with the cartridge inserted, I loaded up Sparta 3.2f, and issued SAVE NECROMAN.OBJ 8000 BFFF and the resulting file does indeed have data there... I even repeated it to a couple separate files, and they all compare the same. (16KB with a 6-byte object code header)

 

Attached File  necromancer.obj   16.01KB   8 downloads

 

a little forensics on this memory dump...  transferred the OBJ file over to the PC - loading into notepad I can see the string "OMANOMANBYBYL WIL WIMSMS" .. and comparing with a known good XEX version of necromancer, its very clearly "NECROMANCER BY BILL WILLIAMS" .. So its partially there...

 

Whats the other LS type chip do... could that be suspect? KS74HCTLS00N  - googling says "TTL Quad 2-Input NAND, HCT-CMOS IC DIP 14PIN"

 

Cheers! - Ryan



#7 Zap! OFFLINE  

Zap!

    Stargunner

  • 1,466 posts
  • Location:Staten Island, New York

Posted Sun Nov 5, 2017 11:05 PM

I had the same thing happen to me the other day with Flight Simulator II. It booted straight to self-test and only showed 2 rows of blocks in RAM test. What I did next was literally pour 91% alcohol on both sides of the connectors, then scrub with a q-tip. While still wet, I put it in and pulled it out of my Atari 800XL about 15 times, which also resulted in cleaning the computer. Finally, I turned it on and it worked like a charm.



#8 _The Doctor__ ONLINE  

_The Doctor__

    River Patroller

  • 2,858 posts
  • Location:10-0-11-00:02

Posted Sun Nov 5, 2017 11:26 PM

true the card edge does not look all that clean



#9 Nezgar OFFLINE  

Nezgar

    Moonsweeper

  • Topic Starter
  • 291 posts
  • Location:Regina SK Canada

Posted Tue Nov 21, 2017 12:04 AM

Thoroughly cleaned connectors... all other carts work, and same symptom when used in multiple machines. out of ideas of this one other than replacing the mask ROM. 16K game - would a 27C128 EPROM be pin compatible if I replaced it?



#10 ndary OFFLINE  

ndary

    Moonsweeper

  • 470 posts
  • Location:Israel

Posted Tue Nov 21, 2017 1:19 AM

Yes, you can..

 

But first i would replace the .1uf cap and check all traces from the ATARI Prom to the Cartridge slot and to the 74LS00 chip,

 

You can remove the ATARI ROM and put there a 27c128 Eprom (just make sure that its faced down to the cartridge edge)

 

those are not 'resistors' you see in R2 & R3, there are there to make a short. just Take out the 'LEFT LEG' of R2 and solder it to the 'LEFT LEG' of C4, this will take care of the 'CHIP SELECT' signal that is required for the 27C128 Eprom to work.

 

if after replacing the PROM with an EPROM (that has the NECROMANCER GAME) you still don't get the game to work then replace the 74LS00, it may go bad.

 

see image

 

 

Attached Thumbnails

  • XE SuperCart PCB Rev 2 - 16K EEPROM.jpg


#11 _The Doctor__ ONLINE  

_The Doctor__

    River Patroller

  • 2,858 posts
  • Location:10-0-11-00:02

Posted Tue Nov 21, 2017 1:19 AM

couldn't hurt to replace the ls

and deleted the rest as ndary covered at the same time


Edited by _The Doctor__, Tue Nov 21, 2017 1:21 AM.


#12 Nezgar OFFLINE  

Nezgar

    Moonsweeper

  • Topic Starter
  • 291 posts
  • Location:Regina SK Canada

Posted Tue Nov 21, 2017 11:17 AM

Thanks for the tips! Will acquire the parts, and see how it goes!







Also tagged with one or more of these keywords: xegs, cartridge, necromancer

0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users