Jump to content

Photo

1088XEL Atari ITX Motherboard DIY Builders Thread

1088XEL JOY2PIC-STIK XEL-CF-][ UAV Sophia U1MB

948 replies to this topic

#651 flashjazzcat OFFLINE  

flashjazzcat

    Quadrunner

  • 13,688 posts
  • Location:United Kingdom

Posted Sun Feb 11, 2018 1:13 PM

Since PCLINK.SYS is not usually on CAR:, I should have said that DEVICE PCLINK would probably generate a conspicuous CONFIG error, but in either case, it would clearly show that the CONFIG.SYS file on CAR: was not being used. And yet here it looks as if it is.

Where did you obtain the copy of SDX dated 27-01-2018?

#652 DrVenkman ONLINE  

DrVenkman

    River Patroller

  • 3,325 posts
  • Back off, man! I'm a scientist.
  • Location:KMBT

Posted Sun Feb 11, 2018 1:25 PM

 

I'm about to go take this to real hardware to see if this is something going on in Altirra or what. 

 

Alright, on my real 1088XEL, I do NOT see this aberrant behavior. The copy of CONFIG.SYS I have on D5: is being respected. Commenting out the RAMDISK line prevents DO: from being created, while leaving the line in allows it, exactly as expected.

 

​So, something is fubar in my Altirra setup (though I don't know what; I reset it completely pretty much every new test build from Avery and just point it at my saved U1MB firmware file so I don't have to reflash the virtual machine and then save it again every time).

 

Anyway - it looks to me then like the 1088XEL firmware is good to go, Jon. And thank you.

 

EDIT: Indeed, my Altirra settings were corrupted! I went into the Altirra Tools --> Options menu and reset everything, then setup my virtual machine from scratch. Everything is A-OK there now too. Windows can be a real PITA sometimes ... :) 



#653 DrVenkman ONLINE  

DrVenkman

    River Patroller

  • 3,325 posts
  • Back off, man! I'm a scientist.
  • Location:KMBT

Posted Sun Feb 11, 2018 1:26 PM

Since PCLINK.SYS is not usually on CAR:, I should have said that DEVICE PCLINK would probably generate a conspicuous CONFIG error, but in either case, it would clearly show that the CONFIG.SYS file on CAR: was not being used. And yet here it looks as if it is.

Where did you obtain the copy of SDX dated 27-01-2018?

 

That's probably a date generated by the SDX Imager tool when I modded the FDISKx.OVL files to set the Hidden attribute. 



#654 flashjazzcat OFFLINE  

flashjazzcat

    Quadrunner

  • 13,688 posts
  • Location:United Kingdom

Posted Sun Feb 11, 2018 1:35 PM

OK - great. Thanks for confirming.

BTW: I downloaded the latest beta copy of SDX from the SpartaDOS X Upgrade Project site: still 4.49c, but dated 11-02-2018. Operation is still correct, as per the previous beta I had installed, which is to say CONFIG.SYS is read from the correct partition.

I notice the FDISK OVL files on CAR: still don't have the hidden attribute set... I've already informed Konrad and Trub of this requirement a couple of times, but perhaps someone else can remind them. ;)
 

That's probably a date generated by the SDX Imager tool when I modded the FDISKx.OVL files to set the Hidden attribute.


Of course: again, I missed the obvious.

EDIT: Indeed, my Altirra settings were corrupted! I went into the Altirra Tools --> Options menu and reset everything, then setup my virtual machine from scratch. Everything is A-OK there now too. Windows can be a real PITA sometimes ... :) 


Excellent. I guess I should just get on and prepare the release packages, otherwise it would be possible to hold off indefinitely in the face of red-herrings and third-party "variables". :)

Edited by flashjazzcat, Sun Feb 11, 2018 1:38 PM.


#655 Lavalamp OFFLINE  

Lavalamp

    Star Raider

  • 86 posts
  • Location:Wellington, New Zealand.

Posted Sun Feb 11, 2018 1:41 PM

Hi, can someone confirm I have crimped my Sophia cable correctly, I'm assuming pin one is audio to the RGB connector? Pin 10 is not connected?

 

attachicon.gifIMG_1239.JPG

 

Still waiting on a back order from Digi key for 3 final components...

 

attachicon.gifIMG_1241.JPG

 

 

Looking at this image below  it looks like I nailed it, where would the best spot be to get the audio for the RGB cable that came with the Sophia? A Pin from the Aux Audio? If so which Pin? Or somewhere closer to the RGB header? Thanks Chaps.

 

SC1224.png



#656 mytek OFFLINE  

mytek

    River Patroller

  • 2,821 posts
  • Location:Santa Rosa, CA

Posted Sun Feb 11, 2018 7:41 PM

 

 

Looking at this image below  it looks like I nailed it, where would the best spot be to get the audio for the RGB cable that came with the Sophia? A Pin from the Aux Audio? If so which Pin? Or somewhere closer to the RGB header? Thanks Chaps.

 

attachicon.gifSC1224.png

 

 

Probably be best to use pin 2 which is the Left Channel output (normal MONO signal on stock A8 with only one Pokey chip). Keep in mind that the audio output signals connected to this header are always active, so plugging into the 3.5 mm stereo jack will not disable the connection as it does for the DIN-13. Most likely not a problem, but I figured I'd point that out in case it is.

 

AUDIO_AUX.png



#657 chevymad OFFLINE  

chevymad

    Chopper Commander

  • 109 posts

Posted Sun Feb 11, 2018 9:09 PM

Figured out how to flash the XEGS rom to the U1MB today. I can now access Missile Command! Everythings working great. Lots of learning curve since i've never used any sio2pc or Respeqt before, and until now hadn't flashed my old u1mb either. I'm amazed at how clear the picture and sound is with the 1088. Also probably my imagination but the stick seems just slightly more responsive? Looking forward to adding more mods to this and getting a case. Though it is kinda cool to look at. 



#658 mytek OFFLINE  

mytek

    River Patroller

  • 2,821 posts
  • Location:Santa Rosa, CA

Posted Sun Feb 11, 2018 10:32 PM

Figured out how to flash the XEGS rom to the U1MB today. I can now access Missile Command! Everythings working great. Lots of learning curve since i've never used any sio2pc or Respeqt before, and until now hadn't flashed my old u1mb either. I'm amazed at how clear the picture and sound is with the 1088. Also probably my imagination but the stick seems just slightly more responsive? Looking forward to adding more mods to this and getting a case. Though it is kinda cool to look at. 

 

Glad to see you are enjoying it. You can thank Bryan's UAV and the 1088XEL's 4-Layer board for the clean video you're seeing. When it comes to the joystick response, I don't know if you could really see a difference, but there are no caps on the PIA inputs so perhaps that gives a little less delay.



#659 chevymad OFFLINE  

chevymad

    Chopper Commander

  • 109 posts

Posted Sun Feb 11, 2018 10:39 PM

I've had a UAV in my 800xl for awhile now too. It's good, but not this good. Of course that computer's always had inferior video. Even with several other mods before Bryans. I did a UAV in my 400 as well and it's better then the 800. Anyways, this will probably be my "daily" use atari, the others will go in the closet again. 



#660 Lavalamp OFFLINE  

Lavalamp

    Star Raider

  • 86 posts
  • Location:Wellington, New Zealand.

Posted Mon Feb 12, 2018 1:41 AM

 

 

Probably be best to use pin 2 which is the Left Channel output (normal MONO signal on stock A8 with only one Pokey chip). Keep in mind that the audio output signals connected to this header are always active, so plugging into the 3.5 mm stereo jack will not disable the connection as it does for the DIN-13. Most likely not a problem, but I figured I'd point that out in case it is.

 

attachicon.gifAUDIO_AUX.png

 

 

Thanks awesome.



#661 flashjazzcat OFFLINE  

flashjazzcat

    Quadrunner

  • 13,688 posts
  • Location:United Kingdom

Posted Mon Feb 12, 2018 3:01 PM

I notice the FDISK OVL files on CAR: still don't have the hidden attribute set...


Somewhat OT, but I emailed Trub about this and he said it's taken care of going forward. ;)

#662 Firedawg OFFLINE  

Firedawg

    Dragonstomper

  • Topic Starter
  • 518 posts
  • Location:Atlanta, GA

Posted Mon Feb 12, 2018 4:41 PM

Thanks to MacRorie this kid is starting another 3 builds.  One of which will be on this board!!!  Oh, and by the way don't showoff your 1088XEL unless you want to see severe Atari envy up close.  Was talked (begged actually) into building my remaining boards for two friends, and I could not scare them off with cost.  I'll be running a mini-MacRorie shop here for a week or two.

 

1088xelGrnBrd-1.jpg



#663 DrVenkman ONLINE  

DrVenkman

    River Patroller

  • 3,325 posts
  • Back off, man! I'm a scientist.
  • Location:KMBT

Posted Mon Feb 12, 2018 5:21 PM

Thanks to MacRorie this kid is starting another 3 builds.  One of which will be on this board!!!  Oh, and by the way don't showoff your 1088XEL unless you want to see severe Atari envy up close.  Was talked (begged actually) into building my remaining boards for two friends, and I could not scare them off with cost.  

 

That's awesome! I very much want to build my second board at some point this year, but we'll see. :)



#664 john_q_atari ONLINE  

john_q_atari

    Space Invader

  • 39 posts
  • Y build 1 when U can have 2 for twice the price!
  • Location:San Jose, CA

Posted Tue Feb 13, 2018 2:02 PM

I am getting ready to start my build later this week when my boards arrive from MacRorie. I am still waiting on 2 parts from overseas. I was wondering what peoples' experience was as to how long it took to receive these parts in the states after they were mailed?

 

Lotharek's U1MB mailed on Jan 26, last update WARSZAWA WER, POLAND on Jan 30th.
arihav electronics stacked video connector marked shipped on Feb 4th.



#665 mytek OFFLINE  

mytek

    River Patroller

  • 2,821 posts
  • Location:Santa Rosa, CA

Posted Tue Feb 13, 2018 2:10 PM

I am getting ready to start my build later this week when my boards arrive from MacRorie. I am still waiting on 2 parts from overseas. I was wondering what peoples' experience was as to how long it took to receive these parts in the states after they were mailed?

 

Lotharek's U1MB mailed on Jan 26, last update WARSZAWA WER, POLAND on Jan 30th.
arihav electronics stacked video connector marked shipped on Feb 4th.

 

It's been awhile since I had to order these things so my recollection of how long is probably not accurate, perhaps one of the other builders can chime in on that.

 

As for the stacked connectors, it seems a pity that a lot of people will end up with more than needed due to the minimum order situation. Might be good to offer those for sale to others to either pick-up if they are close to the same area, or put in the mail including the shipping into the price.



#666 Mr Robot OFFLINE  

Mr Robot

    Chopper Commander

  • 240 posts
  • AtariArtist
  • Location:USA

Posted Tue Feb 13, 2018 2:46 PM

I am getting ready to start my build later this week when my boards arrive from MacRorie. I am still waiting on 2 parts from overseas. I was wondering what peoples' experience was as to how long it took to receive these parts in the states after they were mailed?

 

Lotharek's U1MB mailed on Jan 26, last update WARSZAWA WER, POLAND on Jan 30th.
arihav electronics stacked video connector marked shipped on Feb 4th.

 

 

Not a U1MB, but I ordered some stuff from Lotharek last year...

 

I'm in the USA, no idea where you are...

 

Ordered Aug 29, Shipped Sep 2, Arrived Sep 8... Excellent service!



#667 john_q_atari ONLINE  

john_q_atari

    Space Invader

  • 39 posts
  • Y build 1 when U can have 2 for twice the price!
  • Location:San Jose, CA

Posted Tue Feb 13, 2018 2:50 PM

 

 

Not a U1MB, but I ordered some stuff from Lotharek last year...

 

I'm in the USA, no idea where you are...

 

Ordered Aug 29, Shipped Sep 2, Arrived Sep 8... Excellent service!

 

I'm in the San Francisco bay area. He marked the order as shipped within an hour of my placing the order. Seems like my package is sitting in limbo somewhere as there is no tracking information from outside Poland. If others got their orders quickly perhaps I will reach out to Lotharek and inquire.



#668 Mr Robot OFFLINE  

Mr Robot

    Chopper Commander

  • 240 posts
  • AtariArtist
  • Location:USA

Posted Tue Feb 13, 2018 2:56 PM

 

I'm in the San Francisco bay area. He marked the order as shipped within an hour of my placing the order. Seems like my package is sitting in limbo somewhere as there is no tracking information from outside Poland. If others got their orders quickly perhaps I will reach out to Lotharek and inquire.

 

I'm in the Midwest, I paid with paypal, my tracking number is on the paypal transaction. That's how I got you precise dates. 



#669 MacRorie OFFLINE  

MacRorie

    Dragonstomper

  • 907 posts
  • No matter where you go, there you are.
  • Location:NorCal!

Posted Tue Feb 13, 2018 3:14 PM

 
It's been awhile since I had to order these things so my recollection of how long is probably not accurate, perhaps one of the other builders can chime in on that.
 
As for the stacked connectors, it seems a pity that a lot of people will end up with more than needed due to the minimum order situation. Might be good to offer those for sale to others to either pick-up if they are close to the same area, or put in the mail including the shipping into the price.


Folks,

I have *everything* you need to build the the 1088XEL. I have them in 100s of quantity. If you are missing anything, I am more than willing to sell it to you and I can guarantee you that it will be cheaper than buying it from the ten different vendors you need to get them from.

I mean, I even have U1M and I am more than willing to change the headers on it for you for a small fee. However, I just cannot list every single part on the boards. I mean, it is getting to that point and I am trying to set up a website for all of the parts, but if you do not see it and you do not want to wait the two to three weeks to get parts from 3-4 different countries, I am here for you, please just ask.

My experience with the stacked connectors was that EVEN paying extra for EMS, it took two weeks to get here. As for things from Poland, sometimes it was 10 days, sometimes it was longer. One shipment took from November until January (not even kidding there).

Hope this helps.
-M

#670 DrVenkman ONLINE  

DrVenkman

    River Patroller

  • 3,325 posts
  • Back off, man! I'm a scientist.
  • Location:KMBT

Posted Tue Feb 13, 2018 5:42 PM

 

I'm in the San Francisco bay area. He marked the order as shipped within an hour of my placing the order. Seems like my package is sitting in limbo somewhere as there is no tracking information from outside Poland. If others got their orders quickly perhaps I will reach out to Lotharek and inquire.

 

The last stand-alone U1MB I ordered (last September) took 12 days to arrive for me (suburbs of Nashville, TN) from Poland. Pretty sure I got tracking info through the Polish post up to the point it was shipped overseas, and then after it cleared US customs, that event was also reflected on the Polish post site as well. Don't recall if I also got tracking info from the USPS once it was in the US., but once it was here, it only took another couple days.

 

As an aside, lemme toss some unsolicited praise for MacRorie's kits - the stuff arrives labeled, VERY well packed and in a timely fashion. I've put my own build together sort of piecemeal - boards first while he was getting full kits together, then a full-kit BOM, then an XEL-CF II board, and now waiting for a cartridge tunnel and the accessory boards for my Realan case. Very happy customer here, and I'm already trying to figure out how I can justify building out my second board. If/when I do, I'll be buying the bits and pieces from him again. 



#671 MacRorie OFFLINE  

MacRorie

    Dragonstomper

  • 907 posts
  • No matter where you go, there you are.
  • Location:NorCal!

Posted Wed Feb 14, 2018 3:48 PM

Soon, my precious, soon it will be our time. . . .

Attached Thumbnails

  • IMG_6431.JPG
  • IMG_6432.JPG


#672 mytek OFFLINE  

mytek

    River Patroller

  • 2,821 posts
  • Location:Santa Rosa, CA

Posted Wed Feb 14, 2018 4:27 PM

Wow that looks nice  :thumbsup: . I have a case just like that, so now I know what it'll look like in blue  :) .



#673 DrVenkman ONLINE  

DrVenkman

    River Patroller

  • 3,325 posts
  • Back off, man! I'm a scientist.
  • Location:KMBT

Posted Wed Feb 14, 2018 5:48 PM

Damn, ninja'd by Mac!

 

My panels arrived today too ...

 

IMG_9781.JPG

 

IMG_9782.JPG

 

IMG_9784.JPG

(wish I'd noticed that big cat hair before I took the photo :P )

 

IMG_9786.JPG

(the ghost image looks pretty great, Michael! Thanks for that.)

 

I don't know if they do it for every order, but someone put a tiny bag of gummi bears in my box. That was a pleasant surprise. :)

IMG_9787.JPG

 

 



#674 mytek OFFLINE  

mytek

    River Patroller

  • 2,821 posts
  • Location:Santa Rosa, CA

Posted Wed Feb 14, 2018 5:55 PM

Yep they always give you a bag of gummi bears, and yes the ghost came out great, as well as the Atari Fuji.

 

I love it, the new generation of the Atari 8-Bit is upon us   :thumbsup:  :) .

 

Ok now what would be nice is if you guys posted over in the Mini-ITX Cases topic and upload your FPD files, assuming you don't mind sharing.



#675 john_q_atari ONLINE  

john_q_atari

    Space Invader

  • 39 posts
  • Y build 1 when U can have 2 for twice the price!
  • Location:San Jose, CA

Posted Wed Feb 14, 2018 11:10 PM

Wow those pictures are beautiful! MacRorie, what case is that? It looks like it is metal? Are they all metal? It sort of looked like to me in photos that I had seen previously that the sides were plastic in the H80 and perhaps H60.

 

And thanks for the shipment MacRorie! Everything arrived nice and organized, fast, and safe and sound. My video connectors from Israel arrived today too. And the PCB board, so beautiful! Almost makes me not want to solder anything too it. Glad I picked up more than one :-)

 

Let the building begin! Maybe my U1MB will get here from Poland before Easter. Who knows... It's the last missing piece.







Also tagged with one or more of these keywords: 1088XEL, JOY2PIC-STIK, XEL-CF-][, UAV, Sophia, U1MB

0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users