Jump to content

Photo

Fix for Lynx II that can't read some carts?


8 replies to this topic

#1 zzip OFFLINE  

zzip

    River Patroller

  • 2,534 posts

Posted Thu Dec 7, 2017 2:36 PM

I recently pulled out my Lynx and noticed a bunch of cartridges will give an "Insert Cartridge" message when inserted, while others work. Is there something I can do? Clean the contacts? (if so how?)

#2 BadPricey OFFLINE  

BadPricey

    Moonsweeper

  • 416 posts

Posted Fri Dec 8, 2017 9:22 AM

Try using an eraser. Gently rub in the directions of the contacts so not to damage them. Wipe them off after with a dry cloth towel before putting them in your Lynx. I think some have used rubbing alcohol but I haven't.
Rgds
BadPricey

#3 karri OFFLINE  

karri

    River Patroller

  • 2,420 posts
  • Location:Espoo, Finland

Posted Fri Dec 8, 2017 10:33 AM

Electronics cleaning is often done with https://en.wikipedia...opropyl_alcohol

 

In Finland you get it from any pharmacy. I believe it is cleaner than rubbing alcohol.

 

Sometimes rubbing alcohol is ethanol plus some added bitterants to make it undrinkable. And sometimes it is just isopropyl alcohol. Check the bottle for C3H8O.



#4 tbb033 OFFLINE  

tbb033

    Chopper Commander

  • 173 posts

Posted Fri Dec 8, 2017 1:01 PM

Check the bottle for C3H8O.

 Sounds like a droid from Star Wars!  :lolblue:



#5 necrocia OFFLINE  

necrocia

    Chopper Commander

  • 142 posts

Posted Sun Dec 17, 2017 6:51 PM

I've had good success with DeOxit. Here's a blog post I wrote about it - https://www.igorkrom...game-catridges/



#6 zzip OFFLINE  

zzip

    River Patroller

  • Topic Starter
  • 2,534 posts

Posted Tue Dec 19, 2017 12:02 PM

Thanks for the replies, I didn't notice I had any until now.

Some of the replies are suggesting I clean the carts, and I will try that, but I was assuming that the contacts in the Lynx itself might be the problem.. how can I clean those? Is there something I can safely stick in the cart slot that would help? Or do I need to disassemble it?

#7 BadPricey OFFLINE  

BadPricey

    Moonsweeper

  • 416 posts

Posted Tue Dec 19, 2017 3:30 PM

Some carts work, some don't. I would suggest it is cart related and not slot. Not sure how you'd clean that?

#8 zzip OFFLINE  

zzip

    River Patroller

  • Topic Starter
  • 2,534 posts

Posted Fri Dec 29, 2017 10:43 AM

I cleaned the carts with isopropyl alcohol, but that didn't do anything.

Then I tried not inserting the carts all the way. The games started working! I found that if push the cart all the way in, but then pull it back less than a millimeter, it will usually work.

Almost like the contacts aren't properly aligned with the cart slot. But why would it develop a problem like that if it's just been sitting in a closet?

#9 karri OFFLINE  

karri

    River Patroller

  • 2,420 posts
  • Location:Espoo, Finland

Posted Fri Dec 29, 2017 12:36 PM

Most likely some pins have been bent inside the cart connector. I looked inside my lynx and straightened two pins with a dentists tool.




0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users