Jump to content

Photo

I/O Error 00

error peb expansion ti-99 box peripheral i/o

28 replies to this topic

#26 AwkwardPotato OFFLINE  

AwkwardPotato

    Space Invader

  • Topic Starter
  • 33 posts

Posted Thu Jan 4, 2018 7:48 PM

The 74LS259 still hasn't arrived, however, while waiting, is there anything else that should happen during the normal TI startup sequence that I should check for on the card, in order to determine if there are other faults elsewhere, since even when the drive is selected properly it refuses to work?



#27 pcoderdude14 ONLINE  

pcoderdude14

    Space Invader

  • 26 posts

Posted Thu Jan 4, 2018 8:11 PM

The 74LS259 still hasn't arrived, however, while waiting, is there anything else that should happen during the normal TI startup sequence that I should check for on the card, in order to determine if there are other faults elsewhere, since even when the drive is selected properly it refuses to work?

Hey there!

There is a little trick that I know, that doesn't actually do anything else then make sure that the FDC card is "connected" to the drives...that is , to take the "card edge " connector, and, turn it upside down...purposely.  If, when you do so, the drive(s) lights (LEDs) turn on AND stay on, ...that way, you know that the drives are getting SOMETHING from the card.   Of course, when you've turn on the P-box to get the drives "lit" , make sure that you turn the power off (to P-box, and, drives that are being powered w/o the P-box Power Supply)....and then switch back the "card edge" connector the right way again.

 

I hope this helps....

 

Having VERY similiar problems with my CorComp FDC.

 

Jt



#28 Opry99er OFFLINE  

Opry99er

    Quadrunner

  • 8,389 posts
  • Location:Hustisford, WI

Posted Thu Jan 4, 2018 8:26 PM

So, all your Disk commands return this error?

RUN DSK1.TEST
SAVE DSK1.TEST

etc.?


Additionally, this may sound silly, but have you moved your controller card over one slot in the PEB?

#29 AwkwardPotato OFFLINE  

AwkwardPotato

    Space Invader

  • Topic Starter
  • 33 posts

Posted Thu Jan 4, 2018 10:12 PM

- pcoderdude14:

 

I'll try that out when I get the chance.

 

- Opry99er

 

Yep, every single disk command returns that error, whether in TI Basic or Disk Manager. The card is in Slot 8.







Also tagged with one or more of these keywords: error, peb, expansion, ti-99, box, peripheral, i/o

0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users