Jump to content

Photo

FinalGrom99 on the TI-99/8


7 replies to this topic

#1 kl99 OFFLINE  

kl99

    Dragonstomper

  • 806 posts
  • Location:Vienna, Austria

Posted Sun Apr 15, 2018 12:26 AM

Hi Guys! Hi Ralph!

 

Yesterday we tried out the FinalGrom99 cartridge on the 99/8, for me for the first time.

It is not showing up on the Menu Selection Screen.

The Menu Selection Screen is not based on numbers but letters, letter A is still Extended Basic II (stored in ROM), letter B is to set Speed.

 

We tried two different carts who were verifed before and after on a 99/4A to work.

 

Ciro told me he used the FlashRom99 on his 99/8, he never tried the FinalGrom99 yet.

Any other 99/8 users: please try it out as well on your machine, it could be a problem on my machine.

I think to remember that I used the XB 2.7 suite cart (Ubergrom) on my 99/8 with success.

 

Could it be the same problem that blocks the QI consoles from using the FinalGrom99 with success?

How is the status there?

 

How can I help to diagnose from here?

 

 



#2 Ksarul OFFLINE  

Ksarul

    River Patroller

  • 4,499 posts

Posted Sun Apr 15, 2018 8:31 AM

The 99/8 definitely has the lockout function for ROM-only cartridges as part of the OS, so I would think that the FlashROM wouldn't work on it. On the FinalGROM, it depends where the FinalGROM's startup code is lurking. If it is in ROM, it is probable that the startup code isn't detected, similar to the detection failure in a V2.2 console. One other important thing to remember: if the startup code is in GROM, it has to be in one of the first four GROM bases, as the 99/8 only scans those on startup (unlike the 99/4A which scans the first 16).



#3 ti99iuc OFFLINE  

ti99iuc

    Stargunner

  • 1,366 posts
  • Location:Italy

Posted Sun Apr 15, 2018 8:57 AM

The 99/8 definitely has the lockout function for ROM-only cartridges as part of the OS, so I would think that the FlashROM wouldn't work on it. [...]

 

I was surprised too indeed :)

 

Attached File  TI998+PEB+Monitor_testFR99-3.jpg   618.3KB   0 downloads



#4 kl99 OFFLINE  

kl99

    Dragonstomper

  • Topic Starter
  • 806 posts
  • Location:Vienna, Austria

Posted Sun Apr 15, 2018 10:19 AM

The available source code for the 99/8 Rom/Grom has the Rom only lock out. yes! correct!

However that available source code lists are not necessarily matching the compiled binaries of the Rom/Grom we find in Ciro's 99/8 machine.

We already wondered once why 3rd party cartridges are working on the 99/8 in Mame.



#5 fabrice montupet OFFLINE  

fabrice montupet

    Moonsweeper

  • 272 posts
  • Location:Burgundy - France

Posted Sun Apr 15, 2018 1:39 PM

The FinalGROM 99 does'nt works on my 99/8 prototype #22 Rev1, due to its ROM v1.0 that reacts as the 4QI computer.



#6 kl99 OFFLINE  

kl99

    Dragonstomper

  • Topic Starter
  • 806 posts
  • Location:Vienna, Austria

Posted Mon Apr 16, 2018 12:29 AM

But the problem with the FinalGrom99 on the 99/4QI is not the Rom only lock out software (coming via v2.2). Afaik that is covered by always having a fake Grom Header.

The problem was some differences/missing signals on the cartridge boards on QI boards.

The problem is independent of the Grom0 software version, be it v1.0 or v2.2.

In the end we need Ralph to join the discussion I assume.



#7 fabrice montupet OFFLINE  

fabrice montupet

    Moonsweeper

  • 272 posts
  • Location:Burgundy - France

Posted Mon Apr 16, 2018 10:11 AM

The problem was some differences/missing signals on the cartridge boards on QI boards.

I know that. The missing signals are CRUIN and CRUCLK-, they are missing on the QI computer.

The problem is dependant of the GROM0 and the hardware. My previous message was not enough detailled.

An other difference on the QI: the data bus of the cartrige port is isolated from that of the I/O port. But this not concerns the FinalGROM99.



#8 ralphb OFFLINE  

ralphb

    Dragonstomper

  • 558 posts
  • Location:Germany

Posted Tue Apr 24, 2018 12:36 PM

I'm so sorry, I'm really late to the party.  :(

 

If I remember the issue correctly then the FinalGROM 99 menu is not showing up.

 

The FinalGROM 99 has its menu in  GROM #3, and then only one instruction to jump to ROM >6010 via XML.  I did that because of the ROM lockout, but I didn't know it wouldn't work on QI consoles.  My analysis is not yet complete, but it seems that the TI menu code starts up all right (my QI machine has the standard GROMs.)

 

This indeed suggests it's a signal issue, but the CRU lines are not used.

 

Can you elaborate "the data bus of the cartrige port is isolated from that of the I/O port"?  Does this also apply to the data bus?






0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users