Jump to content

Photo

Can't Play Centipede on my Apple IIs!?!


5 replies to this topic

#1 DistantStar001 OFFLINE  

DistantStar001

    Space Invader

  • 27 posts

Posted Wed May 9, 2018 1:45 PM

So here's the thing.  I have a copy of Centipede on a 5 1/4 in floppy that I've tried to play on 3 of my Apple IIs (//c, //gs, and Mac LC III with //e card).  All will boot the disc, and all will load the game, but when I press return to play, the //c, and Mac flash a pattern of colors on the screen, and then freeze.  Only the //gs will actually play (and does so reliably).  At first I thought that this was a problem with the disk, or maybe the file, but when I loaded the same game to my actual //e from the Apple Game Server (through the cassette in port, since I don't have a compatible drive at the moment), I got the exact same malfunction.  I've tried all four versions from the AGS (AppleSoft, and Assimilator prompts, HiFi, and LowFi), and I still get the same result.  Since I've tried multiple copies of this game, on multiple computers, and with multiple media, I'm assuming that it's not the software (also agin it does work fine on the //gs).

 

Next, I tried stripping out all of the controller, and enhancement cards cards on my //e, with no luck, and reconfiguring my Mac //e emulator with the same results every time.  I can't un-enhance my //e, as I no longer have the original chips.  The //c is stock, with no modifications.  The Mac, and //gs were both booted from the exact same floppy drive, but the //c was booted from it's internal.  All the computers are in working order, and all have been tested with other games, and software, but only Centipede produces this malfunction.  

 

So then I though maybe it was an incompatibility with the 65C02 processor (my //e is enhanced after all), and as such, the //c, and //e share the same chip.  But that wouldn't explain why it doesn't work on the Mac LC, or why it does work on the //gs, since the //e card in my LC, and //gs use the exact same chip set for 8 bit Apple II software.  

 

I'm wondering if anybody else has had this problem?  Also, if you have managed to get Centipede to work on an Apple II, let me know how.  Was it from a floppy, or cassette port?  If your computer is a //e, then was it enhanced, platinum, or standard?  Has anyone tried a //c+?  if you're using a //gs, and ran into the same, or similar problem, then what ROM version are you running? (mine's ROM 01) Finally, if you've managed to get it to work on a Mac LC, then what was the configuration, and what version of IIe Startup are you using? (mine's Version 2.2)  Any ideas? Comments?  It's just kinda bugging me, because I can't figure out why.

 

 



#2 spacecadet OFFLINE  

spacecadet

    River Patroller

  • 2,707 posts

Posted Wed May 9, 2018 4:04 PM

It's an interesting question, but I think the answer's probably contained in your post. The most likely culprit seems like illegal opcodes running on the 6502 that the 65C02 didn't support. The Apple IIe card and IIGS do not have the same CPU - the IIGS uses a 65C816 to emulate a 65C02, and the IIe card uses an actual 65C02. So my guess is that there's just something in the emulation of the 65C02 on the 65C816 chip that's allowing whatever illegal opcode that game uses to execute. It's possible that the 65C816 wasn't a 100% accurate emulation of the 65C02, but may have added back in some of the more common illegal opcodes for compatibility's sake. That would be interesting if true; and maybe it's common knowledge but I hadn't known about it. (Edit: in fact, reading a little more about the 65C816, it seems that it could emulate both the 65C02 and 6502.)

 

I could be wrong but I just think it's probably not as weird as you think it is, since it seems like part of the premise you're operating from is that the IIe card and IIGS should act the same, but there could be minor differences just as there are between the 6502 and 65C02 themselves. I would expect the IIe card to act like a IIe (and IIc), not a IIGS. A IIGS is gonna act like a... well, like a computer with a 65C816 in it.


Edited by spacecadet, Wed May 9, 2018 4:10 PM.


#3 DistantStar001 OFFLINE  

DistantStar001

    Space Invader

  • Topic Starter
  • 27 posts

Posted Thu May 17, 2018 10:57 PM

Thanks.  That explains it.  Now that I finally have a working 5 1/4 drive for my //e, I seem to be running into a lot of this.


Edited by DistantStar001, Thu May 17, 2018 11:00 PM.


#4 DistantStar001 OFFLINE  

DistantStar001

    Space Invader

  • Topic Starter
  • 27 posts

Posted Fri May 18, 2018 2:58 PM

Does any one know if there is a 65CO2 compatible version out there?



#5 Keatah OFFLINE  

Keatah

    Missile Commander

  • 20,574 posts

Posted Fri May 18, 2018 4:21 PM

I'm wondering if anybody else has had this problem?

 

Yup. Your copy is not 65C02/enhanced aware.

 

Does any one know if there is a 65CO2 compatible version out there?

 

Don't sweat the details or reasoning if you just want to play.

Look up the 4am crack OR usotski prodos port OR san inc crack.



#6 The Usotsuki OFFLINE  

The Usotsuki

    Stargunner

  • 1,949 posts
  • Also called "Licca"

Posted Fri May 18, 2018 6:05 PM

I was gonna say, my ProDOS version works fine on AppleWin in 65C02 mode...





Reply to this topic



  


0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users