Jump to content

Photo

**Now Working** Ps1 Modchips not working. Using pic12f629


2 replies to this topic

#1 icemanxp300 OFFLINE  

icemanxp300

    River Patroller

  • 4,759 posts
  • Location:NY

Posted Tue May 15, 2018 8:12 PM

Ok so nothing like wasting 3 hrs or so trying to mod a ps1 I don't even need as I already have a modded unit. At this point it is purely about principle.

 

I have tried programming numerous times different files.

 

http://www.eurasia.n...download&cid=43

 

 

The first I tried was PSX 12F629 package and it says that a 9000 series only uses 3 wires w/ a jumper. I am not sure this pcb is a 9000 series though as the unit says on bottom it is a 7501. Wiring this way will not play any games even original w/that jumper there, I think the wiring diagram may be wrong.

 

I then tried, this mm3 hex dump

 

http://www.maxconsol...released.18321/

 

This however gives me a configuration verify failed error which I believe is a programming glitch. Using Gq-4x. topic started here about it.

 

http://www.mcumall.c...p?TOPIC_ID=5513

 

I have the option of changing the file format I have tried programming the hex file as binary and hex, nothing works. Well original games will play but not burned.

 

Below are the pics of what I am using for wiring.

 

Here is the psx wiring given for the pcb I am using.

 

 

 

PSX7501.JPG

 

 

 

Here is the mm3 wiring given for the pcb I am using

 

 

 

750x.jpg

750x2.jpg

750xthumb.jpg

 

 

Here is the file format choice I can choose when I load the hex file.

 

gq4xfomat.jpg

 

 

...



#2 icemanxp300 OFFLINE  

icemanxp300

    River Patroller

  • Topic Starter
  • 4,759 posts
  • Location:NY

Posted Mon May 21, 2018 5:30 PM

Ok, so just in case this helps anyone. I decided to try the mm3 again on the pic12f629. This was after many failed attempts LOL. This time I used a different USB port and made sure to have external power on my GQ-4X programmer. I chose hex files and loaded the USA hex file and in the file format mode I chose hex file as well. I then as well lowered the write speed from +2 down to 0.

 

I soldered in a test socket into a 90001 model. I had 2 chips that worked. One was bad and another would program but not work either. At least now I am set-up w/a tester ps1, so I can program and test these and know if they are good or not.

 

The configuration verify failed happened even though the chips worked. That is a programmer error.



#3 Bratwurst OFFLINE  

Bratwurst

    Stargunner

  • 1,197 posts

Posted Wed May 30, 2018 1:19 PM

Just chiming in that I couldn't get any pic to verify writing in hex with a GQ-4X either, but they ultimately did work for the application I wrote them for.






0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users