Jump to content

Photo

ProDOS Problem


36 replies to this topic

#26 DistantStar001 OFFLINE  

DistantStar001

    Star Raider

  • Topic Starter
  • 75 posts

Posted Tue Jul 10, 2018 11:53 PM

Just out of curiosity, what is the best 80 column card for a //e?



#27 Keatah OFFLINE  

Keatah

    Missile Commander

  • 21,319 posts

Posted Wed Jul 11, 2018 1:32 AM

I like the u-SCI 80/64e. It seems to have had the best reliability over the years. And they are of simple construction. And I've used them in less than ideal environments. But all they do are the 80 Columns, Double HiRes graphics, and 64K memory expansion. Nothing as versatile as the RamWorks series from AE.

 

There's also that little shitbox card that shipped with the Platinum //e systems. Those also provide reliable basic functionality.



#28 DistantStar001 OFFLINE  

DistantStar001

    Star Raider

  • Topic Starter
  • 75 posts

Posted Wed Jul 11, 2018 1:50 AM

Do you have a picture?



#29 Keatah OFFLINE  

Keatah

    Missile Commander

  • 21,319 posts

Posted Wed Jul 11, 2018 2:44 AM

Unfortunately I do not.



#30 DistantStar001 OFFLINE  

DistantStar001

    Star Raider

  • Topic Starter
  • 75 posts

Posted Wed Jul 11, 2018 12:41 PM

So I've looked up the RAM on my VidTech card, and it uses 4264-15 chips, which according to some sources are compatible with 4164 chips (the same as in the //e).  According to one forum (on vcfed.org), this substitution worked on an Atari 800XL (running simple basic prompts).  Assuming that they work, would this work for my //e if I replaced the RAM chips on the card with those from my original mother board, or have I been reading nonsense?



#31 DistantStar001 OFFLINE  

DistantStar001

    Star Raider

  • Topic Starter
  • 75 posts

Posted Wed Jul 11, 2018 8:11 PM

OK, so swapping the RAM does work, and finally my //e passes its internal diagnostics reliably ("System OK").  My keyboard is fully functional, except a few sticky keys (Up Arrow, T, and H), but but I think some tubing alcohol, or contact cleaner will take care of that.  I'm really not in a rush on that.  It boots from both 3.5in, and 5.25in drives, and all 3 drives are functioning more or less normally (the heads are clean, and all that).  However, I still can't load ProDOS!?!  What am I missing here?

 

I'm still getting many of the same errors that I was getting when I started, and BankStreet Writer won't even load now.  I would suspect the disks, but they all load on my //c, and IIgs without a problem. I've even booted these disks on my Mac LC III (with //e card), and they seem to work without a problem, except on my actual //e.  

 

Any ideas?



#32 Keatah OFFLINE  

Keatah

    Missile Commander

  • 21,319 posts

Posted Fri Jul 13, 2018 1:00 PM

The manual just so happens to have been posted to Asimov. Right now it's in the unsorted folder, but it will soon be moved to the appropriate subsection.

 

ftp://ftp.apple.asimov.net/pub/apple_II/unsorted/80-64e%20u-SCI%20MICROSCI%2080-column%20&%2064K%20card.pdf



#33 DistantStar001 OFFLINE  

DistantStar001

    Star Raider

  • Topic Starter
  • 75 posts

Posted Mon Jul 16, 2018 2:50 PM

It's been suggested to me that the problem could be the Disk ][ controller card, but would that cause problems trying to load ProDOS, or ADTPro from the cassette ports?



#34 DistantStar001 OFFLINE  

DistantStar001

    Star Raider

  • Topic Starter
  • 75 posts

Posted Sat Jul 21, 2018 11:59 PM

It's not the Disk ][ controller card.



#35 DistantStar001 OFFLINE  

DistantStar001

    Star Raider

  • Topic Starter
  • 75 posts

Posted Sun Jul 22, 2018 12:53 AM

So I yanked my RamFactor card, and now ProDOS, and ADTPro seem to boot fine, but Bank Street is still giving me some odd problems.  

IMG 0208
  IMG 0207
 
My RamFactor did have an exposed EPROM on it, so maybe it got corrupted?  If so, how do find/make a replacement?

Edited by DistantStar001, Sun Jul 22, 2018 12:56 AM.


#36 trash_44fr OFFLINE  

trash_44fr

    Space Invader

  • 34 posts

Posted Sun Jul 29, 2018 2:42 AM

Greetings,

The RamFactor ROMs are here.



#37 DistantStar001 OFFLINE  

DistantStar001

    Star Raider

  • Topic Starter
  • 75 posts

Posted Sun Jul 29, 2018 10:35 PM

Thank you!





Reply to this topic



  


0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users