Jump to content

Photo

Atari 800XL custom bios switch questions


3 replies to this topic

#1 256 colors OFFLINE  

256 colors

    Space Invader

  • 21 posts
  • Location:Not So Great Britain any more

Posted Tue Jun 12, 2018 2:11 AM

I bought a 800XL from eBay with this switch from left to right in 3 positions i get

 

1st position 64XL with blue ready screen which pass all the tests for ram/sound/keyboard all okay

2nd position i get ether a red or yellow blank screen

3rd position i get black screen with i can type text on too

I'm guessing the switch is for xl/os b/os a in that order am i doing something or does the switch job sound like it's been botched job?



#2 Nezgar OFFLINE  

Nezgar

    Dragonstomper

  • 756 posts
  • Location:Regina SK Canada

Posted Tue Jun 12, 2018 7:28 AM

Sounds line a common switch between 2 OS ROM's. Usually between the stock XL OS, and the other for compatibility with 800 OSb.

Sounds like yours has a 3 position switch, where the centre position is not connected. red/yellow screen is a common symptom of a missing/bad OS ROM, which the centre position would simulate.

Inside I expect you would see a 2nd chip soldered on top of the first. With the switches' wires connected to the power pins of each.

I don't immediately recall a particular OS that used a black background. Maybe you could run a utility to dump the OS to a file, and upload here...

Edited by Nezgar, Tue Jun 12, 2018 7:29 AM.


#3 256 colors OFFLINE  

256 colors

    Space Invader

  • Topic Starter
  • 21 posts
  • Location:Not So Great Britain any more

Posted Tue Jun 12, 2018 7:39 AM

Sounds line a common switch between 2 OS ROM's. Usually between the stock XL OS, and the other for compatibility with 800 OSb.

Sounds like yours has a 3 position switch, where the centre position is not connected. red/yellow screen is a common symptom of a missing/bad OS ROM, which the centre position would simulate.

Inside I expect you would see a 2nd chip soldered on top of the first. With the switches' wires connected to the power pins of each.

I don't immediately recall a particular OS that used a black background. Maybe you could run a utility to dump the OS to a file, and upload here...

 

Okay thank you i not able to do any more tests as it's a bare bones setup at the moment with only 800XL/Atari power supply/RF cable/joystick and no software

I've yet to add a 1010 or a 1050 with replacement power supply so I'm quite limited to what i can do



#4 BillC OFFLINE  

BillC

    Stargunner

  • 1,773 posts
  • Location:BC Canada

Posted Tue Jun 12, 2018 1:39 PM

Sounds line a common switch between 2 OS ROM's. Usually between the stock XL OS, and the other for compatibility with 800 OSb.

Sounds like yours has a 3 position switch, where the centre position is not connected. red/yellow screen is a common symptom of a missing/bad OS ROM, which the centre position would simulate.

Inside I expect you would see a 2nd chip soldered on top of the first. With the switches' wires connected to the power pins of each.

I don't immediately recall a particular OS that used a black background. Maybe you could run a utility to dump the OS to a file, and upload here...

This machine could have a RamrodXL which has sockets for 3 individual OS chips, this upgrade uses a 3-position switch to select the active OS.

ramrodxl.jpg






0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users