Jump to content

Photo

No power to Atari 5200 4-port

no power 4 port switchbox power supply

No replies to this topic

#1 pollyisagoodbird OFFLINE  

pollyisagoodbird

    Combat Commando

  • 2 posts

Posted Sat Jul 7, 2018 12:15 PM

So my 5200 has apparently given up the ghost and just refuses to turn on. I recall the last time it functioned (about a month ago was when I played it last) it took a couple of tries to get it to turn on, but eventually it worked perfectly fine and I was able to turn it off and on with ease as I switched out games. Now all of the sudden it doesn't want to turn on at all. I have had this 5200 for a few years, and it has worked great otherwise.

 

At the moment I don't have anything to test the power supply itself. But I'm assuming it's the switchbox. When I was trying to turn it on I examined the switchbox after several attempts and noticed it smelled like burning plastic. It wasn't strong, but you could definitely smell it if you held it up to your nose. I took it apart and everything looks good, except for the part where you plug in the actual power supply. The part where you plug the console in - which was where it smelled like burning plastic the most when I examined it - seems okay.

 

Attached are pics of the switchbox, which I have taken out of its shell to look at. As you can see, the part where you plug the power supply into (the black thing, I don't know the name of it) seems rusty and corroded all over. Would this be my problem? Could I take it off the switchboard and clean it up, or would it be best to just buy a new part?

Also, what can I use to test out my power supply to make sure that's not what's causing the issue?

Attached Thumbnails

  • 20180704_134812_HDR.jpg
  • 20180704_134829_HDR.jpg
  • 20180704_134902_HDR.jpg
  • 20180704_134924_HDR.jpg






Also tagged with one or more of these keywords: no power, 4 port, switchbox, power supply

0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users