Jump to content

Photo

[Final] Tyre Trax


178 replies to this topic

#176 Karl G OFFLINE  

Karl G

    Dragonstomper

  • 850 posts

Posted Thu Apr 25, 2019 6:59 AM

The only difference between pal60 and ntsc is the color definitions, so Stella has no way of detecting the difference. It might be useful to say which colors don't seem to work well on the pal60 variant.

#177 Muddyfunster OFFLINE  

Muddyfunster

    Moonsweeper

  • Topic Starter
  • 314 posts

Posted Sat Apr 27, 2019 6:16 AM

 

Hello!

 

Great game! Fast and fun. Also, it's nice to see logs from Pitfall zoom by ;)

 

Just one issue: both the PAL 60 and NTSC register as being NTSC (you can see this in Stella under Game properties -> Display). Since I'm playing on a PAL system, I have colours being shifted in both cases, which makes the NTSC version very weird and the PAL okay-ish but too dark in some places, so you don't see the obstacles. Maybe this is a simple declaration in the program that's missing? I don't have a clue how this works, but other PAL games register and display correctly.

 

Cheers and many thanks for your work

 

 

 

Thanks for your feedback.

 

The PAL version is a PAL60 version, which means it's identical to the NTSC version but the colours are normalised to the PAL palette. PAL on the 2600 has less colours available, it's not always a 1-1 match. Reds and Yellows usually suffer a bit.

 

If you can show and example of where the colour is dark compared to the NTSC version, that would help.

 

when running the PAL60 test ROM In Stella, press CTRL + F until you cycle to PAL60.

 

Also, the ROMs on this thread are not the final ROMs. Some further minor tweaking happened for those.



#178 Gilles_B OFFLINE  

Gilles_B

    Space Invader

  • 10 posts

Posted Thu May 2, 2019 4:23 AM

 

If you can show and example of where the colour is dark compared to the NTSC version, that would help.

 

 

Hi!

 

Thanks for replying. I've attached to shots from stella where you can see the shift. Now what I see on my wall (I'm using a projector) is even darker. To give you an idea, The mountains in the background appear black. 

 

Hope this helps

Attached Thumbnails

  • Tyre Trax Game 1 ntsc.png
  • Tyre Trax Game 1 pal 60.png


#179 Gilles_B OFFLINE  

Gilles_B

    Space Invader

  • 10 posts

Posted Thu May 2, 2019 8:00 AM

as I have another pal 60 game not working as I expected (see below), I experimented further. My usual setup is the following: my light sixer, modded for composite output, goes into my ligawo upscaler to hdmi, and from there to my acer H5380BD projector. This works fine, the output from the harmony is recognised as pal (for the harmony itself and pal games) and outputs at 1080p@60Hz. So far, so good.

 

Now I have two pal60 games showing opposite behaviours. This one shows the right colours on stella but darker ones through my setup. The upscaler tells me it's receiving NTSC443, though, not PAL. 

The other game, Fear of the dark http://atariage.com/...ari-2600/page-3 , shows up in stella but in use through my setup it's the intended yellow.

 

It got me thinking, though, maybe there is something wrong with my setup. So I took out my old but trusty Toshiba TDP-FF!, a tiny projector that doesn't have hdmi and plugged the console directly into its composite port, and voila ! Reverso ! The projector recognises PAL for both games, but now Fear of the dark is green and Tyre Trax has the correct colours, both just as in Stella on the pal60 setting.






0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users