Jump to content

Photo

Power Supply Problem?


4 replies to this topic

#1 800xl_1984 OFFLINE  

800xl_1984

    Space Invader

  • 42 posts
  • Location:Missouri USA

Posted Sat Sep 15, 2018 9:21 AM

When powering my 800XL, I suddenly get a hum through audio and no boot (black screen). 800XL power light illuminates. Swapped out a second machine with the same result, so I'm chalking it up to the power supply. Does this seem like a probable cause? Which replacement power supplies are recommended?

 

Thanks,

J.

 



#2 DrVenkman OFFLINE  

DrVenkman

    River Patroller

  • 3,557 posts
  • Back off, man! I'm a scientist.
  • Location:KMBT

Posted Sat Sep 15, 2018 9:35 AM

When powering my 800XL, I suddenly get a hum through audio and no boot (black screen). 800XL power light illuminates. Swapped out a second machine with the same result, so I'm chalking it up to the power supply. Does this seem like a probable cause? Which replacement power supplies are recommended?

 

Thanks,

J.

 

 

Man, it sure sounds like an "Ingot" power supply going bad. Hope you didn't just fry two XL machines. 

 

XL Power Supplies.jpg



#3 800xl_1984 OFFLINE  

800xl_1984

    Space Invader

  • Topic Starter
  • 42 posts
  • Location:Missouri USA

Posted Sat Sep 15, 2018 9:40 AM

Agreed. I will order a replacement and see what comes of it.



#4 _The Doctor__ OFFLINE  

_The Doctor__

    Quadrunner

  • 5,645 posts
  • Location:10-0-11-00:02

Posted Sat Sep 15, 2018 9:29 PM

Never test a power supply by hooking it up to the computer and then another computer, you probably took years off it's life...

 

Humm bars, buzzing and other such noises mean ac or ground issues.. ALWAYS test with a known good power supply, If the hum goes away you will know the other one was bad and will not harm more than one computer or stress it out!



#5 800xl_1984 OFFLINE  

800xl_1984

    Space Invader

  • Topic Starter
  • 42 posts
  • Location:Missouri USA

Posted Sat Sep 22, 2018 7:23 AM

Definitely was a power supply issue. Guess I lucked out when it didn't fry the 800XLs.






0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users