Jump to content

Photo

RespeQt 4.3 beta


149 replies to this topic

#126 DrVenkman OFFLINE  

DrVenkman

    River Patroller

  • 3,956 posts
  • Back off, man! I'm a scientist.
  • Location:KMBT

Posted Fri Mar 1, 2019 4:47 PM

Interesting discussion about the PDB files, thanks. :) 

 

Has anyone managed to write a bootable floppy copy of The Goonies? Side B of the Happy Warp Backup disk has a PDB for it (#5, in case anyone wants to try themselves), but it won't successfully write a disk from either of the two ATX versions I have - both fail with a disk error on track 26. Trying a straight, no-PDB copy produces a complete disk but it fails during the boot at the credits screen but before the title screen and music appear. 



#127 _The Doctor__ ONLINE  

_The Doctor__

    Flux Capacitor Master Craftsman

  • 6,721 posts
  • Location:10-0-11-00:02

Posted Wed Mar 13, 2019 11:29 PM

So, I made binaries for Win32 and Mac.

 

attachicon.gifRespeQt_mac.zip

attachicon.gifRespeQt_win32.zip

 

@DrVenkman: I have to get out my RaspberryPi and try to build it. Stay tuned.

 

fail, says I don't have the qt core... all the others revisions I have on my computer work just fine although I am using a win64 computer...

so I renamed the binary to respeqt32.exe and put it in one of my other versions folders and launched it, worked just fine.


Edited by _The Doctor__, Wed Mar 13, 2019 11:37 PM.


#128 JoSch ONLINE  

JoSch

    Moonsweeper

  • 491 posts
  • Location:Germany

Posted Thu Mar 14, 2019 2:20 AM

fail, says I don't have the qt core... all the others revisions I have on my computer work just fine although I am using a win64 computer...

so I renamed the binary to respeqt32.exe and put it in one of my other versions folders and launched it, worked just fine.

Ok. Assuming you are unsing the Windows version, I will try to make a complete package of the binaries.



#129 JoSch ONLINE  

JoSch

    Moonsweeper

  • 491 posts
  • Location:Germany

Posted Fri Mar 15, 2019 2:05 AM

I have rebuild the binary packages for macOS and Win32 with my latest changes.

Beware that these are only binary packages, you also need the complete package, you find here http://atariage.com/...beta/?p=4150092.

Replace the binary in the complete package with the binaries found in the new ones.

 

If there are problems, please PM me or ebiguy.

 

Attached Files



#130 Kyle22 OFFLINE  

Kyle22

    River Patroller

  • 4,017 posts
  • Call my BBS! telnet://broadway1.lorexddns.net
  • Location:McKees Rocks (Pittsburgh), PA

Posted Sun Mar 17, 2019 9:43 PM

I have found the bug in the last several versions of RespeQt. It crashes to an Error Report. This prevented me from doing a backup of my BBS until I found out the problem.

 

I un-ARCd (IIRC, or possibly copied) some files to the drive and didn't notice their datestamp was 9 Feb 47. EVERY one of these files crashed RespeQt.

After I did CHTD on the offending files I was able to do a full [Error Free] backup at divisor zero.

 

Error message pic:

IMG_2749.JPG

 

Edit: Here's a pic of what it choked on:

 

IMG_2750.JPG


Edited by Kyle22, Sun Mar 17, 2019 9:59 PM.


#131 _The Doctor__ ONLINE  

_The Doctor__

    Flux Capacitor Master Craftsman

  • 6,721 posts
  • Location:10-0-11-00:02

Posted Sun Mar 17, 2019 9:57 PM

I'd say that's an issue to be addressed for sure.....    the fun part begins....



#132 Kyle22 OFFLINE  

Kyle22

    River Patroller

  • 4,017 posts
  • Call my BBS! telnet://broadway1.lorexddns.net
  • Location:McKees Rocks (Pittsburgh), PA

Posted Sun Mar 17, 2019 10:01 PM

I'd say that's an issue to be addressed for sure.....    the fun part begins....

Yes, it does. :)



#133 flashjazzcat OFFLINE  

flashjazzcat

    Quadrunner

  • 14,494 posts
  • Location:United Kingdom

Posted Mon Mar 18, 2019 1:28 AM

Yep: dozens of users with files from the late Forties are going to be tripped up with this one. Critical! :)

Perhaps RespeQt is attempting to create a file with a date stamp of 1947 or 2047, which I guess will create issues.

#134 JoSch ONLINE  

JoSch

    Moonsweeper

  • 491 posts
  • Location:Germany

Posted Mon Mar 18, 2019 4:47 AM

Kyle22, thanks for the bug report. We will look into it.



#135 _The Doctor__ ONLINE  

_The Doctor__

    Flux Capacitor Master Craftsman

  • 6,721 posts
  • Location:10-0-11-00:02

Posted Mon Mar 18, 2019 5:19 AM

consider a time traveling DeLorean, or time traveling retrogamers... or any number or Real time clock scenarios, plus the fact it happened to people backing up their BBS... yeah it is a big enough problem. The time date of files from within an extracted zip or a real time clock in need of setting or bad batteries of the RTC... I fully expect 8 bit users will still be using their Atari's in 2047!! And of course we may be traveling back to the future at any time...

 

No one likes hitting a brick wall at 87 mph or doing so at 88 mph but not having the wattage to make the jump.... in any event it happened to more than one sysop so I say good detective work KYLE22, glad we could run this one down. Y2047K !!      ) probably other years will do this as well.... time to make a directories full of ascending date stamp files to see where it starts going kabloohy! (


Edited by _The Doctor__, Mon Mar 18, 2019 5:21 AM.


#136 DrVenkman OFFLINE  

DrVenkman

    River Patroller

  • 3,956 posts
  • Back off, man! I'm a scientist.
  • Location:KMBT

Posted Mon Mar 18, 2019 5:51 AM

Here’s another issue/bug report combined with a question. In the current version, I cannot use the Explore disk option to copy files into the disk image. I’m sure I’ve done this in the past but it doesn’t appear to be working on my 4.3 installation.

Perhaps relatedly, although RespeQt lets me mount a folder as a drive(e.g., my Desktop), I cannot seem to access any files stored there even to load them. I’ve used this process in the past so I know it used to work.

Be nice to know if anyone else has run into these issues.

#137 JoSch ONLINE  

JoSch

    Moonsweeper

  • 491 posts
  • Location:Germany

Posted Mon Mar 18, 2019 7:07 AM

Here’s another issue/bug report combined with a question. In the current version, I cannot use the Explore disk option to copy files into the disk image. I’m sure I’ve done this in the past but it doesn’t appear to be working on my 4.3 installation.

Perhaps relatedly, although RespeQt lets me mount a folder as a drive(e.g., my Desktop), I cannot seem to access any files stored there even to load them. I’ve used this process in the past so I know it used to work.

Be nice to know if anyone else has run into these issues.

Is this on a specific platform, or on all?



#138 ebiguy OFFLINE  

ebiguy

    Chopper Commander

  • Topic Starter
  • 213 posts
  • Location:Paris, France

Posted Mon Mar 18, 2019 1:18 PM

Here’s another issue/bug report combined with a question. In the current version, I cannot use the Explore disk option to copy files into the disk image. I’m sure I’ve done this in the past but it doesn’t appear to be working on my 4.3 installation.

Perhaps relatedly, although RespeQt lets me mount a folder as a drive(e.g., my Desktop), I cannot seem to access any files stored there even to load them. I’ve used this process in the past so I know it used to work.

Be nice to know if anyone else has run into these issues.

 

Hi, thank you for using and testing and reporting issues on RespeQt.

I found the bug (my fault !).

It is fixed.

But before rebuilding, I am going to look at the issue about last modified date.



#139 ebiguy OFFLINE  

ebiguy

    Chopper Commander

  • Topic Starter
  • 213 posts
  • Location:Paris, France

Posted Mon Mar 18, 2019 2:27 PM

I have found the bug in the last several versions of RespeQt. It crashes to an Error Report. This prevented me from doing a backup of my BBS until I found out the problem.
 
I un-ARCd (IIRC, or possibly copied) some files to the drive and didn't notice their datestamp was 9 Feb 47. EVERY one of these files crashed RespeQt.
After I did CHTD on the offending files I was able to do a full [Error Free] backup at divisor zero.

Hi Kyle22,

I am not sure to understand how to reproduce the problem.

I understand that you have a file with date 47 but where is it (what is C: on your screenshot ?). Is it an ATR image in RespeQt or a folder image or a real hardisk plugged in the Atari (SIDE2 + CF card).

You say you make a backup. From which device to which device ? Which SpartaDos command ? (is it SpartaDos - it looks like but not sure)

Could you provide a very detailed explanation of the configuration and the procedure to follow so I can reproduce (what do you configure in respeQt, which commands are run under DOS...) ?

 



#140 _The Doctor__ ONLINE  

_The Doctor__

    Flux Capacitor Master Craftsman

  • 6,721 posts
  • Location:10-0-11-00:02

Posted Mon Mar 18, 2019 3:22 PM

I doesn't matter what device it copies from, it only matters that it is copied to the PCLx: drive that lives on the windows machine



#141 DjayBee OFFLINE  

DjayBee

    Moonsweeper

  • 359 posts
  • Location:Stuttgart, Germany

Posted Mon Mar 18, 2019 3:39 PM

But before rebuilding, I am going to look at the issue about last modified date.


AFAIK Unix can only address years until 2038.

Perhaps it is failing due to the fact that the files are tried to be timestamped with the year 2047.

#142 JoSch ONLINE  

JoSch

    Moonsweeper

  • 491 posts
  • Location:Germany

Posted Mon Mar 18, 2019 4:03 PM

Normally, the tinestamp should wrap around. My guess would be, that a Date object is supposed to be created, but couldnt be. So the program crashes.

#143 Kyle22 OFFLINE  

Kyle22

    River Patroller

  • 4,017 posts
  • Call my BBS! telnet://broadway1.lorexddns.net
  • Location:McKees Rocks (Pittsburgh), PA

Posted Mon Mar 18, 2019 5:00 PM

It is SDX 4.47.

Copying from hard drive partition D3: (C: drive) to RespeQt using PCLINK protocol.

 

Edit: punctuation.


Edited by Kyle22, Mon Mar 18, 2019 5:01 PM.


#144 _The Doctor__ ONLINE  

_The Doctor__

    Flux Capacitor Master Craftsman

  • 6,721 posts
  • Location:10-0-11-00:02

Posted Mon Mar 18, 2019 6:22 PM

It's not problem on the Atari side.

 

Temporary work around, make an error directory in the RespeqQT folder or the active pclink folder, copy the out of bounds date material with today's date (Atari none the wiser) ... when done copying all files let RespeQT bring up the error directory and ask to rename or re-date the offending files, when doing so RespeQT just uses move the on the files with the corrections...

 

best to do a real fix though.... in 19 short years this shouldn't be another y2k'ish frenzy... after all 1978 to 2001 was 23 years give or take, we have from 2019 to 2038... yeah we don't need this to keep happening every 15 to 20 years that's for sure... :)



#145 Kyle22 OFFLINE  

Kyle22

    River Patroller

  • 4,017 posts
  • Call my BBS! telnet://broadway1.lorexddns.net
  • Location:McKees Rocks (Pittsburgh), PA

Posted Mon Mar 18, 2019 10:09 PM

Or, for purposes of speed, just re-date them on the fly to today's date. :)

 

Edit: The current date as of time of file transfer. Obviously, not Today's (this day's) date.

 

Edit: Clarity


Edited by Kyle22, Mon Mar 18, 2019 10:14 PM.


#146 ebiguy OFFLINE  

ebiguy

    Chopper Commander

  • Topic Starter
  • 213 posts
  • Location:Paris, France

Posted Thu Mar 21, 2019 5:04 PM

Or, for purposes of speed, just re-date them on the fly to today's date. :)

 

I pushed the 2 fixes on Git repo:

- avoid the crash and ignore the bad date.

- fix the communication issue with folder image.

 

Could you please test this version and tell me if it is OK.

Attached Files



#147 Kyle22 OFFLINE  

Kyle22

    River Patroller

  • 4,017 posts
  • Call my BBS! telnet://broadway1.lorexddns.net
  • Location:McKees Rocks (Pittsburgh), PA

Posted Thu Mar 21, 2019 5:40 PM

I pushed the 2 fixes on Git repo:
- avoid the crash and ignore the bad date.
- fix the communication issue with folder image.
 
Could you please test this version and tell me if it is OK.


Sure, when I get home. I'm on my phone now.

#148 Kyle22 OFFLINE  

Kyle22

    River Patroller

  • 4,017 posts
  • Call my BBS! telnet://broadway1.lorexddns.net
  • Location:McKees Rocks (Pittsburgh), PA

Posted Thu Mar 21, 2019 10:20 PM

Well, it seems as if SDX 4.47 doesn't allow me to change the year to 47.

 

I'll work on this.

 

Doing another full backup now.

 

Will report.

 

Edit: I'll RTF the SDX M.

 

CHTD will not do this. I must sector-edit or find the original source of he offending files.

 

No prob. I'll get this. Hold on.

 

I'll do this tomorrow. Backup still running nice at divisor zero.

:)

It's getting late. Board will beck up in the morning.


Edited by Kyle22, Thu Mar 21, 2019 10:46 PM.


#149 Kyle22 OFFLINE  

Kyle22

    River Patroller

  • 4,017 posts
  • Call my BBS! telnet://broadway1.lorexddns.net
  • Location:McKees Rocks (Pittsburgh), PA

Posted Fri Mar 22, 2019 7:54 AM

Sorry, brain fart. I guess if I set the date first, then do CHTD, then set it back should do the job.



#150 Kyle22 OFFLINE  

Kyle22

    River Patroller

  • 4,017 posts
  • Call my BBS! telnet://broadway1.lorexddns.net
  • Location:McKees Rocks (Pittsburgh), PA

Posted Wed Apr 17, 2019 6:02 PM

Sorry, I guess I forgot to report that it works perfectly now. Thanks.

The bad dates are on the files contained in an ARC. Un-ARCing them to hard disk is what triggered the bug.





Reply to this topic



  


0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users