Jump to content

Photo

Coleco Telstar troubleshooting


1 reply to this topic

#1 supercoupe91 OFFLINE  

supercoupe91

    Chopper Commander

  • 120 posts

Posted Wed Jan 23, 2019 6:40 PM

Recently picked up a Telstar pong unit and I'd like to get it working. It powers on makes noise, but I can't get a picture. I'm using an av to coax adapter and I've tried replacing the rf cable. Also tried adjusting the pots inside but the best I could get was a flickering in the static. I've also tried reflowing the solder on joints around the rf module but I'm really just spit balling at this point. Some actual direction here would be quite helpful. I should also add that I'm testing on a Crt and haven't even attempted to try on a modern set.

#2 RevEng OFFLINE  

RevEng

    Bit Player

  • 5,214 posts
  • Location:bottom of the stack

Posted Wed Jan 23, 2019 10:24 PM

One option would be to do a composite video mod. Even if you don't want to do that, the linked post has the pinout for the AY-3-8500 pong chip, and a manual with a reference design that matches the telstar more or less.




0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users