Jump to content

Photo

Compact Computer 40 Plus


17 replies to this topic

#1 fabrice montupet OFFLINE  

fabrice montupet

    Moonsweeper

  • 496 posts
  • Location:Burgundy - France

Posted Tue Feb 26, 2019 3:20 AM

Hi,

 

CC-40 Plus owners could show detailed pictures of the motherboard?  I would like to know if there have been different versions of it.

Thanks by advance :)


  • kl99 likes this

#2 kl99 OFFLINE  

kl99

    Dragonstomper

  • 869 posts
  • Location:Vienna, Austria

Posted Tue Feb 26, 2019 2:21 PM

will do, added to my todo list



#3 fabrice montupet OFFLINE  

fabrice montupet

    Moonsweeper

  • Topic Starter
  • 496 posts
  • Location:Burgundy - France

Posted Tue Feb 26, 2019 3:25 PM

Thank you :) I would like to know if the TI engineers made the motherboard  in one shot or after some PCB corrections. 

 

Here is a picture of mine, fully fonctionnal after a week of repairs (received dead) :

cc40plus1.jpg

 

cc40plus2.jpg

 

ticc40plus3.jpg

 

ticc40plus4.jpg


  • arcadeshopper , Ksarul and RickyDean like this

#4 arcadeshopper OFFLINE  

arcadeshopper

    River Patroller

  • 4,337 posts
  • Location:Portland, Oregon USA

Posted Tue Feb 26, 2019 3:29 PM

Thank you icon_smile.gif I would like to know if the TI engineers made the motherboard  in one shot or after some PCB corrections. 

 

Here is a picture of mine, fully fonctionnal after a week of repairs (received dead) :

 

 

did you have a repair log?



#5 fabrice montupet OFFLINE  

fabrice montupet

    Moonsweeper

  • Topic Starter
  • 496 posts
  • Location:Burgundy - France

Posted Tue Feb 26, 2019 3:56 PM

I just made a page (In french) dedicated to the repair, here:

http://www.ti99.com/...d-un-cc-40-plus

 

 

 


  • arcadeshopper , Ksarul , 99er and 2 others like this

#6 arcadeshopper OFFLINE  

arcadeshopper

    River Patroller

  • 4,337 posts
  • Location:Portland, Oregon USA

Posted Tue Feb 26, 2019 5:35 PM

I just made a page (In french) dedicated to the repair, here:

http://www.ti99.com/...d-un-cc-40-plus

 

 

very nice work!



#7 kl99 OFFLINE  

kl99

    Dragonstomper

  • 869 posts
  • Location:Vienna, Austria

Posted Wed Feb 27, 2019 1:54 PM

Is it the one from Curtis?

http://www.suddenlin...rtismc/cc40.htm



#8 fabrice montupet OFFLINE  

fabrice montupet

    Moonsweeper

  • Topic Starter
  • 496 posts
  • Location:Burgundy - France

Posted Wed Feb 27, 2019 2:43 PM

The motherboards are identical but unlike the model presented in this page, mine has no black TI logo and no top and back sides inscription.

And yours?



#9 curtis OFFLINE  

curtis

    Star Raider

  • 57 posts
  • Location:Amarillo, TX

Posted Wed Feb 27, 2019 5:08 PM

Is it the one from Curtis?

http://www.suddenlin...rtismc/cc40.htm

Yes, this is one I forgot I had.

 

I picked it up from a guy who thought he could solder and he couldn't.  Just ask Fabrice!

 

I had planned on fixing it myself, but never got around to it and actually had forgotten I even had it.  Didn't find it again until I started cleaning things out.  Since I got it, my eyesight has not improved and I knew I wasn't up to the task of bringing this back to life.  Fabrice did an outstanding job on it as you can tell from the logs.

 

Curtis


  • arcadeshopper likes this

#10 acadiel OFFLINE  

acadiel

    Stargunner

  • 1,506 posts
  • www.hexbus.com
  • Location:USA

Posted Wed Feb 27, 2019 7:25 PM

I just made a page (In french) dedicated to the repair, here:
http://www.ti99.com/...d-un-cc-40-plus
 
 
 


Amazing!

Ksarul has my old plus. I might have the pictures kicking around here.

#11 acadiel OFFLINE  

acadiel

    Stargunner

  • 1,506 posts
  • www.hexbus.com
  • Location:USA

Posted Wed Feb 27, 2019 7:41 PM

Some notes - the cassette board is broken in the same place.

There are two LEDs.

Also note that adding a 32K cart only brings it from 6K to 18K.

fc7bfa5f2aefe43c78507caeb97aceb9.jpgadce2315f9ab2324d79ed76206b23403.jpge70f56d202ccf3cf3d6d5c69499e3c1e.jpg13aa21d224fc6ec2b29d05f048cad521.jpgf196871ae2c7f331bba173de0a59fe28.jpg368ab28dfed22b66639e3e549d5e7e9b.jpg4e0810a785350deb287340124106e2ce.jpg0177572c659d2d79b89ee6b342f3d04d.jpgadc6ee14022efdccf6e41ec34828ec2c.jpg98d428429eb17f668c8d46f7c0d3fdda.jpg84bd63641aa77b7d37dbff02c13614ee.jpg6d66e83823e1c0f40c9b31e45b114a36.jpg388e0902afa632114eb8c76cb1600d27.jpg03de5971de5f44e1c649a7e36daf8c8d.jpgc9b6cb6eb9f26e5cd73316f38dd10c93.jpg5d194cea3cc9a0f4c6444234620fd0cf.jpgea6454fec2e6b72888c0c80f44e8d27f.jpg
  • fabrice montupet likes this

#12 fabrice montupet OFFLINE  

fabrice montupet

    Moonsweeper

  • Topic Starter
  • 496 posts
  • Location:Burgundy - France

Posted Wed Feb 27, 2019 8:04 PM

Thank you Curtis,

 

Interesting information for the CC-40 Plus owners:
If you look at this Curtis's picture:

power+.jpg

 

And a picture of the CC-40 Plus I got:

cc40plusr4.jpg

 

You'll notice a similarity: All the two mini brown PCB are broken at the same place. There is a explanation: this is due to a TI (or TDK) design error. When the keyboard/LCD board is installed in the top side of the chassis,  small little plastic tubes must be placed on each brace, the goal is to put the motherboad to a precise distance from the keyboard/LCD board is (about 1cm). But the mini PCB has a problem of dimension. One of the little tubes is in contact to the mini PCB when the motherboard is installed, so this tube has good chance to damage the mini PCB. If you have the same model of prototype, be carefull during the assembly. The best way to prevent this problem is to install a smaller tube or not install one at this place.
About this mini PCB, I think that its goal is not to generate the cassette signal but to supply all the needed tensions to the motherboard.
 

 



#13 fabrice montupet OFFLINE  

fabrice montupet

    Moonsweeper

  • Topic Starter
  • 496 posts
  • Location:Burgundy - France

Posted Wed Feb 27, 2019 8:07 PM

Oh! thank you Jon for all these pictures! Interesting! :)
Note that your mini brown PCB has the same problem as I described !

 

I see that there is a strap on R222 of mine.


Edited by fabrice montupet, Wed Feb 27, 2019 8:33 PM.


#14 curtis OFFLINE  

curtis

    Star Raider

  • 57 posts
  • Location:Amarillo, TX

Posted Thu Feb 28, 2019 3:31 PM

Interesting historical note.

 

The CD initials in the pictures, if I remember correctly, are for C. D. Wilson, the project manager for the CC-40+ project.  I met him a few years back.  Quite an interesting fellow.  He told me the problem with the wafertape was just a few days form being fixed when the CC-40 project got canceled along with the 4A.  Something about spin up timings.  Too many years ago...


  • acadiel likes this

#15 fabrice montupet OFFLINE  

fabrice montupet

    Moonsweeper

  • Topic Starter
  • 496 posts
  • Location:Burgundy - France

Posted Fri Mar 1, 2019 2:59 AM

Interesting historical note too! :)

 

At a time when everything in computing market was going very fast, each month, each week counted. It's sad that Texas Instruments killed its projects for the CC40. It is even more incomprehensible that the firm replaced it with the TI-74 marketed in 1986. At the end of 1983, the CC-40 Plus were finalized, its peripherals and accessories were numerous, even the Wafertape was near to be operational. TI kill all this stuff to replace it with a very good pocket calculator, but launched too late.
I asked myself why there was "CD" inscriptions on most of the CC-40 Plus. I don't imagine that C. D. Wilson wrote it during the developpment of the compact computer. If there are logical initials,  it would be the ones of the developpers on their own material. I conclude that  C. D. Wilson collected all the CC-40 he could for him when TI decided to destroy all the stuff. If it's the case, thanks to him.


  • Ksarul and RickyDean like this

#16 fabrice montupet OFFLINE  

fabrice montupet

    Moonsweeper

  • Topic Starter
  • 496 posts
  • Location:Burgundy - France

Posted Fri Mar 1, 2019 3:21 PM

During my tests the voltage peaks at the output of the LM358 were not sufficient to light the two LEDs, everything actually matches the fact that they were placed in the circuit to operate as a conventional diode and clipping the cassette OUT signal. The forward voltage of a 1N4148 is not sufficient.



#17 kl99 OFFLINE  

kl99

    Dragonstomper

  • 869 posts
  • Location:Vienna, Austria

Posted Sat Mar 2, 2019 3:34 PM

During my tests the voltage peaks at the output of the LM358 were not sufficient to light the two LEDs, everything actually matches the fact that they were placed in the circuit to operate as a conventional diode and clipping the cassette OUT signal. The forward voltage of a 1N4148 is not sufficient.

 

would this change if you use the AC-9201 for powering the unit? The Wafertape drive had a similar issue, where stability if ever could only be reached via non-battery mode.



#18 fabrice montupet OFFLINE  

fabrice montupet

    Moonsweeper

  • Topic Starter
  • 496 posts
  • Location:Burgundy - France

Posted Sat Mar 2, 2019 3:59 PM

My CC-40+ has no issue, it works fine, all its components have been tested OK (CPU, 18Kb RAM, ROM, LCD, ... )  I have also tested the 40+ with the Hexbus Printer Plotter and RS232C expansions , I saved and loaded a program on a tape recorder and I have done the same on a floppy disk with the disk controller I made.  All is OK :)

In any cases, the AC-9201 is the power supply is usualy use with my CC-40 units.

 

I just wondered why there are two leds on the PCB, and I think having found their use, they are used as classic diodes and not as lights.


Edited by fabrice montupet, Sat Mar 2, 2019 4:40 PM.

  • Ksarul and RickyDean like this




0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users