Jump to content

Photo

GoTek in external Oceanic enclosure


3 replies to this topic

#1 telmnstr OFFLINE  

telmnstr

    Space Invader

  • 34 posts

Posted Thu May 16, 2019 9:28 PM

Hello,

 

  I picked up a Gotek (black) floppy emulator along with the $2 OLED screen. I reflashed the firmware with FlashFloppy using st32flash (available via ubuntu apt-get) as my fake prolific 5v serial USB dongle kept getting rejected by Windows 10 and Windows 10 USB passthru to Ubuntu in Virtualbox. The flash firmware works great, and the OLED screen is sexy.

 

 It is mounted in an Oceanic America external case, which had a Chinon FB-354. The Chinon is jumpered as master, and the case has a PCB in it with a single IC. There was a wire running from the PCB to a WPS point on the PCB (write protect switch?)

 

 Only once ever has my ST Mega 2 been able to talk to the drive. I always get drive not found.

 

 The internal drive has always been failed as long as I have owned the machine, and I couldn't find a replacement.

 

 I disconnected the internal drive so it would no longer respond, hoping that the external would respond (as B.) Is this an incorrect assumption? Does SD0 need to be there for SD1 to work?

 

 I have tried the GoTek jumpered as SD0, SD1, and both.

 

 The other Oceanic floppy I have, I just tried it and it doesn't seem to work either.

 

I believe it is possible to rejumper the Atari internally so the external drive becomes drive A? Worthwhile?

 

I have had a MegaSatan in the ST for a number of years. Mounted it on standoffs to the metal RF shield so the cards are accessible via the rear expansion slot.

 

 Any tips appreciated!


Edited by telmnstr, Thu May 16, 2019 9:29 PM.


#2 Umberto OFFLINE  

Umberto

    Moonsweeper

  • 322 posts
  • Location:Washington State

Posted Thu May 16, 2019 10:00 PM

Both internal and external drives must be set to SEL0. Are you inverting the 34pin cable on the gotek? if you are then I would suspect drive select is problematic,  which is a function of the Yamaha chip.



#3 ParanoidLittleMan ONLINE  

ParanoidLittleMan

    Stargunner

  • 1,679 posts

Posted Fri May 17, 2019 2:07 AM

This seems like PSG chip failure - and from that chip come floppy selection lines, without buffering, so they are 'fragile' . I had that problem when attached 5 inch floppy drive to Atari. Needed to replace PSG chip. What should not cost too much even now .



#4 telmnstr OFFLINE  

telmnstr

    Space Invader

  • Topic Starter
  • 34 posts

Posted Fri May 17, 2019 4:06 PM

Mmm turns out it was a lack of MS0 jumper on the GoTek? I found an older posting on here that mentions it being jumpered. I didn't notice talk of that anywhere else though.

 

It now shows up as both drives. I haven't tried it with the 520ST yet.

 

Interesting regarding PSG IC. I've always been turning off both devices before plugging/unplugging the huge DIN cable. Now I will always do so.

 

Some other notes... the Oceananic external drive is a higher than half height drive, so the GoTek has a gap between the top and the top of the Oceanic housing. Also the screw holes are off on the sides, or bottom... so one or the other is going to have to get drilled to mount the cover back on properly (the Oceanic cover secures to two screw holes on the chassis and the 4 screw holes in the side of the drive. The drive is also screwed down to the bottom of the chassis. Its compact but not as elegant for GoTek unfortunately. It will work tho.

 

Mega 2 ST + GoTek:

 

Atari mega2 Gotek

 


Edited by telmnstr, Fri May 17, 2019 4:14 PM.





0 user(s) are browsing this forum

0 members, 0 guests, 0 anonymous users