Jump to content

Room 34's Photo

Room 34

Member Since 1 May 2002
OFFLINE Last Active Feb 22 2013 6:56 AM

Topics I've Started

Help! My Asteroids cocktail table is not displaying video

Sun Feb 26, 2012 4:53 PM

I have an Asteroids cocktail table that I've owned for about 10 years. It has been sitting upstairs in my house unused for the past several months. The last time I fired it up, though, it was working perfectly.

Unfortunately now I have a problem. I just turned it on, for the first time in months, and there's no video. It's definitely turning on (I can hear it) and when I open the cabinet while it's powered up, I see a solid red light on each board, and an orange glow coming from the bottom of the CRT. (Is that a vacuum tube? I have no idea.) But nothing ever comes up on the screen.

My problem is, I don't know if the CRT is just dying/dead (in which case, I think it's pretty much a lost cause), or if there's a simple part like a vacuum tube or fuse that needs to be replaced. Or maybe it's something with one of the boards, but I don't think that's the case.

I created a video demonstrating what I've described above, in case actually seeing it in action helps anyone diagnose the problem.



Basically, I am just hoping someone who knows more about how these things work can give me an idea of whether this is something I can easily resolve myself, whether it needs a pro repair, or whether it's just a lost cause.

(I am old enough to know that it takes a while for this kind of display to warm up. But even after it was left on for several minutes, there was nothing on the screen.)

Thanks!