Jump to content

JimDrew's Photo

JimDrew

Member Since 1 Oct 2013
OFFLINE Last Active Apr 15 2018 10:55 AM

Posts I've Made

In Topic: 1541U2+ Doesn't Work on C64 Reloaded Mk2

Sun Apr 15, 2018 10:56 AM

If you isolate pin 2 on the user port from the user port device, you can supply a separate 5v supply to device (along with ground of course) and that will resolve the issue.  As long as the Mk2 is not supplying the +5v to the user port device then there are no video issues.


In Topic: 1541U2+ Doesn't Work on C64 Reloaded Mk2

Sun Apr 15, 2018 10:03 AM

Apparently using any user port device that requires power with the Mk2 cause the same display issue, not just the WiModem.


In Topic: 1541U2+ Doesn't Work on C64 Reloaded Mk2

Sat Apr 14, 2018 4:40 PM

The only thing I have found that causes 'Issues' on the MK2 is the Wimodem as it sends 5v pulses that cause display interference.

 

That's a myth.  There are no "pulses" sent by the WiModem.  The problem is with the C64Reloaded's 8701 replacement circuitry.  It is too sensitive to changes in the 5 volt rail.  The exact same problem exists with the C64Reloaded Mk1 board *if* you use the fake 8701 board.  If you use a real 8701 with the C64Reloaded Mk1 board there are no issues.  Likewise, if you put the fake 8701 board into a C64 you will then have the issues.  Also, if try to use several other user port devices, such as Jason Ranheim's EPROM programmer, the PP64 EPROM programmer, or the Covox Voicemaster with the fake 8701 board or the C64Reloaded Mk2 board, you will also have the exact same issue that is seen with a WiModem. 

 

So... let's recap:

 

C64Reloaded Mk1 board with fake 8701 and WiModem, EPROM programmer, or digitizer = video artifacts

C64Reloaded Mk 1 board with real 8701 and WiModem, EPROM programmer, or digitizer = perfect video

C64Reloaded Mk2 board with WiModem, EPROM programmer, or digitizer = video artifacts

C64 with fake 8701 and WiModem, EPROM programmer, or digitizer = video artifacts

C64 with real 8701 and WiModem, EPROM programmer, or digitizer = perfect video


In Topic: Wifi modem! Telnet from any computer with a serial port

Sat Feb 3, 2018 11:46 PM

New version of firmware has been released!

 

---------------------------------------------------------------------------------------------

 
v2.60 - 02/03/18

  • Added buffer limit (*BL) value to AT&V output.
  • Changed buffer code to allow space characters in the BUSY message.
  • Added support for a/, which repeats the last AT command.
  • Fixed issue with phone book entries not storing (AT&Zx=).
  • Created new command ATI3 to show the connection time information.
  • Changed +++ parser to match the Hayes specification, fixing problems with uploads with +++.
  • Fixed input parser when no characters are in the buffer.

In Topic: Wifi modem! Telnet from any computer with a serial port

Sat Feb 3, 2018 5:07 PM

Yep... I was going through the code and cleaning it up and I killed a line of code at some point.  I have also fixed the +++ parser.  That was broken in a funny way where if your uploaded file had 3 or more + characters in a row it would put the WiModem232 into command mode!  I am testing the new features as well and I will release this shortly.