Jump to content
  • entries
    654
  • comments
    2,653
  • views
    874,632

HiDPI

SpiceWare

1,578 views

The EyeTV software is normally used full-screen when watching a show, but I've found that it's easiest to use the OS X GUI to scheduling recordings. This is difficult to do as my TV uses 7" CRT tubes to generate the display, which limits the horizontal resolution to something between (if I recall correctly) 1300 & 1400 pixels which results in hard to read text. The next model up from my HDTV used 9" CRT tubes, and it was able to resolve the full 1920 across the screen, but that was not within my budget. The other problem is the interlacing (that's the i in 1080i) causes a lot of flicker, which also contributes to making it difficult to read.

 

1080i

blogentry-3056-0-56426800-1357358063_thumb.jpg

 

1080i closeup

blogentry-3056-0-90468900-1357358068_thumb.jpg

 

OS X supports something called HiDPI, which is used to drive the new Retina Displays. Basically the OS treats the resolution at half in each direction and draws each "virtual pixel" using 4 real pixels so everything appears to be twice as big. Text and HiDPI aware programs will use all 4 real pixels and generating high quality images. 1080i is 1920x1080, so switching to HiDPI means it'll treat it like a 960x540 display.

 

The HiDPI settings were initially hidden, so I entered this on the command line to enable them:

sudo defaults write /Library/Preferences/com.apple.windowserver DisplayResolutionEnabled -bool YES;
sudo defaults delete /Library/Preferences/com.apple.windowserver DisplayResolutionDisabled;

 

The HiDPI option showed up but when I selected it the mini switched to 50 Hz for some reason, which my TV doesn't support. Remoting into the mini I changed it back to 60 Hz, but then it would switch back to 1080i instead of HiDPI. I went around and around with that for a while, which was rather frustrating. I then found a shareware utility, SwitchResX, that let me select HiDPI at 60Hz. Works great, so I registered it.

blogentry-3056-0-37822800-1357360016_thumb.png

 

HiDPI

blogentry-3056-0-90490700-1357358074_thumb.jpg

 

HiDPI closeup

blogentry-3056-0-61253100-1357358079_thumb.jpg

 

Using HiDPI also reduced the amount of flicker.

 

 

I have discovered that the Aggregate Device causes AirServer to output noise instead of the whatever audio is sent from the iDevice. I haven't looked at it very much, but did find that switching the Sound Output back to just HDMI cleared it up. I hope to find a fix for this so I can leave audio out using the Aggregate Device.



2 Comments


Recommended Comments

The AirServer issue with the Aggregate Device appears to have fixed itself.

 

I did find an issue with using HiDPI - some non-resizeable windows are too large and the bottom ends up offscreen. I found 4 preference panels in EyeTV 3 that were clipped, 2 of them with controls that are inaccessible. I've dropped Elgato a support request on it. The forms have quite a bit of white space so it should be easy for them to address it.

 

There's a few Mac preference windows that are too big as well - I believe that's because 800x600 is the lowest resolution officially supported by OS X.

Share this comment


Link to comment

Guess they're not going to address it :(

Sadly the resolution you listed, 960x540, is lower than the required resolution to run the program. Mac OS X v10.5.8 or later systems do not support such a resolution.

Share this comment


Link to comment
Guest
Add a comment...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...