Jump to content

About This Club

The little box that saves and talks! This club is meant to serve as a central location for information about AtariVox programming: creating and incorporating voices into homebrews, and using it to save and load game data (high scores, game progress and other settings).

  1. What's new in this club
  2. It is a general problem, not related to the AtariVox. E.g. see here.
  3. Alrighty, thanks for the help. I did a quick search for a trouble shooting place on the forums and in the manual. This club was all I found.
  4. Well, if you look around at AtariAge, this is a common problem.
  5. I don’t know much about shielded RF cables. Nothing at all really, but do find it a bit odd that I would need one and others do not if this isn’t a common problem. My machine isn’t modded at all.
  6. I suppose you need a better shielded RF cable.
  7. Just tried speakers. No change, still very fuzzy.
  8. I am not in any way an electronics expert, but could you try plugging in headphones or speakers and see if it helps?
  9. I hooked the Atari up through the antenna on my hdtv and same issues as the CRT. Clear without AtariVox+, fuzzy with AtariVox+. Second controller port works fine when a controller is plugged into it. Any ideas? (Also, no speaker is hooked into the Atarivox+ if that matters. Was just going to use it as a savekey for Penult)
  10. I just recently got my Atarivox+. I haven't had any trouble with my four switch 2600 before, but this could obviously be something maybe faulting out with this 40 year old system and have nothing to do with the Atarivox+, not really sure. It's connected to a NTSC CRT television. When I plug the Atarivox into the second controller port the screen turns fuzzy, but as soon as I take it out the screen is clear again. Power issue? Atarivox issue? I haven't noticed this with a second controller plugged into the system. Before Atarivox+: After I plug it in: Thanks for any help with this
  11. Good to see at least that Stella is emulating the behaviour correctly. I suspect that before we added the flow control in version 6.3, it wouldn't have worked at all.
  12. Posting this for posterity: When writing to the AtariVox EEPROM (and I presume MemCard/SaveKey), it seems that it's necessary to wait for the write-commit to be acknowledged before starting a second write, or the second write will be silently ignored. Tested both on Stella's software AtariVox emulation and using a Harmony cart with a real AtariVox. Basically all you have to do is something like this: WaitForI2CAck: jsr i2cStartWrite bcs WaitForI2CAck jsr i2cStopWrite Having the second write be completely ignored was driving me nuts trying to debug, and just adding a few frames of wait time didn't help for some reason.
  13. Is i2c_v2.3left.inc working correctly now? Then I would add it to my SaveKey for Dummies! thread.
  14. I never did finish this, but there was some discussion in 2600 Programming about reading the AtariVox/SaveKey from the left port or reading two at once, so I thought I'd at least upload what I have so far for reference. As I mentioned in that topic, if I picked this up again, I might use the QuadTari to switch between two of them in the right port so as not to have to have separate drivers, and not have to deal with swapping a controller out before starting the utility. copyvox.zip
  15. Updated the list (again): Added Penult, updated a couple of other Atari 2600 entries to reflect High Score saving Removed Scramble 5200 (the AtariVox doesn't support the 5200) Removed Baby Pac-Man (doesn't actually support the AtariVox/SaveKey) Cleaned up the rest of the formatting for 2600 Hacks and 7800 games That should bring it up to date. At least for the moment.
  16. Yes, Three.s uses 6 unused bytes from Boulder Dash. BTW: You can see which slots are used in Stella's debugger.
  17. That's the problem with starting a Club... sometimes you have to maintain it.
  18. Thanks - I didn't see Penult in the list, but I'll add it. I suspect there are a lot of WIPs out there just using scratchpad space right now. The list had to have been updated since May 20, 2019, because RobotWar: 2684 is listed. That didn't exist until April of 2020, and didn't get the new name until much more recently. There are other games that save data that aren't in the list either (THREE•S, and some of Seemo's games). But I suspect they may be sharing pre-existing slots. (Thomas?)
  19. Thank you for maintaining this list Nathan👍
  20. Some additional information: Penult - Save Data (Game Data) Wall Jump Ninja - Save Data (High Scores). You might also want to mention that Wall Jump Ninja 1.0 (sold on cart) can overwrite Assembloids data! [ref] This was fixed in the v1.1 release. Don't know if you also want to link to the address map as well, looks like it hasn't been updated in a while though: "Last Updated May 20, 2019" - James
  21. Updated the list (finally): Added changes listed in above comments Added programmers' names Reformatted everything in the 2600 Homebrew section (still working on the other sections) Removed: Dragon's Descent, Evil Magician Returns II, Gyvolver, Tyre Trax (none support the AtariVox or SaveKey that I can determine) Added: BitChess, Frantic, Robot City, Tower of Rubble, Indenture, Monster (renamed Outpost 26), Karate Master Needed: Links to threads/ROMs for Thrust+ Platinum and Speech Tester Please let me know if you notice any missing information or broken links. I'll finish reformatting the 2600 hacks/5200/7800 sections soonish.
  22. Yes, that's what I wanted to check first. That clumsy controller detection of R77 is really annoying. @DirtyHairy Would the situation improve if we stop using separate controllers for joysticks and paddles in the R77 kernel? Would that be worth a try? Eventually we should build a R77 image with QuadTari support for testing.
  23. That might be the case, yes. Not sure, but it may work if you first attach a joystick and only later swap to the QuadTari. This might trick the R77 controller detection. There are parts in R77 software we can fix and we cannot. I am not sure yet, but probably the latter is the case. Sounds like that, yes. That should work. Have a look at index_r77.html I haven't tested this yet. I know the 2600-daptor II(!) supports the SaveKey, but the firmware has to be flashed for this. Good idea. Given the current problems with R77, what should we do with QuadTari support here? E.g. Stella's controller auto-detection might strike. BTW: Instead of R77 OTG, you can also test via your computer. That should be about the same.
  24. Added a request issue on the R77 Github page for this: https://github.com/DirtyHairy/r77-firmware-ng/issues/4.
  25. Yeah, forgot about that part. This support is definitely not in R77 yet; it's not even in any release version of Stella yet, so you have to compile from Git. So you won't be able to test that part for now. Well, there's the detection, but also then having to specify the serial port to use within Stella itself. So it's still not automatic, and you'd need a keyboard hooked up to (1) look in "/dev" directory for the serial port, and (2) enter that into the Stella UI. I'm working on improving this in https://github.com/stella-emu/stella/issues/688, but now that I think of the R77 case, it's even more relevant. Unfortunately, we (the Stella team) were not really consulted on how this hardware was designed. Not that we needed to be, of course, but we could certainly have provided some opinions here and there that would have made the product much better suited to Stella. Or maybe not, since it probably would have cost more as a result ...
  26.  
  • Recently Browsing   0 members

    No registered users viewing this page.


×
×
  • Create New...