Jump to content

Dropcheck

Members
  • Content Count

    1,656
  • Joined

  • Last visited

Community Reputation

1,193 Excellent

2 Followers

About Dropcheck

  • Rank
    Stargunner

Contact / Social Media

Profile Information

  • Gender
    Female
  • Location
    Stigler, OK

Recent Profile Visitors

17,502 profile views
  1. Not sure if it was a design flaw in the 1088XEL since other devices prior to the Fujinet's existence worked without issue. Sometimes it's a combination of two different hardware created years apart that combine weirdly to cause conflict. The resistor fix on the SIO2PC should have corrected the issue without removal, maintaining the features of the SIO2PC . But that choice is up to you. 😏
  2. Stephen, that has no place in this forum. That is offensive to me. 😠
  3. The PBI is a 800XL/and some 600XL models only port. When the 130XE computers came out Atari changed the original 800XL PBI port somewhat, making the combined cartridge and ECI ports physically and electrically incompatible. You could usually find an adapter board that allowed most PBI devices to work on the 130XE and vise versa. But not all. On both the XEL and XLD Mytek included the 130XE version PBI which is compatible with any 130XE "PBI" device, assuming you can get it to fit in the case. On the XEL Mytek also included a mini-PBI connector, primarily for the CF3 boards. Third party device creators could also develop for the connector. The Freezer device depending on what year it was made in also came with an adapter board for 130XE computers.
  4. Please take these type of discussions to the proper thread. 🙂 There are several in the dedicated Fujinet section. Or start your own thread. This one is dedicated to hardware issues.
  5. Yes. Although I don't know if you can completely blame the 1088XEL SIO. There's also some other issues with the Fujinet regardless of what Atari computer you connect it too. Right now if you turn off the Fujinet using its own power switch, you often lose the pass through of SIO signals. So if for some reason the Fujinet is not playing nice with other SIO devices in your chain, you're only option is to completely physically disconnect it from the chain. They are working on a fix for that as I understand.
  6. The SIO-Aux only exposes 5 of the 12 needed signals for the Fujinet. It's not a simple cut and paste operation. You definitely would not like esthetics either inside or outside. Your best bet would be to use the external version of the Fujinet with a short SIO cable.
  7. Unfortunately the Fujinet requires quite a bit more circuitry and would not easily fit on the 1088XLD I/O ModSystem.
  8. The 1088XEL and 1088XLD are two very different animals. Both require the U1M and UAV boards to function in it's basic configuration. If you want to beef up your video output then you can opt for the Sophia or VBXE boards, but you will need to have a monitor that supports their output. Both the 1088XEL/XLD have the CF3 Dual CF adapters. The MultiSIO Internal Board is for the 1088XLD only. If you aren't soldering or assembling anything yourself, then the PIC-Stick programmer is not needed. The advantage of having either the XEL/XLD assembled for you is that it's all tested and verified working before shipment to you. Unless the postal service/USP service dumps it upside down or from 10-15 feet, you should be able to do a 'things loose and moving around inside' quick test and be up and running within minutes of arrival. I've worked with TBA in developing some of their offerings and can vouch for their professionalism.
  9. TTL is a logic level family, usually used to describe most older chip families even if they have a SMT as well as a DIP/SIP footprint. The Atari line of computers are most definitely in that logic family as are almost all chips powered by 5V. 'A TTL input signal is defined as "low" when between 0 V and 0.8 V with respect to the ground terminal, and "high" when between 2 V and VCC (5 V)' A bare ESP32 module operates on 3.3V, so is not directly TTL compatible. It has usually been depicted in most tutorials and youtube videos as needing logic level converters to interface with TTL logic, such as the UNO boards and other +5V devices. The RN used in the Fujinet provides a very simplistic level converter, but it's not really smart enough to handle power on/off, and when the Fujinet power is turned off acts as a load on the SIO bus, breaking the passthrough feature. It also doesn't isolate against feedback power. As far as the audio line needing to be filtered/logic level converted...... The original schematic does not have the signal going through the RN to drop voltage, instead it goes through C3/R5. I'm assuming that those two parts are doing the same thing as the RN to drop the voltage to something the ESP32 can handle. I'm not an engineer, so all I can say is that it's very possible it will need to handled by an additional isolate/buffer chip line as well. Which unfortunately takes us back to a two chip solution. Or maybe one chip and something discrete to handle the Audio In line. There are far better electronics savvy members than me that can weight in here to correct my assessment if I am materially wrong.
  10. Would this one chip solution work? The 3.3v power to the ESP32 is already switched on/off. With the R1 resistor holding the OE pin in a low state until the 3.3v is high enough and stable, the outputs are held in a high Z state, effectively disconnecting the ESP32 from the SIO bus.
  11. I see connection for the Audio, but not for Mtrl_Ctrl. On the original schematic Audio is not run through the RN, but the Mtrl_Ctrl signal is. Is that a mistake, a senior moment?
  12. At the risk of irritating people, I recommend taking these posts on recompiling the current firmware for a deprecated hardware version to the proper thread. This thread deals with the hardware, not even firmware, of the current version. Perhaps the sysop can move them to the right thread. 😔
  13. I'm not an engineer, but if you are referring to the strange SIO loading stutter, it sounds like a buffer delayed sound. Maybe the Fujinet isn't actually separated from the bus. Could the 07 chip actually be buffering both the Fujinet and the second SIO device? On another topic..... what board assembler did you use to have the Fujinet pcbs assembled?
  14. FYI I have a few items on my site that I am closing out. These items are on sale. Once they are gone I do not plan to stock or build any more. Super MMU Adapter Reimaged Ramrod XL ATX12V 1088XEL Power Adapter
×
×
  • Create New...