Jump to content

Matthias

Members
  • Content Count

    1,170
  • Joined

  • Last visited

Everything posted by Matthias

  1. Hello Guitari! In the "Controller Configuration" screen of Impulse X you need to set two things: 1) The "Rotary Device" type, in your case set this to "Amiga mouse". 2) The "Adapter" type. Unfortunately MacRorie didn't post the pinout of his PCB, but judging from the photo it seems he is following the pinout that i published in the 1990ies. So the proper setting for this adpater should be "ST M. Adapter M.Domin". A wrong combination of "Rotary Device" and "Adapter" will show the effect of "shaking" when you move the mosue, but the mouse buttons should usually work. Hope this helps Matthias
  2. Hello! FYI: Instead of OPTION, hold down 2 while booting Impulse X and you get my "Memory Track Manager Remix" loaded. It works similar to Ataris original MT Manager, but has some enhancements like displaying the content of a file or transferring it to a PC via serial connection. Browsing through the file content may help to track down the problem. Kind regards Matthias
  3. Hello! This isn't correct, the shoulder buttons of the ProController (or buttons 4 and 6 on all controllers) just work the same as Left and Right on the thumbpad, they don't have different speed values than Left and Right (however, you can combine them with C to double the basic speed). Kind regards Matthias
  4. Hello! Thanks for your feedback, it encouraged me to run another test, by removing the CD-Player. Without CD-Player the SCINV.ROM worked, then with CD-Player attached again it did not work (as before). Kind regards Matthias PS: All tests were done using a K14-PAL-Jaguar but withboth 50Hz and 60Hz.
  5. Hello! Thanks for the invitation! Too bad that SillyVenture and the Euro-Jagfest do collide again Unfortunately the SVINV.ROM doesn't work for me (black screen, no sound), i flashed it to my Skunkboard Rev 3. Regards Matthias
  6. Hello! No, HOFF and VOFF are registers of the chip, you can set them at any time. On my Lynbx-page you can find the sources for two small C-programs demonstrating the usage of both offset registers and a SCB-chain to implement a scrolling playfield: http://www.mdgames.de/lynx_eng.htm#SPRDEMO4 Kind regards Matthias
  7. Matthias

    Lightguns

    Hello, caused by a recent request of Jeffrey_bones i did some research on the internet for using lightguns with modern TVs (LED ..) and found this interesting solution: Kind regards Matthias
  8. Hello! A good choice, i am using this lib for my own SD-card project also. Kind regards Matthias
  9. Apparently Raiden doesn't switch on the video system when it is started, Atari knew about this and had to change the VLM start code to handle this problem. See Cart.S and CDBoot1.s in the VLM-sources. Kind regards Matthias
  10. Hello! Now the music is ok, probably the sfx too. But now there is a delay of almost 10 seconds between start of the ROM-image and the appearance of the title screen. The target focus isn't below of the forefinger, but left of it as it would indicate the middle of the hand. User interface: Starting a game using OPTION isn't really intuitive, neither is it to use PAUSE to leave the GameOver-screen. Best regards Matthias PS: Signatures are only visible for people who are logged in.
  11. Hello! The 3 background images are now ok (on my PAL-K-Jag with CD-Player and Rev. 3 Skunkboard), but the music/sfx is still just hissing noise Also: The game stucks after one play in the "Game Over" screen (with the ants moving around). Kind regards Matthias
  12. Hello! Last weekend i downloaded the most recent ROM-versions from there, dated Octobre 20 and Octobre 21, but both worked somehow strange. I have put them on the second bank of my Sillyventure Skunkboard, on a Jaguar K-PAL-model with 50/60 Hz-switch and CD-Player. As seen in the attached screenshots, all the background images are displayed in a funny way ("vertical interlaced") while the foreground sprites seem to be ok. The music is just a hissing sound, but reacts on the switch in the OPTION-screen. Any ideas? Kind regards Matthias
  13. Hello! For selfish reasons (*) i had to investigate this, so i had set up several Jaguars, but never had a problem with the three games mentioned above. The Skunkboard was a Rev 3 with latest firmware, the Jaguars were 1994 K-models with Toshiba and Motorola (all PAL) and a 1995 M-Model (NTSC) having Motorola chips. The PAL-consoles were tested with either 50Hz or 60Hz, one of them had the CD-Player installed, one had a BJL-Boot-ROM. So maybe Peter's downloads were corrupted? Best regards Matthias * = Peter is one of the testers of my SD-Card-adapter, so i had to find out if his problems might be caused by using my software to flash the Skunkboard.
  14. Hello! You're right. Forgot about that. So on level 1 it should be safe, then on level 8 (which is the repeat of level 1 with extra difficulty) the snake should appear. In the version that i talked about a third car was driving on that side of the highway, it always collided with the frog that was resting on the green stripe. In the newer version this car is now removed, so the frog is now safe. It's ok now As mentioned, the green zone between highway and river is ok now, but key 0 only switches the music/sfx off, this key should be implemented as a toggle. The frog always jitters (x-position) when sitting on the wood rows(from bottom to top) 1, 3 and 4, but not on row 2. Kind regards Matthias
  15. Hello! The sad thing is, that for these 'rare' things people are paying more for both the CD and the shipping costs as they would for my regular products. Unlike my Marble Madness demo for Lynx, the Jaguar version that is used there does not even have any kind of gameplay. Kind regards Matthias
  16. Hello! Ok, i have downloaded both files, although i was wondering about the big difference in file sizes: 1MB compared to 1.75 MB. Small advice: Adding a date/timestamp helps to the filenames helps a lot for later references (I.e. FROGZ64_20170806.ABS). When started, the screen stays black for a very, very long time. 5 or 6 seconds is too long, i had rebooted the Jaguar 2 times and switched from testing the ABS to the ROM before i decided to let the machine run a longer period of time. The animated Jagpad-Sprite still shows some bright pixels inside its shape. The game runs faster under 60Hz than under 50Hz. The green stripe between highway and river wasn't a save place for my frog. Neither does key 0 toggle the sound/music nor does the "* plus #" combination (aka "reset") let you leave a level. The skull sprite stays most often forever. IMHO it should disappear before the new frog appears. Kind regards Matthias
  17. Hello! You are welcome The common trick is to make a copy of the Jaguar-CD on your PC, usually the copy works better on the Jaguar, at least if the Jaguar CD is a CD-R. Matthias
  18. Hello! Seems that you were fooled by a misleading translation, sorry for this. You don't have to combine notes to play the correct melody, it's the combination of symbols that tells you which notes (piano keys) you have to play. In fact it is just one the one that you have spoken about. To make it more clear: The geometrical figures (circle, triangle, rectangle, trapeziod, etc. ) symbolize the white keys on the keyboard, the proper black keys are defined by the combination of one of the figures with a dot. So the melody shown on the plaque in the tower room requires hitting just one black key, all the other notes are white keys. Hope this helps Matthias
  19. Hello! I think this is caused by DetermineFileInfo() in JCP.C, but only if your file has the extension ".ROM". As Tursi said, the 6MB-file will be split into 2 parts, and therefore the second part will also be processed by DetermineFileInfo(), which will alter the base address to 0x802000 for headerless "files" if the file extension is ".ROM". Regards Matthias
  20. Hello! I have just uploaded a Skunkboard-specific version of my tool here http://www.mdgames.de/Memdmp12.zip This version now supports switching between Bank0, Bank1 and the 6MB (sorry for the joypad-key-mapping), i tried it out with an updated formerly Rev2-board. Interestingly you will see the behaviour that Carl has described when you browse the $c00000 adress area, but only as long you are just switching between Bank0 and Bank1. As soon as you have once switched to the 6MB-mode you will always see the first 2MBs of Bank1 shown in the browser at this adress area. Kind regards Matthias
  21. Hello, if you do have a BJL-cable (or can burn a Jaguar-CD) my E2prom-Browser might be useful for you: http://www.mdgames.de/je2prombrowser.htm Best regards Matthias
  22. It still doesn't work for me. Matthias
  23. Hello, i am not sure if it is of any help to you (because the screnshots are dark and the description is in german language only), but here is my walktrough: http://www.mdgames.de/philiawalktrough.zip Regards Matthias
×
×
  • Create New...