Jump to content

skr

+AtariAge Subscriber
  • Content Count

    959
  • Joined

  • Last visited

Everything posted by skr

  1. Maybe I´m lost in translation (no native english speaker me is ), but that´s what I meant: Machine Boots. So if he has an AtariMax Cartridge (not the programmer, just the cartridge), he can create an ATR containing the Incognito ROM with MaxFlashStudio. Open the AtariMax Cart, replace the chip with the one from the Incognito and flash it, using the ATR with a SIO device. Only thing I don´t know is, if he has an AtariMax Cart and a SIO-Device.
  2. I think he somewhere stated, that he changed something back and could make it boot. Anyway: The install is quite easy to remove, so my first step would be to go back to original config and see, if it is working. And if it does, he can attempt programming the chip, if needed. And I have to admin, that I always forget, that some people do have one Atari only, and not lots of. Sorry.
  3. I would like to buy one dust cover for the 400, two for the 800, and one for the 1200XL. You could write a little article about the covers and possibilities to create custom ones for the ABBUC magazine.
  4. If you have an AtariMax cart, you can use that one to flash the chip! No extra hardware needed. I used that several times to flash the chip of my U1MB.
  5. It depends on what you actually need and want. The "smallest" version already gives you Stereo and "frees" your original PoKey-chip (keep it, they´re getting more and more rare and expensive). This can be considered totally standard and will satisfy probably most needs of Atari users. You normally won´t miss anything when going with this version. If you like to have Covox, you should consider that option. The "big" gun is needed only, if you´re doing fancy stuff with lots of soundchannels or experimental stuff with SID emulation. So far I´m only aware of one software that can deal with more than 8 sound channels to make use of a QuadPoKey, and that is the Theta Music Composer (TMC). As @Duddie is a forum member here too, he could give you more advice on the details.
  6. I totally can recommend it. It not only gives you Stereo, but also a spare Pokey. Have it in my U1MB 800XL and so far didn´t encount any problems. Even I´m sure, soxmexonle will find some software, that doesn´t work with it.
  7. I just did a raw image of my SIO2SD card. Maybe it would be helpful for you, to put that on your card. If you want to try, let me know and I´ll send you the DropBox link.
  8. First check the Wiki: http://sio2sd.gucio.pl/wiki/SoftwareATARI_en To update the device, the BIN-file has to be in the root, not in the Atari folder. Which OS you are formatting the SD card with? I´m on Mac and have to use the Terminal, as the built in formatter has not much options.
  9. I don´t know the differences between Unocart and Ultimate Cartridge, so I´m not sure this is helpful: Converted the ROM to a Williams-CAR (with Atari800MacX) and then it runs fine on my Atari 800 XL with U1MB. Also set it to 64K Ram and bootet with LiteDOS mounted, also working fine.
  10. Thanks, @k-Pack, somehow I missed that one.
  11. Looks like I don´t have DG 3.0, so I would be interested.
  12. Don´t like the printing too, but I would love to something like that for my 400, 800s and 1200XL, too. Edit: Uh, that´s even cooler:
  13. Wow, this is working. Thank you so much! Now I´m so keen to ask one more question: It seems, that there is written a file "default.atrview" to the root, which does not work as the root is write protected: This only happens, when I try to start the FontMaker as an App (which I created with the scripteditor). Would be nice, if that file would be in another place. Anyway, starting it manually from the Terminal, it looks like I think it should:
  14. Doesn´t compile, too. I leave it for now, as I have no experience with Lazarus and this seems too complicated for me and I have more important things to do.
  15. I tried to, but get nothing than an app called "project1.app" with no windows. Maybe I´m doing it totally wrong, so here is what I tried: Installed fpc and fpcrsc with brew, respectively brew cask. (All instructions on the Lazarus project sites didn´t work, so I ended up doing it with brew) Installed Lazarus IDE. Open "Main.pas", "AtariColorSelector.pas" and "ExportWindow.pas" and started compiling, but all I get is an app "project1.app" that does nothing and has no windows. From my experience with XCode and Visual Studio I expect the file "FontMaker.dproj" to be somewhat important, but I can´t open it with Lazarus.
  16. I guess, due to the fact that the 400/800 were not sold very much in Europe, there is no big interest here for it. Especially Poland, where the mentioned manufacturers are located, was late to the game, starting in the mid 80s with the XE series. So their focus surely is not on the 400/800. An alternative would be covers made of fabric, which I have several from. But I don´t remember the source for it, will try to find it again.
  17. At least I get an Altirra window for a very short moment: Altirra_wine64.mp4
  18. Retronics (@Duddie)from Poland offers a lot of different dust covers which also come with a nice packaging. Just write to [email protected] or look for retronics on facebook. Retroventure (@grey/msb) from Poland also sells them, but currently they only have the console-covers (Jaguar, VCS) on their website: http://www.retroventure.eu/en/
  19. Ok, I will dig into this. I have no experience with Lazarus but remember that my first contact left the note "not so easy" in my mind.
  20. For stuff like this you might want to check the AtariWiki: https://atariwiki.org/wiki/Wiki.jsp?page=Action#section-Action-CARImages
  21. Nothing to do with being worse or better than something else. But with the last version-upgrade to Catalina, Apple decided to make a cut and go 64 Bit completely. That renders some software incompatible. Some retro-software I need is running fine (like Altirra) but this one and MadStudio I couldn´t make work so far. Not a personal problem for me, as I also have a Win10-Laptop for retro apps only, but I don´t like switching computers as I most of the time simply have my MacBook located next to my Ataris and do all kinds of stuff, mostly using eclipse with WUDSN IDE and Atari800MacX, on that one.
  22. As said, I´m on OS X Catalina, which does not support any 32-Bit application. So, wine doesn´t work anymore and I´m trying to make as many programs running on wine64 as possible.
  23. That looks really great, but I can´t get it running with wine64 on OS X catalina. Any chance of trying to make it run? A native OS X version would be even cooler, but as far as I can see it´s written in Delphi? Anyway, this is what I get: [email protected] Desktop % wine64 /Applications/Atari/8Bit/Mac_PC_Soft/AtariFontMaker/AtariFontMaker.exe 001b:err:ntoskrnl:ZwLoadDriver failed to create driver L"\\Registry\\Machine\\System\\CurrentControlSet\\Services\\wineusb": c0000142 000f:fixme:service:scmdatabase_autostart_services Auto-start service L"wineusb" failed to start: 1114 001f:err:display:macdrv_ChangeDisplaySettingsEx No matching mode found 1920x1200x32 @60! 0009:err:module:__wine_process_init L"Z:\\Applications\\Atari\\8Bit\\Mac_PC_Soft\\AtariFontMaker\\AtariFontMaker.exe" not supported on this system
  24. I´m having the same issue since test 4. With test7 I got this: [email protected] ~ % wine64 /Applications/Atari/Altirra-4.00-test7/Altirra64.exe /startuplog:hostui,hostdisp 001b:err:ntoskrnl:ZwLoadDriver failed to create driver L"\\Registry\\Machine\\System\\CurrentControlSet\\Services\\wineusb": c0000142 000f:fixme:service:scmdatabase_autostart_services Auto-start service L"wineusb" failed to start: 1114 001f:err:display:macdrv_ChangeDisplaySettingsEx No matching mode found 1920x1200x32 @60! [ 0.000] Windows 6.1.7601 [ 0.000] Startup logging enabled. [ 0.000] Initializing OLE. 0009:fixme:uxtheme:BufferedPaintInit Stub () [ 0.003] Initializing themes [ 0.003] Loading config var overrides [ 0.003] Loading options [ 0.003] Loading settings [ 0.004] Running instance [ 0.004] Preloading DLLs [ 0.013] Registering controls [ 0.013] Initializing frame system [ 0.013] Initializing commands and accelerators [ 0.014] Applying options [ 0.014] Initializing filespec system [ 0.014] Initializing UI panes [ 0.018] Initializing logging [ 0.018] Initializing native UI [ 0.019] Creating main window 0009:fixme:win:RegisterTouchWindow (0x1005a 00000000): stub 0009:fixme:win:UnregisterTouchWindow (0x1005a): stub 0009:fixme:win:SetGestureConfig (0x1005a 00000000 1 0x21e510 12): stub [ 0.118] Restoring main window [ 0.206] Initializing WinSock [ 0.206] Initializing simulator [ 0.211] Initializing game controllers [ 0.232] Initializing menus [ 0.581] Initializing debugger [ 0.581] Initializing compatibility system [ 0.581] Initializing display UI [ 0.690] Loading profiles [ 0.690] Loading current profile [ 0.698] Initializing native audio 0032:fixme:coreaudio:ca_channel_layout_to_channel_mask Unhandled channel 0xffffffff 0032:fixme:coreaudio:ca_channel_layout_to_channel_mask Unhandled channel 0xffffffff 0032:fixme:coreaudio:ca_channel_layout_to_channel_mask Unhandled channel 0xffffffff 0032:fixme:coreaudio:ca_channel_layout_to_channel_mask Unhandled channel 0xffffffff [ 0.935] Loading ROMs [ 0.937] Restoring pane layout 0009:fixme:win:RegisterTouchWindow (0x100b8 00000000): stub 0009:fixme:win:UnregisterTouchWindow (0x100b8): stub 0009:fixme:win:SetGestureConfig (0x100b8 00000000 1 0x21e360 12): stub [ 0.941] HOSTUI: Creating display window [ 0.943] CRASH: Code: C0000005 PC: 00000001`400BD8FE ExeBase: 00000001`40000000 [ 0.943] CRASH: [ 0] exe+000B1FCE [ 0.943] CRASH: [ 1] exe+000B1FA0 [ 0.943] CRASH: [ 2] exe+000B1FA0 Assertion failed: sz > 0, file ../../../wine/dlls/dbghelp/stabs.c, line 118
  25. When I look at all the tapes I have here (lots of), only two of them have those cases. So I would say, no, not very common. But that´s just me. I´m not representing the whole of Europe.
×
×
  • Create New...