Jump to content

Cyprian

Members
  • Content Count

    473
  • Joined

  • Last visited

Community Reputation

111 Excellent

About Cyprian

  • Rank
    Moonsweeper

Contact / Social Media

Profile Information

  • Gender
    Male

Recent Profile Visitors

7,392 profile views
  1. It means that sometime it's worth to read the manual. BTW. I've found older version http://www.atarimania.com/documents/Madmac_Ref_Man_Jan-1990.pdf Where I can find the latest one?
  2. For the last few days I was struggling with my code, which sometimes worked and sometimes it didn't Fortunately thanks to @dilinger Virtual Jaguar debugger I've just found an issue. It seems RMAC doesn't handle math correctly. Copyright (C) 199x Landon Dyer, 2011-2020 Reboot V2.0.23 Oct 24 2020 (Linux/OSX) Variables Test1 / Test2 should have the same value: nop LISTSIZE_FULL = 5 Base = $F00000 Test1 = Base + ((LISTSIZE_FULL*8)*4*4) Test2 = Base + (LISTSIZE_FULL*8)*4*4 move.l #Base,D0 move.l #Test1,D0 move.l #Test2,D0 nop nop But they don't:
  3. my hardware is in my footer: Mega ST 1 / 7800 / Portfolio / Lynx II / Jaguar / TT030 / Mega STe / 800 XL / 1040 STe / Falcon030 / 65 XE / 520 STm
  4. actually the connection is stable, I'm able to reset the Jag with jcp -r I need to investigate that issue further, but it seems that banging Sunkboard with skunkCONSOLEWRITE can sometimes screw it.
  5. I have Skunkboard v2 (Sillyventure version) and I have faced a problem with skunkCONSOLEWRITE. After few jcp "run from ram" times following code causes a red screen after Jag reset ( "jcp -r") bsr skunkRESET lea Napis,A0 bsr skunkCONSOLEWRITE lea Napis,A0 bsr skunkCONSOLEWRITE Below My Skunk rom and jcp version: jcp v02.04.02 built on Jul 10 2016 Boot version 03.00.02, Serial 6510 Should I upgrade jcp and Skunk rom?
  6. I do code on the real Jag, but in the first step I use VJ. I have Skunkboard, unfortunately it isn't stable enough - I observed that after using a few skunkCONSOLEWRITE in a row, when I do a reset with "JCP -r" I have a red screen with "Jaguar" logo and JCP is not able to connect to the Jag
  7. I've faced the same issue. I have code witch works under VJ and doesn't under Jaguar. Would be cool to have equivalent of skunkCONSOLEWRITE (debug print just to DOS text console) in Virtual Jaguar. It would allow me to compare debug output for both Jagaur and VJ.
  8. IMO most common configuration is 1040 ST with 1MB ram next is 1040 STe with 4MB (because easy way to expand RAM)
  9. There is a comment by Drygol on April 1, in which he mentioned they should be available this week. https://atarionline.pl/v01/index.php?subaction=showfull&id=1611412343&archive=&start_from=0&ucat=1,9&ct=nowinki
  10. There is a new USB adapter for the ST: mouSTer https://retrohax.net/the-mouster-project-is-here/ Works fine and it's firmware is regularly updated. And it's small what is important in case of the 1040 (I have mouSTer which fits perfectly and a second adapter from other vendor which is a bit to long for my 1040)
  11. ok, maybe it is my ISP issue, but I still have no access to it
×
×
  • Create New...