Jump to content

lwizardl

Members
  • Content Count

    103
  • Joined

  • Last visited

Community Reputation

24 Excellent

About lwizardl

  • Rank
    Chopper Commander
  • Birthday 08/29/1980

Profile Information

  • Gender
    Male
  • Location
    Battle Creek, Michigan

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. if you was closer I would grab the monitor but totally opposite sides of the country
  2. I know a few that when they try to repair board game or toy boxes they often use water activated gum tape to tape the inside of the box for added strength.
  3. I bought one, but sadly I think it got damaged from the wrong power supply. I opened it up tonight and I do not see any damage to it but I am not getting any video at all from it, but my system does get power because the led light is on.
  4. just got in the 2 power cables from masschamber, going to order some 7805 voltage regulators and see if I can repair the system and av box, if not I have a replacement bottom shell coming that I will do the video and power mod to
  5. Awesome! Looking forward to finally being able to play the 5200 after owning it since like 2016 hehe. Next will be the test of do my 3 controllers work
  6. can you verify they are working if so I will take 2 so I have a known working spare
  7. okay then I have some repair work to do then, because I tried it the day it arrived but didn't notice anything. Guess I will have more work to do Looks like it is for the Atari computer line for sure, says CO17945 for 400/800/1200XL Computer & 822, 850, 1010, 1020, 810/1050/XF551 Drives Power Supply
  8. Yup I'm going to use that new bottom to do the video mod for it, but I still am not sure if the power cable I have is the correct one or if working. Bought all 3 items (system,av, power) on ebay listed as working but we all know that is not always true that they are working. Added picture of the 5200 power supply and av box that i have so far
  9. I have an Atari 5200 system that I have owned for about 4 years now and never ben able to play any games for it. I recently bought a Power Supply and av box for the 4 player system and get nothing from them or the system. I have tried about 5 different games and same results. I am thinking either I have 1) Bad AV box 2) Bad Power Supply 3) Bad system 4) all of the above. So I am looking to buy a confirmed working av box and power supply for my system, I currently do not want to av and power mod the system but I know that will be a future solution if I can not find working cables for them. I own 3 controllers for the system but can not tell if those are working or not yet because I can not get the system working. Shipping to Michigan
  10. this would be perfect for me to do av mod on my system, sending pm
  11. I would be interested in Call of Cthulhu I'll send you a pm
  12. those are both great movies, that should go fast I think
  13. Yup still around but just not much time for gaming lately
×
×
  • Create New...