Jump to content

metarog

Members
  • Content Count

    324
  • Joined

  • Last visited

Everything posted by metarog

  1. Here you go. Let me know if you need anything else.
  2. Ok, I’ll try to get that done tomorrow.
  3. Which ones are still needed? I e got a new scanner now.
  4. Great deal! Fair warning though. O2 collecting can be addictive. Good luck getting all the Hybrid games. They can be a challenge to set up and play correctly but have a certain charm all their own.
  5. As long as the voltage and amps are similar any male tip power supply should work. I believe an Atari 2600 should be compatible. The O2 has a bridge rectifier so anywhere around 9 to 12V and around 500 amps should be ok.
  6. Yes, open up the bottom cover and there is a little switch on the silver RF module in the upper right.
  7. My scanner is busted. Would close up IPhone pics work?
  8. I have a complete set of O2 Games, boxes and manuals. However I haven’t used my scanner in years. I’ll give Atlantis a go tomorrow.
  9. I too am anxious to play this. I hope all is well with the project and people.
  10. Do you mean the disc on the bottom or the top shell?
  11. You should get a video signal with some random blocks and figures. of you are not getting power I would check the voltage regulator first as that can fail over time.
  12. Not the backlight issue. It could be the ribbon cable that connects backlight to the power is not properly seated. I’d check that first just in case.
  13. The one with the dual tips works with either the barrel or straight tip O2s. I think the earlier models used male AC plugs and the newer used female. The Voice does not need its own power supply you are correct.
  14. I saw the Astrocade either at Sears or Lionel Play World. It was something I wanted but the parents thought it was too expensive.
  15. It took about 6 months to track them all down. I got them all through this forum and a few others. That was over 5 years ago though so they may be tougher to find now.
  16. Ive run across this problem a few times but the culprit is usually the membrane keyboard. Ive had a few dozen 02s and about a quarter of them had keyboard issues. Im not saying it cant be the chips but in my experience the keyboard is the likely problem.
  17. The only one I recall shrink wrapped was Computer Intro as it had that thick manual.
  18. Well it was worth a shot. I looked around but none of my boards have any of those chips.
  19. It is the 8244 Audio Video chip. You will probably have to pull it from another O2. Ill check to see if I have an extra one. Ive already sold 2 of them in the past. I havent heard of that issue and mod but if you do find out please let us know.
  20. You can try swapping out the two socked chips on the motherboard. They are the 8048 and the one right below it. These chips do go bad from time to time.
  21. Well this may be the case of good timing here. I recently moved and just found my O2 spare parts box. Inside was a male tip O2 AC adapter. I tested it in my fluke and you can see the reading. Let me know if you want this. Im in the U.S. so if you are too shoot me an offer and I can send it out to you.
  22. It might be bad Controller chips or a broken trace from the chips to the controllers. Take a close look on the motherboard and see if there is any corrosion or damage between the controller inputs and the chips.
  23. It seems that either there is a crack in the interior of one of the connecting ribbons or the screen itself went bad. Ive had both things happen to me before as Ive had 6 Zodiacs over the years. There is someone selling a display model on EBay and that might be your best bet for a cheap screen replacement and/or ribbon change. Sorry I couldnt be of more help.
  24. Try taking the back panel off (you will need a small torx but) and press in the ribbon that goes to the tapwave circuit board. They have connections under these little brown plastic tabs. I had a similar issue and one if those ribbons had come loose.
×
×
  • Create New...